]> git.pld-linux.org Git - packages/kernel.git/commitdiff
up to 6.4.8 auto/th/kernel-6.4.8-1
authorJan Palus <atler@pld-linux.org>
Thu, 3 Aug 2023 15:08:37 +0000 (17:08 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 3 Aug 2023 15:08:37 +0000 (17:08 +0200)
atheros-disallow-retrain-nongen1-pcie.patch
kernel.spec

index c3bec28b0c2072c7f037bcdbfc8cc1b6fff3350e..76562e04d7059c8fa1ce30a645ab4372831aaf98 100644 (file)
@@ -143,12 +143,10 @@ Changes since v2:
  include/linux/pci.h     |  2 ++
  3 files changed, 77 insertions(+), 8 deletions(-)
 
-diff --git a/drivers/pci/pcie/aspm.c b/drivers/pci/pcie/aspm.c
-index ac0557a305af..729b0389562b 100644
---- a/drivers/pci/pcie/aspm.c
-+++ b/drivers/pci/pcie/aspm.c
-@@ -192,12 +192,56 @@ static void pcie_clkpm_cap_init(struct pcie_link_state *link, int blacklist)
-       link->clkpm_disable = blacklist ? 1 : 0;
+--- linux-6.4/drivers/pci/pcie/aspm.c.orig     2023-08-03 14:40:42.800427402 +0200
++++ linux-6.4/drivers/pci/pcie/aspm.c  2023-08-03 14:44:34.622963310 +0200
+@@ -210,6 +210,44 @@
+       return -ETIMEDOUT;
  }
  
 +static int pcie_downgrade_link_to_gen1(struct pci_dev *parent)
@@ -189,11 +187,12 @@ index ac0557a305af..729b0389562b 100644
 +      return 0;
 +}
 +
- static bool pcie_retrain_link(struct pcie_link_state *link)
+ static int pcie_retrain_link(struct pcie_link_state *link)
  {
        struct pci_dev *parent = link->pdev;
-       unsigned long end_jiffies;
-       u16 reg16;
+@@ -226,6 +264,12 @@
+       if (rc)
+               return rc;
  
 +      if ((link->downstream->dev_flags & PCI_DEV_FLAGS_NO_RETRAIN_LINK_WHEN_NOT_GEN1) &&
 +          pcie_downgrade_link_to_gen1(parent)) {
index 0e22d6790a0421699e83aad1caf32c0d05800bf6..60a87036af5ae42f1e3ce55a4111832abbf3640c 100644 (file)
@@ -67,7 +67,7 @@
 
 %define                rel             1
 %define                basever         6.4
-%define                postver         .7
+%define                postver         .8
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -121,7 +121,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v6.x/linux-%{basever}.tar.xz
 # Source0-md5: bb65b2232cf596e7044c56a7c4205f51
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v6.x/patch-%{version}.xz
-# Patch0-md5:  046bacd50640ca59ac77c89c9fbf50f5
+# Patch0-md5:  f67eada44b3634361a2b25127b0a8161
 %endif
 Source1:       kernel.sysconfig
 
This page took 2.930214 seconds and 4 git commands to generate.