]> git.pld-linux.org Git - packages/kernel.git/commitdiff
up to 6.6.5
authorJan Palus <atler@pld-linux.org>
Fri, 8 Dec 2023 13:00:20 +0000 (14:00 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 8 Dec 2023 13:00:20 +0000 (14:00 +0100)
kernel.spec
neighbour-randomize-layout-crash.patch [deleted file]

index a12399e155ee8aa1928b5a1cb3df4dc1fe1ae301..c526005310669f3c7d590dad7283111d5c16fb83 100644 (file)
@@ -59,9 +59,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             1
 %define                basever         6.6
-%define                postver         .4
+%define                postver         .5
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -115,7 +115,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v6.x/linux-%{basever}.tar.xz
 # Source0-md5: 452098d80ba925af3a4ab35998f3aef5
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v6.x/patch-%{version}.xz
-# Patch0-md5:  0d2c1c3ef1c023d9c5f34d19eaad4cb0
+# Patch0-md5:  16bc0dc7e680a14817eab74a28267620
 %endif
 Source1:       kernel.sysconfig
 
@@ -192,8 +192,6 @@ Patch8002:  atheros-disallow-retrain-nongen1-pcie.patch
 Patch8004:     ath-regd.patch
 Patch8005:     rkvdec-hevc.patch
 
-Patch9000:     neighbour-randomize-layout-crash.patch
-
 URL:           https://www.kernel.org/
 AutoReqProv:   no
 BuildRequires: /sbin/depmod
@@ -623,8 +621,6 @@ cd linux-%{basever}
 %patch8005 -p1
 %endif
 
-%patch9000 -p1
-
 %if %{with rt}
 %patch500 -p1
 rm -f localversion-rt
diff --git a/neighbour-randomize-layout-crash.patch b/neighbour-randomize-layout-crash.patch
deleted file mode 100644 (file)
index 1650e8c..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-From 6ebf707e10dee4d186e46e414fe6d923e60e1aae Mon Sep 17 00:00:00 2001
-From: Sasha Levin <sashal@kernel.org>
-Date: Sat, 25 Nov 2023 15:33:58 -0600
-Subject: neighbour: Fix __randomize_layout crash in struct neighbour
-
-From: Gustavo A. R. Silva <gustavoars@kernel.org>
-
-[ Upstream commit 45b3fae4675dc1d4ee2d7aefa19d85ee4f891377 ]
-
-Previously, one-element and zero-length arrays were treated as true
-flexible arrays, even though they are actually "fake" flex arrays.
-The __randomize_layout would leave them untouched at the end of the
-struct, similarly to proper C99 flex-array members.
-
-However, this approach changed with commit 1ee60356c2dc ("gcc-plugins:
-randstruct: Only warn about true flexible arrays"). Now, only C99
-flexible-array members will remain untouched at the end of the struct,
-while one-element and zero-length arrays will be subject to randomization.
-
-Fix a `__randomize_layout` crash in `struct neighbour` by transforming
-zero-length array `primary_key` into a proper C99 flexible-array member.
-
-Fixes: 1ee60356c2dc ("gcc-plugins: randstruct: Only warn about true flexible arrays")
-Closes: https://lore.kernel.org/linux-hardening/20231124102458.GB1503258@e124191.cambridge.arm.com/
-Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
-Reviewed-by: Kees Cook <keescook@chromium.org>
-Tested-by: Joey Gouly <joey.gouly@arm.com>
-Link: https://lore.kernel.org/r/ZWJoRsJGnCPdJ3+2@work
-Signed-off-by: Paolo Abeni <pabeni@redhat.com>
-Signed-off-by: Sasha Levin <sashal@kernel.org>
----
- include/net/neighbour.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/net/neighbour.h b/include/net/neighbour.h
-index 07022bb0d44d4..0d28172193fa6 100644
---- a/include/net/neighbour.h
-+++ b/include/net/neighbour.h
-@@ -162,7 +162,7 @@ struct neighbour {
-       struct rcu_head         rcu;
-       struct net_device       *dev;
-       netdevice_tracker       dev_tracker;
--      u8                      primary_key[0];
-+      u8                      primary_key[];
- } __randomize_layout;
- struct neigh_ops {
--- 
-2.42.0
-
This page took 0.948912 seconds and 4 git commands to generate.