]> git.pld-linux.org Git - packages/kde4-umbrello.git/blob - kde4-umbrello.spec
- new, based on kde4-kdesdk
[packages/kde4-umbrello.git] / kde4-umbrello.spec
1 #
2 # TODO:
3 # - add man files
4 #
5 %define         orgname         umbrello
6 %define         _state          stable
7 %define         qtver           4.8.1
8
9 Summary:        UML Modeler
10 Summary(pl.UTF-8):      Modeler UML
11 Name:           kde4-%{orgname}
12 Version:        4.12.0
13 Release:        1
14 License:        GPL
15 Group:          X11/Development/Tools
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  97b2f51d76b71f6f4efe98a1ee1b76ee
18 URL:            http://www.kde.org/
19 BuildRequires:  QtNetwork-devel >= %{qtver}
20 BuildRequires:  QtScriptTools-devel >= %{qtver}
21 BuildRequires:  automoc4 >= 0.9.88
22 BuildRequires:  boost-devel
23 BuildRequires:  bzip2-devel
24 BuildRequires:  cmake >= 2.8.0
25 BuildRequires:  db-devel
26 BuildRequires:  docbook-dtd42-xml
27 BuildRequires:  docbook-style-xsl
28 BuildRequires:  gettext-devel
29 BuildRequires:  hunspell-devel
30 BuildRequires:  kde4-kdebase-devel >= %{version}
31 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
32 BuildRequires:  libxml2-devel
33 BuildRequires:  libxslt-devel
34 BuildRequires:  qca-devel >= 2.0.0
35 BuildRequires:  qt4-build >= %{qtver}
36 BuildRequires:  qt4-qmake >= %{qtver}
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.600
39 BuildRequires:  shared-mime-info
40 BuildRequires:  utempter-devel
41 BuildRequires:  xorg-lib-libXpm-devel
42 BuildRequires:  xorg-lib-libXtst-devel
43 Obsoletes:      kde4-kdesdk-%{orgname}
44 Obsoletes:      umbrello
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Umbrello UML Modeller is a UML diagram tool that can support you in
49 the software development process. Especially during the analysis and
50 design phases of this process, Umbrello UML Modeller will help you to
51 get a high quality product. UML can also be used to document your
52 software designs to help you and your fellow developers.
53
54 UML is the diagramming language used to describing such models. You
55 can represent your ideas in UML using different types of diagrams.
56 Umbrello UML Modeller 1.2 supports the following types:
57 - class Diagram
58 - sequence Diagram
59 - collaboration Diagram
60 - use Case Diagram
61 - state Diagram
62 - activity Diagram
63 - component Diagram
64
65 %description -l pl.UTF-8
66 Modeler UML Umbrello to narzędzie do diagramów UML pomagające w
67 procesie tworzenia oprogramowania. Szczególnie podczas etapów analizy
68 i projektowania, modeler UML Umbrello może pomóc w uzyskaniu wysokiej
69 jakości produktu. UML może być używany do dokumentowania projektu
70 programu, aby pomóc programiście i jego współpracownikom.
71
72 UML to język diagramów używany do opisu takich modeli. Można
73 przedstawiać idee w UML-u przy użyciu różnych rodzajów diagramów.
74 Modeler UML Umbrello 1.2 obsługuje następujące rodzaje:
75  - diagram klas
76  - diagram sekwencji
77  - diagram współpracy
78  - diagram przypadków użycia
79  - diagram stanów
80  - diagram aktywności
81  - diagram składników.
82
83 %prep
84 %setup -q -n %{orgname}-%{version}
85
86 %build
87 install -d build
88 cd build
89 %cmake \
90         ../
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT{%{_gimpdir}/palettes,%{_appdefsdir}}
98
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT \
101         kde_htmldir=%{_kdedocdir}
102
103 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/locolor
104
105 %find_lang      %{orgname}      --with-kde
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files -f %{orgname}.lang
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_bindir}/umbrello
113 %{_datadir}/apps/umbrello
114 %{_desktopdir}/kde4/umbrello.desktop
115 %{_iconsdir}/*/*x*/*/umbrello*.*
116 %{_iconsdir}/*/*/mimetypes/application-x-uml.png
117 %{_iconsdir}/hicolor/scalable/apps/umbrello.svgz
This page took 0.071432 seconds and 3 git commands to generate.