]> git.pld-linux.org Git - packages/kde4-kopete.git/commitdiff
- added qt patch (fix QList::contains() result usage)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 28 Jul 2021 21:11:09 +0000 (23:11 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 28 Jul 2021 21:11:09 +0000 (23:11 +0200)
kde4-kopete-qt.patch [new file with mode: 0644]
kde4-kopete.spec

diff --git a/kde4-kopete-qt.patch b/kde4-kopete-qt.patch
new file mode 100644 (file)
index 0000000..7bb5e0a
--- /dev/null
@@ -0,0 +1,11 @@
+--- kopete-4.14.3/protocols/jabber/libiris/src/xmpp/xmpp-im/filetransfer.cpp.orig      2014-11-02 12:16:53.000000000 +0100
++++ kopete-4.14.3/protocols/jabber/libiris/src/xmpp/xmpp-im/filetransfer.cpp   2021-07-28 21:45:47.394356452 +0200
+@@ -430,7 +430,7 @@ FileTransfer *FileTransferManager::takeI
+ bool FileTransferManager::isActive(const FileTransfer *ft) const
+ {
+-      return d->list.contains(const_cast<FileTransfer*>(ft)) > 0;
++      return d->list.contains(const_cast<FileTransfer*>(ft));
+ }
+ void FileTransferManager::setDisabled(const QString &ns, bool state)
index 9e789d8320d807077cf6fc0273f4d333910f0c2f..f27a69d8e964798964ddc1d078244e4ac4fbaca1 100644 (file)
@@ -19,6 +19,7 @@ Patch1:               linphone-fix.patch
 Patch2:                mediastreamer.patch
 Patch3:                gcc6.patch
 Patch4:                macros.patch
+Patch5:                %{name}-qt.patch
 URL:           http://www.kde.org/
 BuildRequires: automoc4
 BuildRequires: cmake >= 2.8.0
@@ -226,6 +227,7 @@ do kopete.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 install -d build
This page took 0.352631 seconds and 4 git commands to generate.