]> git.pld-linux.org Git - packages/kde4-kolf.git/blob - kde4-kolf.spec
- rebuild for g++ ABI changes
[packages/kde4-kolf.git] / kde4-kolf.spec
1 %define         _state          stable
2 %define         orgname         kolf
3 %define         qtver           4.8.0
4
5 Summary:        Miniature golf for KDE
6 Summary(pl.UTF-8):      Mini golf
7 Name:           kde4-%{orgname}
8 Version:        4.14.3
9 Release:        2
10 License:        GPL
11 Group:          X11/Applications/Games
12 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  afd71b975549e1022e99b7650798c82a
14 BuildRequires:  automoc4 >= 0.9.88
15 BuildRequires:  cmake >= 2.8.0
16 BuildRequires:  kde4-kdelibs-devel >= %{version}
17 BuildRequires:  kde4-libkdegames-devel >= %{version}
18 BuildRequires:  qt4-build >= %{qtver}
19 BuildRequires:  qt4-qmake >= %{qtver}
20 BuildRequires:  rpmbuild(macros) >= 1.600
21 Obsoletes:      kde4-kdegames-%{orgname}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Kolf is a miniature golf game with block graphics and a 2D top-down
26 view. Courses are dynamic, and up to 10 people can play at once in
27 competition.
28
29 %description -l pl.UTF-8
30 Kolf to miniaturowa gra w golfa z blokowa grafiką i dwuwymiarowym
31 widokiem. Rundy są dynamiczne, a w zawodach może grać do 10 osób
32 naraz.
33
34 %prep
35 %setup -q -n %{orgname}-%{version}
36
37 %build
38 install -d build
39 cd build
40 %cmake \
41         ../
42
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} -C build install \
49         DESTDIR=$RPM_BUILD_ROOT \
50         kde_htmldir=%{_kdedocdir}
51
52 install -d $RPM_BUILD_ROOT/var/games
53 # remove locolor icons
54 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/locolor
55
56 %find_lang %{orgname}   --with-kde
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post                   -p /sbin/ldconfig
62 %postun                 -p /sbin/ldconfig
63
64 %files -f %{orgname}.lang
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{_bindir}/kolf
67 %attr(755,root,root) %{_libdir}/libkolfprivate.so.*.*.*
68 %attr(755,root,root) %ghost %{_libdir}/libkolfprivate.so.?
69 %{_desktopdir}/kde4/kolf.desktop
70 %{_datadir}/apps/kolf
71 %{_iconsdir}/*/*/apps/kolf.png
This page took 0.072385 seconds and 3 git commands to generate.