]> git.pld-linux.org Git - packages/ka5-poxml.git/blob - ka5-poxml.spec
rebuild with qt5-5.15.6
[packages/ka5-poxml.git] / ka5-poxml.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.08.1
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          poxml
8 Summary:        poxml
9 Name:           ka5-%{kaname}
10 Version:        22.08.1
11 Release:        2
12 License:        GPL
13 Group:          X11/Applications/Editors
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  98d8c3cbc3d4c64f17b8fdc2ff9bb38c
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel
18 BuildRequires:  Qt5Xml-devel
19 BuildRequires:  gettext-devel
20 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
21 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
22 BuildRequires:  ninja
23 BuildRequires:  qt5-build >= %{qtver}
24 BuildRequires:  shared-mime-info
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Translates DocBook XML files using gettext po files.
29
30 %description -l pl.UTF-8
31 poxml tłumaczy pliki DocBook XML korzystając z plików .po gettexta.
32
33 %prep
34 %setup -q -n %{kaname}-%{version}
35
36 %build
37 install -d build
38 cd build
39 %cmake \
40         -G Ninja \
41         %{!?with_tests:-DBUILD_TESTING=OFF} \
42         -DHTML_INSTALL_DIR=%{_kdedocdir} \
43         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
44         ..
45 %ninja_build
46
47 %if %{with tests}
48 ctest
49 %endif
50
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %ninja_install -C build
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/po2xml
62 %attr(755,root,root) %{_bindir}/split2po
63 %attr(755,root,root) %{_bindir}/swappo
64 %attr(755,root,root) %{_bindir}/xml2pot
65 %{_mandir}/ca/man1/po2xml.1*
66 %{_mandir}/ca/man1/split2po.1.*
67 %{_mandir}/ca/man1/swappo.1.*
68 %{_mandir}/ca/man1/xml2pot.1.*
69 %{_mandir}/da/man1/po2xml.1.*
70 %{_mandir}/da/man1/split2po.1.*
71 %{_mandir}/da/man1/swappo.1.*
72 %{_mandir}/da/man1/xml2pot.1.*
73 %{_mandir}/de/man1/po2xml.1.*
74 %{_mandir}/de/man1/split2po.1.*
75 %{_mandir}/de/man1/swappo.1.*
76 %{_mandir}/de/man1/xml2pot.1.*
77 %{_mandir}/es/man1/po2xml.1.*
78 %{_mandir}/es/man1/split2po.1.*
79 %{_mandir}/es/man1/swappo.1.*
80 %{_mandir}/es/man1/xml2pot.1.*
81 %{_mandir}/et/man1/split2po.1.*
82 %{_mandir}/fr/man1/po2xml.1.*
83 %{_mandir}/fr/man1/split2po.1.*
84 %{_mandir}/fr/man1/swappo.1.*
85 %{_mandir}/fr/man1/xml2pot.1.*
86 %{_mandir}/gl/man1/po2xml.1.*
87 %{_mandir}/gl/man1/split2po.1.*
88 %{_mandir}/gl/man1/swappo.1.*
89 %{_mandir}/gl/man1/xml2pot.1.*
90 %{_mandir}/it/man1/po2xml.1.*
91 %{_mandir}/it/man1/split2po.1.*
92 %{_mandir}/it/man1/swappo.1.*
93 %{_mandir}/it/man1/xml2pot.1.*
94 %{_mandir}/man1/po2xml.1.*
95 %{_mandir}/man1/split2po.1.*
96 %{_mandir}/man1/swappo.1.*
97 %{_mandir}/man1/xml2pot.1.*
98 %{_mandir}/nl/man1/po2xml.1.*
99 %{_mandir}/nl/man1/split2po.1.*
100 %{_mandir}/nl/man1/swappo.1.*
101 %{_mandir}/nl/man1/xml2pot.1.*
102 %{_mandir}/pt/man1/po2xml.1.*
103 %{_mandir}/pt/man1/split2po.1.*
104 %{_mandir}/pt/man1/swappo.1.*
105 %{_mandir}/pt/man1/xml2pot.1.*
106 %{_mandir}/pt_BR/man1/po2xml.1.*
107 %{_mandir}/pt_BR/man1/split2po.1.*
108 %{_mandir}/pt_BR/man1/swappo.1.*
109 %{_mandir}/pt_BR/man1/xml2pot.1.*
110 %{_mandir}/ru/man1/po2xml.1.*
111 %{_mandir}/ru/man1/split2po.1.*
112 %{_mandir}/ru/man1/swappo.1.*
113 %{_mandir}/ru/man1/xml2pot.1.*
114 %{_mandir}/sv/man1/po2xml.1.*
115 %{_mandir}/sv/man1/split2po.1.*
116 %{_mandir}/sv/man1/swappo.1.*
117 %{_mandir}/sv/man1/xml2pot.1.*
118 %{_mandir}/uk/man1/po2xml.1.*
119 %{_mandir}/uk/man1/split2po.1.*
120 %{_mandir}/uk/man1/swappo.1.*
121 %{_mandir}/uk/man1/xml2pot.1.*
This page took 0.095591 seconds and 4 git commands to generate.