]> git.pld-linux.org Git - packages/ka5-libkexiv2.git/blob - ka5-libkexiv2.spec
- updated to 23.08.5
[packages/ka5-libkexiv2.git] / ka5-libkexiv2.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 %define         kdeappsver      23.08.5
6 %define         kframever       5.94.0
7 %define         qtver           5.15.2
8 %define         kaname          libkexiv2
9 Summary:        libkexiv2 - KDE Exiv2 wrapper
10 Summary(pl.UTF-8):      libexiv2 - obudowanie Exiv2 dla KDE
11 Name:           ka5-%{kaname}
12 Version:        23.08.5
13 Release:        1
14 License:        GPL v2+/LGPL v2.1+
15 Group:          X11/Applications
16 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
17 # Source0-md5:  fbb745604cccbec99980cd702eb50684
18 URL:            https://kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Gui-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.20
22 BuildRequires:  exiv2-devel >= 0.24
23 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
24 BuildRequires:  ninja
25 BuildRequires:  qt5-build >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  shared-mime-info
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Libkexiv2 is a wrapper around Exiv2.
34
35 %description -l pl.UTF-8
36 Libkexiv2 jest wraperem wokół Exiv2.
37
38 %package devel
39 Summary:        Header files for %{kaname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kaname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kaname}.
49
50 %prep
51 %setup -q -n %{kaname}-%{version}
52
53 %build
54 %cmake \
55         -B build \
56         -G Ninja \
57         %{!?with_tests:-DBUILD_TESTING=OFF} \
58         -DHTML_INSTALL_DIR=%{_kdedocdir} \
59         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
60 %ninja_build -C build
61
62 %if %{with tests}
63 ctest --test-dir build
64 %endif
65
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %ninja_install -C build
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_libdir}/libKF5KExiv2.so.5.*.*
81 %{_libdir}/libKF5KExiv2.so.15.*.*
82 %{_datadir}/qlogging-categories5/libkexiv2.categories
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_libdir}/libKF5KExiv2.so
87 %{_includedir}/KF5/KExiv2
88 %{_libdir}/cmake/KF5KExiv2
This page took 0.106017 seconds and 4 git commands to generate.