]> git.pld-linux.org Git - packages/ka5-konsole.git/blob - ka5-konsole.spec
- updated to 23.08.2
[packages/ka5-konsole.git] / ka5-konsole.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.2
5 %define         qtver           5.15.2
6 %define         kf5ver          5.71.0
7 %define         kaname          konsole
8 Summary:        KDE Terminal Emulator
9 Name:           ka5-%{kaname}
10 Version:        23.08.2
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  5cd9724bc52d0a9c99035d3693452bcd
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5DBus-devel >= %{qtver}
19 BuildRequires:  Qt5PrintSupport-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.20
22 BuildRequires:  kf5-extra-cmake-modules >= %{kf5ver}
23 BuildRequires:  kf5-kbookmarks-devel >= %{kf5ver}
24 BuildRequires:  kf5-kconfig-devel >= %{kf5ver}
25 BuildRequires:  kf5-kconfigwidgets-devel >= %{kf5ver}
26 BuildRequires:  kf5-kcoreaddons-devel >= %{kf5ver}
27 BuildRequires:  kf5-kcrash-devel >= %{kf5ver}
28 BuildRequires:  kf5-kdbusaddons-devel >= %{kf5ver}
29 BuildRequires:  kf5-kdoctools-devel >= %{kf5ver}
30 BuildRequires:  kf5-kglobalaccel-devel >= %{kf5ver}
31 BuildRequires:  kf5-kguiaddons-devel >= %{kf5ver}
32 BuildRequires:  kf5-ki18n-devel >= %{kf5ver}
33 BuildRequires:  kf5-kiconthemes-devel >= %{kf5ver}
34 BuildRequires:  kf5-kio-devel >= %{kf5ver}
35 BuildRequires:  kf5-knewstuff-devel >= %{kf5ver}
36 BuildRequires:  kf5-knotifications-devel >= %{kf5ver}
37 BuildRequires:  kf5-knotifyconfig-devel >= %{kf5ver}
38 BuildRequires:  kf5-kparts-devel >= %{kf5ver}
39 BuildRequires:  kf5-kpty-devel >= %{kf5ver}
40 BuildRequires:  kf5-kservice-devel >= %{kf5ver}
41 BuildRequires:  kf5-ktextwidgets-devel >= %{kf5ver}
42 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kf5ver}
43 BuildRequires:  kf5-kwindowsystem-devel >= %{kf5ver}
44 BuildRequires:  kf5-kxmlgui-devel >= %{kf5ver}
45 BuildRequires:  libstdc++-devel >= 6:8
46 BuildRequires:  ninja
47 BuildRequires:  qt5-build >= %{qtver}
48 BuildRequires:  rpmbuild(macros) >= 1.736
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xorg-lib-libX11-devel
51 BuildRequires:  xz
52 Requires:       Qt5Core >= %{qtver}
53 Requires:       Qt5DBus >= %{qtver}
54 Requires:       Qt5PrintSupport >= %{qtver}
55 Requires:       Qt5Widgets >= %{qtver}
56 Requires:       kf5-kbookmarks >= %{kf5ver}
57 Requires:       kf5-kconfig >= %{kf5ver}
58 Requires:       kf5-kconfigwidgets >= %{kf5ver}
59 Requires:       kf5-kcoreaddons >= %{kf5ver}
60 Requires:       kf5-kcrash >= %{kf5ver}
61 Requires:       kf5-kdbusaddons >= %{kf5ver}
62 Requires:       kf5-kglobalaccel >= %{kf5ver}
63 Requires:       kf5-kguiaddons >= %{kf5ver}
64 Requires:       kf5-ki18n >= %{kf5ver}
65 Requires:       kf5-kiconthemes >= %{kf5ver}
66 Requires:       kf5-kio >= %{kf5ver}
67 Requires:       kf5-knewstuff >= %{kf5ver}
68 Requires:       kf5-knotifications >= %{kf5ver}
69 Requires:       kf5-knotifyconfig >= %{kf5ver}
70 Requires:       kf5-kparts >= %{kf5ver}
71 Requires:       kf5-kpty >= %{kf5ver}
72 Requires:       kf5-kservice >= %{kf5ver}
73 Requires:       kf5-ktextwidgets >= %{kf5ver}
74 Requires:       kf5-kwidgetsaddons >= %{kf5ver}
75 Requires:       kf5-kwindowsystem >= %{kf5ver}
76 Requires:       kf5-kxmlgui >= %{kf5ver}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 Konsole is a terminal emulator.
81
82 Features
83
84 • Tabs • Multiple profiles • Silence and Activity monitoring •
85 Bookmark support • Searching • Saving output
86
87 %description -l pl.UTF-8
88 Konsole jest emulatorem terminala.
89
90 Cechy
91
92 • Karty • Wiele profili • Monitoring ciszy i aktywności •
93 Zakładki • Szukanie • Zapisywanie danych wyjściowych
94
95 %prep
96 %setup -q -n %{kaname}-%{version}
97
98 %build
99 %cmake \
100         -B build \
101         -G Ninja \
102         %{!?with_tests:-DBUILD_TESTING=OFF} \
103         -DHTML_INSTALL_DIR=%{_kdedocdir} \
104         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
105 %ninja_build -C build
106
107 %if %{with tests}
108 ctest --test-dir build
109 %endif
110
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %ninja_install -C build
115
116 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,zh_CN}
117
118 # not supported by glibc yet
119 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ie
120
121 %find_lang %{kaname} --all-name --with-kde
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f %{kaname}.lang
130 %defattr(644,root,root,755)
131 /etc/xdg/konsolerc
132 %attr(755,root,root) %{_bindir}/konsole
133 %attr(755,root,root) %{_bindir}/konsoleprofile
134 %ghost %{_libdir}/libkonsoleprivate.so.1
135 %{_libdir}/libkonsoleprivate.so.*.*.*
136 %ghost %{_libdir}/libkonsoleapp.so.1
137 %{_libdir}/libkonsoleapp.so.*.*.*
138 %attr(755,root,root) %{_libdir}/qt5/plugins/konsolepart.so
139 %dir %{_libdir}/qt5/plugins/konsoleplugins
140 %attr(755,root,root) %{_libdir}/qt5/plugins/konsoleplugins/konsole_sshmanagerplugin.so
141 %{_datadir}/metainfo/org.kde.konsole.appdata.xml
142 %{_desktopdir}/org.kde.konsole.desktop
143 %{_datadir}/knotifications5/konsole.notifyrc
144 %{_datadir}/konsole
145 %{_datadir}/kservices5/konsolepart.desktop
146 %{_datadir}/kservicetypes5/terminalemulator.desktop
147 %{_datadir}/knsrcfiles/konsole.knsrc
148 %{_datadir}/qlogging-categories5/konsole.categories
149 %attr(755,root,root) %{_libdir}/qt5/plugins/konsoleplugins/konsole_quickcommandsplugin.so
150 %{_datadir}/kio/servicemenus/konsolerun.desktop
151 %attr(755,root,root)%{_libdir}/kconf_update_bin/konsole_globalaccel
152 %attr(755,root,root)%{_libdir}/kconf_update_bin/konsole_show_menubar
153 %{_datadir}/kconf_update/konsole.upd
154 %attr(755,root,root)%{_datadir}/kconf_update/konsole_add_hamburgermenu_to_toolbar.sh
155 %{zsh_compdir}/_konsole
156 %{_datadir}/kglobalaccel/org.kde.konsole.desktop
This page took 0.378193 seconds and 3 git commands to generate.