]> git.pld-linux.org Git - packages/ka5-kolf.git/blob - ka5-kolf.spec
- updated to 23.08.5
[packages/ka5-kolf.git] / ka5-kolf.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kolf
8 Summary:        kolf
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  e9828e89fa0880c0594a40b1d2a4a65e
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Qml-devel >= 5.11.1
19 BuildRequires:  Qt5Quick-devel >= 5.11.1
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  cmake >= 3.20
22 BuildRequires:  gettext-devel
23 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
24 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
25 BuildRequires:  kf5-kconfig-devel >= %{kframever}
26 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
27 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
28 BuildRequires:  kf5-kcrash-devel >= %{kframever}
29 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
30 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
31 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
32 BuildRequires:  kf5-ki18n-devel >= %{kframever}
33 BuildRequires:  kf5-kio-devel >= %{kframever}
34 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
35 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
36 BuildRequires:  ninja
37 BuildRequires:  qt5-build >= %{qtver}
38 BuildRequires:  rpmbuild(macros) >= 1.164
39 BuildRequires:  shared-mime-info
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Kolf is a miniature golf game. The game is played from an overhead
46 view, with a short bar representing the golf club. Kolf features many
47 different types of objects, such water hazards, slopes, sand traps,
48 and black holes (warps), among others.
49
50 %description -l pl.UTF-8
51 Kolf jest miniaturową grą w golfa. Gra jest pokazywana z z góry,
52 z małą poprzeczką reprezentującą klub golfowy. Kolf zawiera
53 wiele różnych typów obiektów, takich jak pułapki wodne, zbocza,
54 pułapki piaskowe i czarne dziury.
55
56 %prep
57 %setup -q -n %{kaname}-%{version}
58
59 %build
60 %cmake \
61         -B build \
62         -G Ninja \
63         %{!?with_tests:-DBUILD_TESTING=OFF} \
64         -DHTML_INSTALL_DIR=%{_kdedocdir} \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
66 %ninja_build -C build
67
68 %if %{with tests}
69 ctest --test-dir build
70 %endif
71
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %ninja_install -C build
76
77 %find_lang %{kaname} --all-name --with-kde
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files -f %{kaname}.lang
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/kolf
85 %{_desktopdir}/org.kde.kolf.desktop
86 %{_iconsdir}/hicolor/128x128/apps/kolf.png
87 %{_iconsdir}/hicolor/16x16/apps/kolf.png
88 %{_iconsdir}/hicolor/22x22/apps/kolf.png
89 %{_iconsdir}/hicolor/32x32/apps/kolf.png
90 %{_iconsdir}/hicolor/48x48/apps/kolf.png
91 %{_iconsdir}/hicolor/64x64/apps/kolf.png
92 %{_iconsdir}/hicolor/scalable/apps/kolf.svgz
93 %{_datadir}/kolf
94 %{_datadir}/kxmlgui5/kolf
95 %{_datadir}/metainfo/org.kde.kolf.appdata.xml
This page took 0.334453 seconds and 4 git commands to generate.