]> git.pld-linux.org Git - packages/ka5-kmime.git/blob - ka5-kmime.spec
- updated to 23.08.5
[packages/ka5-kmime.git] / ka5-kmime.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         qtver           5.15.2
6 %define         kaname          kmime
7 Summary:        KMime
8 Name:           ka5-%{kaname}
9 Version:        23.08.5
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
14 # Source0-md5:  4019ac058036e32f4de7b50831696349
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= 5.9.0
18 BuildRequires:  cmake >= 3.20
19 BuildRequires:  gettext-devel
20 BuildRequires:  kf5-extra-cmake-modules >= 5.53.0
21 BuildRequires:  kf5-kcodecs-devel >= 5.51.0
22 BuildRequires:  kf5-ki18n-devel
23 BuildRequires:  kf5-ki18n-devel >= 5.51.0
24 BuildRequires:  ninja
25 BuildRequires:  qt5-build >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  shared-mime-info
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 KMime is a library for handling mail messages and newsgroup articles.
34 Both mail messages and newsgroup articles are based on the same
35 standard called MIME, which stands for
36 - **Multipurpose Internet Mail Extensions**. In this document, the
37   term `message` is used to refer to both mail messages and newsgroup
38   articles.
39
40 %description -l pl.UTF-8
41 KMime jest biblioteką do obsługi wiadomości pocztowych i
42 artykułów grup Usenetowych. Zarówno wiadomości pocztowe i
43 artykuły są oparte na tym samym standardzie zwanym MIME
44 - **Multipurpose Internet Mail Extensions**, (**Uniweralne
45   roszszerzenie poczty internetowej**). W tym dokumencie, termin
46   `wiadomość` oznacza zarówno wiadomości pocztowe, jak i artykuły
47   grup news.
48
49 %package devel
50 Summary:        Header files for %{kaname} development
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files for %{kaname} development.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe dla programistów używających %{kaname}.
60
61 %prep
62 %setup -q -n %{kaname}-%{version}
63
64 %build
65 %cmake -B build \
66         -G Ninja \
67         %{!?with_tests:-DBUILD_TESTING=OFF} \
68         -DHTML_INSTALL_DIR=%{_kdedocdir} \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
70 %ninja_build -C build
71
72 %if %{with tests}
73 ctest --test-dir build
74 %endif
75
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %ninja_install -C build
80
81 %find_lang %{kaname} --all-name --with-kde
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files -f %{kaname}.lang
90 %defattr(644,root,root,755)
91 %{_datadir}/qlogging-categories5/kmime.categories
92 %ghost %{_libdir}/libKPim5Mime.so.5
93 %attr(755,root,root) %{_libdir}/libKPim5Mime.so.*.*.*
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_libdir}/cmake/KF5Mime
98 %{_libdir}/qt5/mkspecs/modules/qt_KMime.pri
99 %{_includedir}/KPim5/KMime
100 %{_libdir}/cmake/KPim5Mime
101 %{_libdir}/libKPim5Mime.so
This page took 0.13026 seconds and 3 git commands to generate.