]> git.pld-linux.org Git - packages/ka5-kapman.git/blob - ka5-kapman.spec
- updated to 23.04.3
[packages/ka5-kapman.git] / ka5-kapman.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.04.3
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kapman
8 Summary:        Kapman
9 Name:           ka5-%{kaname}
10 Version:        23.04.3
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  b671f124cf4412490046500c1099e933
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Qml-devel >= 5.11.1
20 BuildRequires:  Qt5Quick-devel >= 5.11.1
21 BuildRequires:  Qt5Svg-devel
22 BuildRequires:  Qt5Widgets-devel
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  gettext-devel
25 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
26 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
27 BuildRequires:  kf5-kconfig-devel >= %{kframever}
28 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
29 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
30 BuildRequires:  kf5-kcrash-devel >= %{kframever}
31 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
32 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
33 BuildRequires:  kf5-ki18n-devel >= %{kframever}
34 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
35 BuildRequires:  ninja
36 BuildRequires:  qt5-build >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  shared-mime-info
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Kapman is a clone of the well known game Pac-Man.
45
46 You must run through the maze to eat all pills without being captured
47 by a ghost. By eating an energizer, Kapman gets the ability to eat
48 ghosts for a few seconds. When a stage is cleared of pills and
49 energizer the player is taken to the next stage with slightly
50 increased game speed.
51
52 %description -l pl.UTF-8
53 Kapman jest klonem dobrze znanej gry Pac-Man.
54
55 Musisz przemieszczać się przez labirynt, połykać pigułki i unikać duchów.
56 Zjadając energetyka, Kapman otrzymuje moc zjadania duchów, która trwa
57 kilka sekund. Gdy plansza zostanie wyczyszczona z pigułek i energetyka,
58 gracz jest przenoszony na następny poziom z nieco przyspieszoną rozgrywką.
59
60 %prep
61 %setup -q -n %{kaname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -G Ninja \
68         %{!?with_tests:-DBUILD_TESTING=OFF} \
69         -DHTML_INSTALL_DIR=%{_kdedocdir} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
71         ..
72 %ninja_build
73
74 %if %{with tests}
75 ctest
76 %endif
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %ninja_install -C build
82
83 %find_lang %{kaname} --all-name --with-kde
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files -f %{kaname}.lang
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_bindir}/kapman
91 %{_desktopdir}/org.kde.kapman.desktop
92 %{_iconsdir}/hicolor/128x128/apps/kapman.png
93 %{_iconsdir}/hicolor/16x16/apps/kapman.png
94 %{_iconsdir}/hicolor/22x22/apps/kapman.png
95 %{_iconsdir}/hicolor/32x32/apps/kapman.png
96 %{_iconsdir}/hicolor/48x48/apps/kapman.png
97 %{_iconsdir}/hicolor/64x64/apps/kapman.png
98 %{_datadir}/kapman
99 %{_datadir}/metainfo/org.kde.kapman.appdata.xml
100 %{_datadir}/sounds/kapman
This page took 0.588458 seconds and 4 git commands to generate.