]> git.pld-linux.org Git - packages/ka5-kamera.git/blob - ka5-kamera.spec
- updated to 23.08.5
[packages/ka5-kamera.git] / ka5-kamera.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kamera
8 Summary:        Kamera
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  2a6f11f2199681f6aca5a1159e717019
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.20
19 BuildRequires:  gettext-devel
20 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
21 BuildRequires:  kf5-kconfig-devel >= %{kframever}
22 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
23 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
24 BuildRequires:  kf5-ki18n-devel >= %{kframever}
25 BuildRequires:  kf5-kio-devel >= %{kframever}
26 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
27 BuildRequires:  libgphoto2-devel
28 BuildRequires:  ninja
29 BuildRequires:  qt5-build >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  shared-mime-info
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Digital camera support for KDE applications. This package allows any
38 KDE application to access and manipulate pictures on a digital camera.
39
40 %description -l pl.UTF-8
41 Wsparcie dla cyfrowych aparatów fotograficznych. Ten pakiet pozwala
42 dowolnej aplikacji KDE na dostęp i operowanie zdjęciami z aparatu
43 cyfrowego.
44
45 %prep
46 %setup -q -n %{kaname}-%{version}
47
48 %build
49 %cmake \
50         -B build \
51         -G Ninja \
52         %{!?with_tests:-DBUILD_TESTING=OFF} \
53         -DHTML_INSTALL_DIR=%{_kdedocdir} \
54         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
55 %ninja_build -C build
56
57 %if %{with tests}
58 ctest --test-dir build
59 %endif
60
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %find_lang %{kaname} --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files -f %{kaname}.lang
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kio/kio_kamera.so
74 %{_datadir}/solid/actions/solid_camera.desktop
75 %{_datadir}/metainfo/org.kde.kamera.metainfo.xml
76 %attr(755,root,root) %{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/kcm_kamera.so
77 %{_desktopdir}/kcm_kamera.desktop
78 %{_datadir}/qlogging-categories5/kamera.categories
This page took 0.052781 seconds and 3 git commands to generate.