]> git.pld-linux.org Git - packages/ka5-kamera.git/blob - ka5-kamera.spec
2494a9cd8fa7578e25860433bac03b61a9aeac3f
[packages/ka5-kamera.git] / ka5-kamera.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.3
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kamera
8 Summary:        Kamera
9 Name:           ka5-%{kaname}
10 Version:        22.12.3
11 Release:        2
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  c125ff48ec9ee3ed13b7bab1ea626e36
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  gettext-devel
20 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
21 BuildRequires:  kf5-kconfig-devel >= %{kframever}
22 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
23 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
24 BuildRequires:  kf5-ki18n-devel >= %{kframever}
25 BuildRequires:  kf5-kio-devel >= %{kframever}
26 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
27 BuildRequires:  libgphoto2-devel
28 BuildRequires:  ninja
29 BuildRequires:  qt5-build >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  shared-mime-info
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Digital camera support for KDE applications. This package allows any
38 KDE application to access and manipulate pictures on a digital camera.
39
40 %description -l pl.UTF-8
41 Wsparcie dla cyfrowych aparatów fotograficznych. Ten pakiet pozwala
42 dowolnej aplikacji KDE na dostęp i operowanie zdjęciami z aparatu
43 cyfrowego.
44
45 %prep
46 %setup -q -n %{kaname}-%{version}
47
48 %build
49 install -d build
50 cd build
51 %cmake \
52         -G Ninja \
53         %{!?with_tests:-DBUILD_TESTING=OFF} \
54         -DHTML_INSTALL_DIR=%{_kdedocdir} \
55         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
56         ..
57 %ninja_build
58
59 %if %{with tests}
60 ctest
61 %endif
62
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %ninja_install -C build
67
68 %find_lang %{kaname} --all-name --with-kde
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files -f %{kaname}.lang
74 %defattr(644,root,root,755)
75 %{_libdir}/qt5/plugins/kf5/kio/kio_kamera.so
76 %{_datadir}/solid/actions/solid_camera.desktop
77 %{_datadir}/metainfo/org.kde.kamera.metainfo.xml
78 %attr(755,root,root) %{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/kamera.so
79 %{_desktopdir}/kamera.desktop
This page took 0.216524 seconds and 2 git commands to generate.