]> git.pld-linux.org Git - packages/ka5-dolphin.git/blame - ka5-dolphin.spec
Revert "- 24.01.95"
[packages/ka5-dolphin.git] / ka5-dolphin.spec
CommitLineData
7f61c04c
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
551c7332 4%define kdeappsver 23.08.4
c88e6063
WF
5%define kframever 5.94.0
6%define qtver 5.15.2
2facd218
WF
7%define kaname dolphin
8Summary: File manager
9Name: ka5-%{kaname}
551c7332
WF
10Version: 23.08.4
11Release: 1
2facd218
WF
12License: GPL v2+/LGPL v2.1+
13Group: X11/Libraries
551c7332
WF
14Source0: https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15# Source0-md5: 93f96b87c6f518ef66609c7bbf93b894
2facd218 16URL: http://www.kde.org/
551c7332 17BuildRequires: Qt5Core-devel >= %{qtver}
725a619b 18BuildRequires: cmake >= 3.20
551c7332
WF
19BuildRequires: kf5-extra-cmake-modules >= %{kframever}
20BuildRequires: kf5-kbookmarks-devel >= %{kframever}
21BuildRequires: kf5-kcmutils-devel >= %{kframever}
22BuildRequires: kf5-kcompletion-devel >= %{kframever}
23BuildRequires: kf5-kconfig-devel >= %{kframever}
24BuildRequires: kf5-kconfigwidgets-devel >= %{kframever}
25BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
26BuildRequires: kf5-kdelibs4support-devel >= %{kframever}
27BuildRequires: kf5-kdoctools-devel >= %{kframever}
28BuildRequires: kf5-kemoticons-devel >= %{kframever}
29BuildRequires: kf5-kguiaddons-devel >= %{kframever}
30BuildRequires: kf5-ki18n-devel >= %{kframever}
31BuildRequires: kf5-kiconthemes-devel >= %{kframever}
32BuildRequires: kf5-kinit-devel >= %{kframever}
33BuildRequires: kf5-kio-devel >= %{kframever}
34BuildRequires: kf5-kitemmodels-devel >= %{kframever}
35BuildRequires: kf5-knewstuff-devel >= %{kframever}
36BuildRequires: kf5-knotifications-devel >= %{kframever}
37BuildRequires: kf5-knotifyconfig-devel >= %{kframever}
38BuildRequires: kf5-kparts-devel >= %{kframever}
39BuildRequires: kf5-kpty-devel >= %{kframever}
40BuildRequires: kf5-kservice-devel >= %{kframever}
41BuildRequires: kf5-ktextwidgets-devel >= %{kframever}
42BuildRequires: kf5-kwidgetsaddons-devel >= %{kframever}
43BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
44BuildRequires: kf5-kxmlgui-devel >= %{kframever}
1dd07e9e 45BuildRequires: ninja
551c7332 46BuildRequires: qt5-build >= %{qtver}
2facd218 47BuildRequires: rpmbuild(macros) >= 1.164
848e409a 48BuildRequires: ruby-test-unit
2facd218
WF
49BuildRequires: tar >= 1:1.22
50BuildRequires: xz
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
e247367b
WF
54Dolphin is a lightweight file manager. It has been designed with ease
55of use and simplicity in mind, while still allowing flexibility and
56customisation. This means that you can do your file management exactly
57the way you want to do it.
58
59Features
60
848e409a
WF
61• Navigation (or breadcrumb) bar for URLs, allowing you to quickly
62navigate through the hierarchy of files and folders. • Supports
63several different kinds of view styles and properties and allows you
551c7332
WF
64to configure the view exactly how you want it. • Split view,
65allowing you to easily copy or move files between locations. •
66Additional information and shortcuts are available as dock-able
67panels, allowing you to move them around freely and display exactly
68what you want. • Multiple tab support • Informational dialogues
69are displayed in an unobtrusive way. • Undo/redo support •
70Transparent network access through the KIO system.
2facd218 71
20d3c798 72%description -l pl.UTF-8
551c7332
WF
73Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w
74użyciu, choć zapewniający elastyczność i możliwości
75konfiguracji. To znaczy, że możesz go używać dokładnie, tak
76jakbyś chciał.
20d3c798
WF
77
78Cechy
79
e1258da4 80• Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
551c7332
WF
81się wśród hierarchi plików i folderów • Wspiera wiele różnych
82rodzajów przeglądania plików pozwalając skonfigurować podgląd
83tak jak sobie tego życzysz • Podzielony widok do łatwego
84kopiowania i przenoszenia plików między lokacjami • Dodatkowe
85informacje i skróty klawiszowe są dostępne jako dokowalne panele,
86pozwalając przemieszczać się do woli i wyświetlać to co chcesz
87• Wiele kart • Informacyjne okna dialogowe nie drażnią
88użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
e1258da4 89dostęp do sieci korzystający z systemu KIO.
2facd218
WF
90
91%package devel
92Summary: Header files for %{kaname} development
93Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kaname}
94Group: X11/Development/Libraries
95Requires: %{name} = %{version}-%{release}
96Requires: cmake >= 2.6.0
97
98%description devel
99Header files for %{kaname} development.
100
101%description devel -l pl.UTF-8
102Pliki nagłówkowe dla programistów używających %{kaname}.
103
104%prep
105%setup -q -n %{kaname}-%{version}
106
107%build
848e409a
WF
108RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
109export RUBYLIB
2facd218 110%cmake \
725a619b 111 -B build \
1dd07e9e 112 -G Ninja \
7f61c04c 113 %{!?with_tests:-DBUILD_TESTING=OFF} \
781fee27 114 -DHTML_INSTALL_DIR=%{_kdedocdir} \
725a619b
WF
115 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
116%ninja_build -C build
2facd218 117
7f61c04c 118%if %{with tests}
725a619b 119ctest --test-dir build
7f61c04c
WF
120%endif
121
122
2facd218
WF
123%install
124rm -rf $RPM_BUILD_ROOT
1dd07e9e 125%ninja_install -C build
2facd218 126
351ae332
KM
127rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
128rm -rf $RPM_BUILD_ROOT%{_localedir}/ie
2facd218
WF
129%find_lang %{kaname} --all-name --with-kde
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
136
137%files -f %{kaname}.lang
138%defattr(644,root,root,755)
2facd218 139%attr(755,root,root) %{_bindir}/dolphin
848e409a 140%attr(755,root,root) %{_bindir}/servicemenuinstaller
551c7332
WF
141%ghost %{_libdir}/libdolphinprivate.so.5
142%{_libdir}/libdolphinprivate.so.5.*.*
143%ghost %{_libdir}/libdolphinvcs.so.5
144%{_libdir}/libdolphinvcs.so.5.*.*
2facd218
WF
145%{_desktopdir}/org.kde.dolphin.desktop
146%{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
147%{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
148%{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
149%{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
150%{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
151%{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
152%{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
153%{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
551c7332 154%{_datadir}/metainfo/org.kde.dolphin.appdata.xml
848e409a 155%{_datadir}/kglobalaccel/org.kde.dolphin.desktop
551c7332 156%{_datadir}/qlogging-categories5/dolphin.categories
848e409a 157%{_datadir}/knsrcfiles/servicemenu.knsrc
551c7332
WF
158%{systemduserunitdir}/plasma-dolphin.service
159%{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
160%{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
161%dir %{_libdir}/qt5/plugins/dolphin
162%dir %{_libdir}/qt5/plugins/dolphin/kcms
163%{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphingeneral.so
164%{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinnavigation.so
165%{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinviewmodes.so
166%{_datadir}/kconf_update/dolphin_detailsmodesettings.upd
167%dir %{_datadir}/dolphin
168%{_datadir}/dolphin/dolphinpartactions.desktop
6fb82bb2 169%{zsh_compdir}/_dolphin
551c7332 170%{_datadir}/config.kcfg/dolphin_contentdisplaysettings.kcfg
2facd218
WF
171
172%files devel
173%defattr(644,root,root,755)
551c7332 174%{_libdir}/libdolphinvcs.so
2facd218
WF
175%{_includedir}/Dolphin
176%{_includedir}/dolphin_export.h
177%{_includedir}/dolphinvcs_export.h
178%{_libdir}/cmake/DolphinVcs
This page took 0.497372 seconds and 4 git commands to generate.