]> git.pld-linux.org Git - packages/ka5-dolphin.git/blame - ka5-dolphin.spec
- updated to 23.04.3
[packages/ka5-dolphin.git] / ka5-dolphin.spec
CommitLineData
7f61c04c
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
a9e68653 4%define kdeappsver 23.04.3
c88e6063
WF
5%define kframever 5.94.0
6%define qtver 5.15.2
2facd218
WF
7%define kaname dolphin
8Summary: File manager
9Name: ka5-%{kaname}
a9e68653 10Version: 23.04.3
6fb82bb2 11Release: 1
2facd218
WF
12License: GPL v2+/LGPL v2.1+
13Group: X11/Libraries
f34f1acb 14Source0: https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
a9e68653 15# Source0-md5: 3f7fd2269d09463aeb1cbaaac3ca2d7b
2facd218
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: cmake >= 2.8.12
781fee27
WF
19BuildRequires: kf5-extra-cmake-modules >= %{kframever}
20BuildRequires: kf5-kbookmarks-devel >= %{kframever}
848e409a 21BuildRequires: kf5-kcmutils-devel >= %{kframever}
781fee27
WF
22BuildRequires: kf5-kcompletion-devel >= %{kframever}
23BuildRequires: kf5-kconfig-devel >= %{kframever}
24BuildRequires: kf5-kconfigwidgets-devel >= %{kframever}
25BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
26BuildRequires: kf5-kdelibs4support-devel >= %{kframever}
27BuildRequires: kf5-kdoctools-devel >= %{kframever}
28BuildRequires: kf5-kemoticons-devel >= %{kframever}
29BuildRequires: kf5-kguiaddons-devel >= %{kframever}
30BuildRequires: kf5-ki18n-devel >= %{kframever}
31BuildRequires: kf5-kiconthemes-devel >= %{kframever}
32BuildRequires: kf5-kinit-devel >= %{kframever}
33BuildRequires: kf5-kio-devel >= %{kframever}
34BuildRequires: kf5-kitemmodels-devel >= %{kframever}
848e409a 35BuildRequires: kf5-knewstuff-devel >= %{kframever}
781fee27
WF
36BuildRequires: kf5-knotifications-devel >= %{kframever}
37BuildRequires: kf5-knotifyconfig-devel >= %{kframever}
38BuildRequires: kf5-kparts-devel >= %{kframever}
39BuildRequires: kf5-kpty-devel >= %{kframever}
40BuildRequires: kf5-kservice-devel >= %{kframever}
41BuildRequires: kf5-ktextwidgets-devel >= %{kframever}
42BuildRequires: kf5-kwidgetsaddons-devel >= %{kframever}
43BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
44BuildRequires: kf5-kxmlgui-devel >= %{kframever}
1dd07e9e 45BuildRequires: ninja
2facd218
WF
46BuildRequires: qt5-build >= %{qtver}
47BuildRequires: rpmbuild(macros) >= 1.164
848e409a 48BuildRequires: ruby-test-unit
2facd218
WF
49BuildRequires: tar >= 1:1.22
50BuildRequires: xz
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
e247367b
WF
54Dolphin is a lightweight file manager. It has been designed with ease
55of use and simplicity in mind, while still allowing flexibility and
56customisation. This means that you can do your file management exactly
57the way you want to do it.
58
59Features
60
848e409a
WF
61• Navigation (or breadcrumb) bar for URLs, allowing you to quickly
62navigate through the hierarchy of files and folders. • Supports
63several different kinds of view styles and properties and allows you
548696c6
WF
64to configure the view exactly how you want it. • Split view,
65allowing you to easily copy or move files between locations. •
66Additional information and shortcuts are available as dock-able
67panels, allowing you to move them around freely and display exactly
68what you want. • Multiple tab support • Informational dialogues
69are displayed in an unobtrusive way. • Undo/redo support •
70Transparent network access through the KIO system.
2facd218 71
20d3c798 72%description -l pl.UTF-8
548696c6
WF
73Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w
74użyciu, choć zapewniający elastyczność i możliwości
75konfiguracji. To znaczy, że możesz go używać dokładnie, tak
76jakbyś chciał.
20d3c798
WF
77
78Cechy
79
e1258da4 80• Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
548696c6
WF
81się wśród hierarchi plików i folderów • Wspiera wiele różnych
82rodzajów przeglądania plików pozwalając skonfigurować podgląd
83tak jak sobie tego życzysz • Podzielony widok do łatwego
84kopiowania i przenoszenia plików między lokacjami • Dodatkowe
85informacje i skróty klawiszowe są dostępne jako dokowalne panele,
86pozwalając przemieszczać się do woli i wyświetlać to co chcesz
87• Wiele kart • Informacyjne okna dialogowe nie drażnią
88użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
e1258da4 89dostęp do sieci korzystający z systemu KIO.
2facd218
WF
90
91%package devel
92Summary: Header files for %{kaname} development
93Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kaname}
94Group: X11/Development/Libraries
95Requires: %{name} = %{version}-%{release}
96Requires: cmake >= 2.6.0
97
98%description devel
99Header files for %{kaname} development.
100
101%description devel -l pl.UTF-8
102Pliki nagłówkowe dla programistów używających %{kaname}.
103
104%prep
105%setup -q -n %{kaname}-%{version}
106
107%build
108install -d build
109cd build
848e409a
WF
110RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
111export RUBYLIB
2facd218 112%cmake \
1dd07e9e 113 -G Ninja \
7f61c04c 114 %{!?with_tests:-DBUILD_TESTING=OFF} \
781fee27 115 -DHTML_INSTALL_DIR=%{_kdedocdir} \
2facd218
WF
116 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
117 ..
1dd07e9e 118%ninja_build
2facd218 119
7f61c04c
WF
120%if %{with tests}
121ctest
122%endif
123
124
2facd218
WF
125%install
126rm -rf $RPM_BUILD_ROOT
1dd07e9e 127%ninja_install -C build
2facd218 128
351ae332
KM
129rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
130rm -rf $RPM_BUILD_ROOT%{_localedir}/ie
2facd218
WF
131%find_lang %{kaname} --all-name --with-kde
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%post -p /sbin/ldconfig
137%postun -p /sbin/ldconfig
138
139%files -f %{kaname}.lang
140%defattr(644,root,root,755)
2facd218 141%attr(755,root,root) %{_bindir}/dolphin
848e409a 142%attr(755,root,root) %{_bindir}/servicemenuinstaller
2facd218
WF
143%ghost %{_libdir}/libdolphinprivate.so.5
144%{_libdir}/libdolphinprivate.so.5.*.*
145%ghost %{_libdir}/libdolphinvcs.so.5
146%{_libdir}/libdolphinvcs.so.5.*.*
2facd218
WF
147%{_desktopdir}/org.kde.dolphin.desktop
148%{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
149%{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
150%{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
151%{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
152%{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
153%{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
154%{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
155%{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
2facd218 156%{_datadir}/metainfo/org.kde.dolphin.appdata.xml
848e409a
WF
157%{_datadir}/kglobalaccel/org.kde.dolphin.desktop
158%{_datadir}/qlogging-categories5/dolphin.categories
159%{_datadir}/knsrcfiles/servicemenu.knsrc
9302e17d
WF
160%{systemduserunitdir}/plasma-dolphin.service
161%{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
162%{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
548696c6
WF
163%dir %{_libdir}/qt5/plugins/dolphin
164%dir %{_libdir}/qt5/plugins/dolphin/kcms
165%{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphingeneral.so
166%{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinnavigation.so
167%{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinviewmodes.so
168%{_datadir}/kconf_update/dolphin_detailsmodesettings.upd
ab4feb9c 169%dir %{_datadir}/dolphin
a8300971 170%{_datadir}/dolphin/dolphinpartactions.desktop
6fb82bb2 171%{zsh_compdir}/_dolphin
2facd218
WF
172
173%files devel
174%defattr(644,root,root,755)
175%{_libdir}/libdolphinvcs.so
176%{_includedir}/Dolphin
177%{_includedir}/dolphin_export.h
178%{_includedir}/dolphinvcs_export.h
179%{_libdir}/cmake/DolphinVcs
This page took 0.469301 seconds and 4 git commands to generate.