]> git.pld-linux.org Git - packages/ka5-bovo.git/blob - ka5-bovo.spec
relup
[packages/ka5-bovo.git] / ka5-bovo.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.08.1
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          bovo
8 Summary:        A Gomoku like game
9 Name:           ka5-%{kaname}
10 Version:        22.08.1
11 Release:        2
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  8adcc29296084e67f8497e6e238e4bb1
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Concurrent-devel
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= 5.11.1
20 BuildRequires:  Qt5Qml-devel >= 5.11.1
21 BuildRequires:  Qt5Quick-devel >= 5.11.1
22 BuildRequires:  Qt5Svg-devel
23 BuildRequires:  Qt5Widgets-devel
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  gettext-devel
26 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
27 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
29 BuildRequires:  kf5-kcrash-devel >= %{kframever}
30 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
31 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
32 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
33 BuildRequires:  ninja
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  shared-mime-info
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Bovo is a Gomoku like game for two players, where the opponents
43 alternate in placing their respective pictogram on the game board.
44 (Also known as: Connect Five, Five in a row, X and O, Naughts and
45 Crosses)
46
47 %description -l pl.UTF-8
48 Bovo to gra w kółko i krzyżyk (do pięciu w rzędzie).
49
50 %prep
51 %setup -q -n %{kaname}-%{version}
52
53 %build
54 install -d build
55 cd build
56 %cmake \
57         -G Ninja \
58         %{!?with_tests:-DBUILD_TESTING=OFF} \
59         -DHTML_INSTALL_DIR=%{_kdedocdir} \
60         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
61         ..
62 %ninja_build
63
64 %if %{with tests}
65 ctest
66 %endif
67
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %ninja_install -C build
72
73 %find_lang %{kaname} --all-name --with-kde
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files -f %{kaname}.lang
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/bovo
84 %{_desktopdir}/org.kde.bovo.desktop
85 %{_datadir}/bovo
86 %{_iconsdir}/hicolor/128x128/apps/bovo.png
87 %{_iconsdir}/hicolor/16x16/apps/bovo.png
88 %{_iconsdir}/hicolor/22x22/apps/bovo.png
89 %{_iconsdir}/hicolor/32x32/apps/bovo.png
90 %{_iconsdir}/hicolor/48x48/apps/bovo.png
91 %{_iconsdir}/hicolor/64x64/apps/bovo.png
92 %{_datadir}/metainfo/org.kde.bovo.appdata.xml
This page took 0.190778 seconds and 4 git commands to generate.