]> git.pld-linux.org Git - packages/ka5-baloo-widgets.git/blob - ka5-baloo-widgets.spec
- updated to 23.08.5
[packages/ka5-baloo-widgets.git] / ka5-baloo-widgets.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          baloo-widgets
8 Summary:        Baloo widgets
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  e009be9182808f2f40ef9fb1edf6435d
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Test-devel
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  cmake >= 3.20
22 BuildRequires:  gettext-devel
23 BuildRequires:  kf5-baloo-devel >= %{kframever}
24 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
25 BuildRequires:  kf5-kconfig-devel >= %{kframever}
26 BuildRequires:  kf5-kfilemetadata-devel >= %{kframever}
27 BuildRequires:  kf5-ki18n-devel >= %{kframever}
28 BuildRequires:  kf5-kio-devel >= %{kframever}
29 BuildRequires:  ninja
30 BuildRequires:  qt5-build >= %{qtver}
31 BuildRequires:  rpmbuild(macros) >= 1.164
32 BuildRequires:  shared-mime-info
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Widgets for Baloo.
39
40 %description -l pl.UTF-8
41 Widżety dla Baloo.
42
43 %package devel
44 Summary:        Header files for %{kaname} development
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for %{kaname} development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla programistów używających %{kaname}.
54
55 %prep
56 %setup -q -n %{kaname}-%{version}
57
58 %build
59 %cmake \
60         -B build \
61         -G Ninja \
62         %{!?with_tests:-DBUILD_TESTING=OFF} \
63         -DHTML_INSTALL_DIR=%{_kdedocdir} \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
65 %ninja_build -C build
66
67 %if %{with tests}
68 ctest --test-dir build
69 %endif
70
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %ninja_install -C build
75
76 %find_lang %{kaname} --all-name --with-kde
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files -f %{kaname}.lang
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/baloo_filemetadata_temp_extractor
87 %ghost %{_libdir}/libKF5BalooWidgets.so.5
88 %attr(755,root,root) %{_libdir}/libKF5BalooWidgets.so.*.*.*
89 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kfileitemaction/tagsfileitemaction.so
90 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/propertiesdialog/baloofilepropertiesplugin.so
91 %{_datadir}/qlogging-categories5/baloo-widgets.categories
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/KF5/BalooWidgets
96 %{_libdir}/cmake/KF5BalooWidgets
97 %{_libdir}/libKF5BalooWidgets.so
This page took 0.163017 seconds and 4 git commands to generate.