]> git.pld-linux.org Git - packages/ka5-akonadi-contacts.git/blob - ka5-akonadi-contacts.spec
- updated to 22.12.1
[packages/ka5-akonadi-contacts.git] / ka5-akonadi-contacts.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.1
5 %define         qtver           5.15.2
6 %define         kaname          akonadi-contacts
7 Summary:        Akonadi Contacts
8 Name:           ka5-%{kaname}
9 Version:        22.12.1
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
14 # Source0-md5:  0422543cd3cb282f1edd3df5b9481f8c
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= 5.11.1
18 BuildRequires:  Qt5Test-devel
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  gpgme-qt5-devel
23 BuildRequires:  ka5-akonadi-devel >= %{kdeappsver}
24 BuildRequires:  ka5-grantleetheme-devel >= %{kdeappsver}
25 BuildRequires:  ka5-kmime-devel >= %{kdeappsver}
26 BuildRequires:  ka5-libkleo-devel >= %{kdeappsver}
27 BuildRequires:  kf5-extra-cmake-modules >= 5.51.0
28 BuildRequires:  kf5-kcmutils-devel >= 5.87.0
29 BuildRequires:  kf5-kcodecs-devel >= 5.51.0
30 BuildRequires:  kf5-kcompletion-devel >= 5.51.0
31 BuildRequires:  kf5-kcontacts-devel >= 5.65.0
32 BuildRequires:  kf5-kdbusaddons-devel >= 5.51.0
33 BuildRequires:  kf5-ki18n-devel >= 5.51.0
34 BuildRequires:  kf5-kiconthemes-devel >= 5.51.0
35 BuildRequires:  kf5-kio-devel >= 5.51.0
36 BuildRequires:  kf5-kitemmodels-devel >= 5.87.0
37 BuildRequires:  kf5-ktextwidgets-devel >= 5.51.0
38 BuildRequires:  kf5-prison-devel >= 5.51.0
39 BuildRequires:  ninja
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Akonadi Contacts is a library that effectively bridges the
46 type-agnostic API of the Akonadi client libraries and the
47 domain-specific KContacts library. It provides jobs, models and other
48 helpers to make working with contacts and addressbooks through Akonadi
49 easier.
50
51 %package devel
52 Summary:        Header files for %{kaname} development
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 Header files for %{kaname} development.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe dla programistów używających %{kaname}.
62
63 %prep
64 %setup -q -n %{kaname}-%{version}
65
66 %build
67 install -d build
68 cd build
69 %cmake -G Ninja \
70         %{!?with_tests:-DBUILD_TESTING=OFF} \
71         -DHTML_INSTALL_DIR=%{_kdedocdir} \
72         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
73         ..
74 %ninja_build
75
76 %if %{with tests}
77 ctest
78 %endif
79
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %ninja_install -C build
84
85 %find_lang %{kaname} --all-name --with-kde
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{kaname}.lang
94 %defattr(644,root,root,755)
95 %ghost %{_libdir}/libKF5AkonadiContact.so.5
96 %{_libdir}/libKF5AkonadiContact.so.5.*.*
97 %ghost %{_libdir}/libKF5ContactEditor.so.5
98 %{_libdir}/libKF5ContactEditor.so.5.*.*
99 %{_libdir}/qt5/plugins/akonadi_serializer_addressee.so
100 %{_libdir}/qt5/plugins/akonadi_serializer_contactgroup.so
101 %{_datadir}/akonadi/plugins/serializer/akonadi_serializer_addressee.desktop
102 %{_datadir}/akonadi/plugins/serializer/akonadi_serializer_contactgroup.desktop
103 %{_datadir}/kf5/akonadi/contact
104 %{_datadir}/qlogging-categories5/akonadi-contacts.categories
105 %{_datadir}/qlogging-categories5/akonadi-contacts.renamecategories
106 %dir %{_libdir}/qt5/plugins/pim5/akonadi/contacts
107 %dir %{_libdir}/qt5/plugins/pim5/akonadi/contacts/plugins
108 %{_libdir}/qt5/plugins/pim5/akonadi/contacts/plugins/categorieseditwidgetplugin.so
109 %dir %{_libdir}/qt5/plugins/pim5/kcms
110 %dir %{_libdir}/qt5/plugins/pim5/kcms/kaddressbook
111 %{_libdir}/qt5/plugins/pim5/kcms/kaddressbook/kcm_akonadicontact_actions.so
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_libdir}/cmake/KF5AkonadiContact
116 %{_libdir}/cmake/KF5ContactEditor
117 %{_libdir}/libKF5AkonadiContact.so
118 %{_libdir}/libKF5ContactEditor.so
119 %{_libdir}/qt5/mkspecs/modules/qt_AkonadiContact.pri
120 %{_libdir}/qt5/mkspecs/modules/qt_ContactEditor.pri
121 %{_includedir}/KF5/AkonadiContact
122 %{_includedir}/KF5/AkonadiContactEditor
This page took 0.101969 seconds and 4 git commands to generate.