]> git.pld-linux.org Git - packages/kBuild.git/commitdiff
fix internal sed misparsing char regexps (Unmatched [ or [^) auto/th/kBuild-0.1.9998-2
authorElan Ruusamäe <glen@delfi.ee>
Sun, 25 Nov 2012 17:22:55 +0000 (19:22 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 25 Nov 2012 17:22:55 +0000 (19:22 +0200)
it's due re_string_fetch_byte_case was marked pure, while it is not

kBuild.spec
re_string_fetch_byte_case-not-pure-attribute.patch [new file with mode: 0644]

index 8d69c358a5a6e6328b44a3a803c8d074fc2f4bdd..184e34241bbdc165e349c652cfdc5435912b7fcf 100644 (file)
@@ -7,7 +7,7 @@
 Summary:       A cross-platform build environment
 Name:          kBuild
 Version:       0.1.9998
-Release:       1
+Release:       2
 Group:         Development/Tools
 # Most tools are from NetBSD, some are from FreeBSD, and make and sed are from GNU
 License:       BSD and GPL v2+
@@ -18,6 +18,7 @@ Source1:      get-source.sh
 Patch0:                %{name}-0.1.3-escape.patch
 Patch1:                %{name}-0.1.5-dprintf.patch
 Patch2:                %{name}-0.1.5-pthread.patch
+Patch3:                re_string_fetch_byte_case-not-pure-attribute.patch
 BuildRequires: acl-devel
 BuildRequires: autoconf
 BuildRequires: automake
@@ -57,6 +58,7 @@ mv %{name} .tmp; mv .tmp/* .
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cat > SvnInfo.kmk << EOF
 KBUILD_SVN_REV := %{svnrev}
diff --git a/re_string_fetch_byte_case-not-pure-attribute.patch b/re_string_fetch_byte_case-not-pure-attribute.patch
new file mode 100644 (file)
index 0000000..7c1164f
--- /dev/null
@@ -0,0 +1,14 @@
+inspired from a fix from glibc:
+http://www.sourceware.org/ml/libc-alpha/2011-12/msg00091.html
+
+--- kBuild-0.1.9998/./src/sed/lib/regex_internal.c~    2012-11-25 17:35:24.000000000 +0200
++++ kBuild-0.1.9998/./src/sed/lib/regex_internal.c     2012-11-25 19:16:31.260977775 +0200
+@@ -781,7 +781,7 @@
+ }
+ static unsigned char
+-internal_function __attribute ((pure))
++internal_function
+ re_string_fetch_byte_case (re_string_t *pstr)
+ {
+   if (BE (!pstr->mbs_allocated, 1))
This page took 0.034665 seconds and 4 git commands to generate.