]> git.pld-linux.org Git - packages/kBuild.git/commitdiff
update to rev 2814 auto/th/kBuild-0.1.9998.2814-1
authorJan Palus <atler@pld-linux.org>
Sat, 16 Jul 2016 11:14:44 +0000 (13:14 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 16 Jul 2016 11:14:44 +0000 (13:14 +0200)
- dropped dprintf/re_string_fetch_byte_case patches (fixed upstream)
- renumbered patches

kBuild-0.1.5-dprintf.patch [deleted file]
kBuild.spec
re_string_fetch_byte_case-not-pure-attribute.patch [deleted file]

diff --git a/kBuild-0.1.5-dprintf.patch b/kBuild-0.1.5-dprintf.patch
deleted file mode 100644 (file)
index 58887f4..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-This dprintf() collides with POSIX.1-2008 dprintf() and is not used at all
-anyways. (Whoa! what a stupid name! standardized before invention of grep!)
-
-Lubomir Rintel <lkundrak@v3.sk>
-
-diff -up kBuild-0.1.5/src/ash/output.c.gcc44 kBuild-0.1.5/src/ash/output.c
---- kBuild-0.1.5/src/ash/output.c.gcc44        2009-04-13 01:20:33.857017054 +0200
-+++ kBuild-0.1.5/src/ash/output.c      2009-04-13 01:20:57.570033297 +0200
-@@ -230,6 +230,7 @@ out1fmt(const char *fmt, ...)
-       va_end(ap);
- }
-+#if 0
- void
- dprintf(const char *fmt, ...)
- {
-@@ -240,6 +241,7 @@ dprintf(const char *fmt, ...)
-       va_end(ap);
-       flushout(out2);
- }
-+#endif
- void
- fmtstr(char *outbuf, size_t length, const char *fmt, ...)
-diff -up kBuild-0.1.5/src/ash/output.h.gcc44 kBuild-0.1.5/src/ash/output.h
---- kBuild-0.1.5/src/ash/output.h.gcc44        2009-04-13 01:20:37.724140366 +0200
-+++ kBuild-0.1.5/src/ash/output.h      2009-04-13 01:20:47.933142098 +0200
-@@ -65,8 +65,10 @@ void outfmt(struct output *, const char 
-     __attribute__((__format__(__printf__,2,3)));
- void out1fmt(const char *, ...)
-     __attribute__((__format__(__printf__,1,2)));
-+#if 0
- void dprintf(const char *, ...)
-     __attribute__((__format__(__printf__,1,2)));
-+#endif
- void fmtstr(char *, size_t, const char *, ...)
-     __attribute__((__format__(__printf__,3,4)));
- void doformat(struct output *, const char *, va_list);
index 9105cd12671431f6aaf4e527d2b8a9d7d7aeb4ec..0be1669d4c843caa7eed1b74c4c219b00dcf1cae 100644 (file)
@@ -4,24 +4,22 @@
 %bcond_without verbose         # disable verbose build
 
 %define                ver     0.1.9998
-%define                svnrev  2700
+%define                svnrev  2814
 Summary:       A cross-platform build environment
 Summary(pl.UTF-8):     Wieloplatformowe środowisko budowania
 Name:          kBuild
 Version:       %{ver}.%{svnrev}
-Release:       3
+Release:       1
 Group:         Development/Tools
 # Most tools are from NetBSD, some are from FreeBSD, and make and sed are from GNU
 License:       BSD and GPL v2+
 Source0:       %{name}-r%{svnrev}.tar.bz2
-# Source0-md5: 7c394fbe248f903d0bc1aabd235dc0a9
+# Source0-md5: ff69b9b96c548bb87eae37936246bce2
 Source1:       get-source.sh
 Patch0:                %{name}-0.1.3-escape.patch
-Patch1:                %{name}-0.1.5-dprintf.patch
-Patch2:                %{name}-0.1.5-pthread.patch
-Patch3:                re_string_fetch_byte_case-not-pure-attribute.patch
-Patch4:                x32.patch
-Patch5:                %{name}-bison.patch
+Patch1:                %{name}-0.1.5-pthread.patch
+Patch2:                x32.patch
+Patch3:                %{name}-bison.patch
 URL:           http://svn.netlabs.org/kbuild
 BuildRequires: acl-devel
 BuildRequires: bison
@@ -81,8 +79,6 @@ mv %{name} .tmp; mv .tmp/* .
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 cat > SvnInfo.kmk << EOF
 KBUILD_SVN_REV := %{svnrev}
diff --git a/re_string_fetch_byte_case-not-pure-attribute.patch b/re_string_fetch_byte_case-not-pure-attribute.patch
deleted file mode 100644 (file)
index 7c1164f..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-inspired from a fix from glibc:
-http://www.sourceware.org/ml/libc-alpha/2011-12/msg00091.html
-
---- kBuild-0.1.9998/./src/sed/lib/regex_internal.c~    2012-11-25 17:35:24.000000000 +0200
-+++ kBuild-0.1.9998/./src/sed/lib/regex_internal.c     2012-11-25 19:16:31.260977775 +0200
-@@ -781,7 +781,7 @@
- }
- static unsigned char
--internal_function __attribute ((pure))
-+internal_function
- re_string_fetch_byte_case (re_string_t *pstr)
- {
-   if (BE (!pstr->mbs_allocated, 1))
This page took 0.107178 seconds and 4 git commands to generate.