]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- added URL
[packages/john.git] / john.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # MMX optimization
4 # Optimization must be chosen at compile time :(
5 # Maybe some patch...? But not yet.
6 #
7 %ifarch athlon
8 %define with_mmx 1
9 %endif
10 Summary:        Password cracker
11 Summary(pl):    £amacz hase³
12 Name:           john
13 Version:        1.6.37
14 Release:        3
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://www.openwall.com/john/a/%{name}-%{version}.tar.gz
18 # Source0-md5:  9403233b640927295c05b0564ff1f678
19 # needed for docs and charset files
20 Source1:        http://www.openwall.com/john/%{name}-1.6.tar.gz
21 # Source1-md5:  aae782f160041b2bdc624b0a84054e32
22 Patch0:         %{name}-1.6.PLD.diff
23 Patch1:         %{name}-1.6.ini.diff
24 Patch2:         %{name}-1.6.makefile.diff
25 URL:            http://www.openwall.com/john/
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 John the Ripper is a password cracker, currently available for UNIX,
30 DOS, WinNT/Win95. Its primary purpose is to detect weak UNIX
31 passwords. It has been tested with Linux x86/Alpha/SPARC, FreeBSD x86,
32 OpenBSD x86, Solaris 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and
33 IRIX.
34
35 %description -l pl
36 John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX,
37 DOS, WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych"
38 hase³. By³ testowany z Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86,
39 Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
40
41 %prep
42 %setup -q -a1
43 # -n %{name}-1.6
44 %patch0 -p1
45 #%patch1 -p1
46 #%patch2 -p1
47
48 %build
49 cd src
50 COPT="%{rpmcflags}"
51
52 # bleh... MMX code must be chosen at compile time :(
53 # cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
54 # K6 optimization exists only in Makefile
55 %ifarch %{ix86}
56         %if %{with mmx}
57                 TARG=linux-x86-mmx-elf
58         %else
59                 TARG=linux-x86-any-elf
60         %endif
61 %else
62         %ifarch alpha
63                 TARG=linux-alpha
64         %else
65                 %ifarch sparc sparc64
66                         TARG=linux-sparc
67                 %else
68                         TARG=generic
69                 %endif
70         %endif
71 %endif
72
73 %{__make} $TARG \
74         OPT="$COPT" \
75         CC="%{__cc}"
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/john}
80 install run/john.conf john-1.6/run/*.chr $RPM_BUILD_ROOT%{_libdir}/john
81 install run/john $RPM_BUILD_ROOT%{_bindir}
82
83 rm -f doc/INSTALL
84
85 cd $RPM_BUILD_ROOT%{_bindir}
86 ln -sf john unafs
87 ln -sf john unique
88 ln -sf john unshadow
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc doc/* john-1.6/doc/{CONFIG,EXAMPLES,EXTERNAL,FAQ,MODES,NEWS,OPTIONS,RULES} run/mailer
96 %attr(755,root,root) %{_bindir}/*
97 %{_libdir}/john
This page took 0.113506 seconds and 4 git commands to generate.