]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- updated descs
[packages/john.git] / john.spec
1 #
2 %ifarch i586 i686 athlon pentium2 pentium3 pentium4
3 %define do_mmx 1
4 %else
5 %define do_mmx 0
6 %endif
7 %ifarch i586 i686
8 %define do_mmxfb 1
9 %define optmmxfb        -DCPU_FALLBACK=1
10 %else
11 %define do_mmxfb 0
12 %undefine optmmxfb
13 %endif
14 Summary:        Password cracker
15 Summary(pl):    £amacz hase³
16 Name:           john
17 Version:        1.7
18 Release:        0.2
19 License:        GPL
20 Group:          Applications/System
21 Source0:        http://www.openwall.com/john/d/%{name}-%{version}.tar.bz2
22 # Source0-md5:  615b912caa677eec790e28745a12b2ae
23 Patch0:         %{name}-mailer.patch
24 URL:            http://www.openwall.com/john/
25 BuildRequires:  rpmbuild(macros) >= 1.213
26 BuildRequires:  sed >= 4.0
27 Requires:       words
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 John the Ripper is a fast password cracker, currently available for
32 many flavors of Unix (11 are officially supported, not counting
33 different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
34 requires a contributed patch). Its primary purpose is to detect weak
35 Unix passwords. Besides several crypt(3) password hash types most
36 commonly found on various Unix flavors, supported out of the box are
37 Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
38 contributed patches.
39
40 %description -l pl
41 John The Ripper jest szybkim "³amaczem" hase³ dostêpnym dla wielu
42 rodzajów uniksów (oficjalnie obs³ugiwanych jest 11, nie licz±c ró¿nych
43 architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
44 ³aty). G³ównym zastosowaniem jest wykrywanie s³abych hase³ uniksowych.
45 Oprócz ró¿nych rodzajów skrótów hase³ crypt(3) najczê¶ciej u¿ywanych
46 na ró¿nych uniksach, obs³ugiwane s± tak¿e skróty Kerberos/AFS oraz
47 Windows NT/2000/XP LM, a tak¿e kilka innych przy u¿yciu ³at.
48
49 %prep
50 %setup -q 
51 %patch0 -p1
52
53 sed -i -e 's/CLK_TCK/CLOCKS_PER_SEC/g' src/*.c
54
55 %build
56 cd src
57
58 %if %{do_mmxfb}
59 %{__make} linux-x86-any \
60         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
61         CC="%{__cc}"
62 mv ../run/john ../run/john-non-mmx
63 %{__make} clean
64 %endif
65
66 %ifarch %{ix86}
67         %if %{do_mmx}
68                 TARG=linux-x86-mmx
69         %else
70                 TARG=linux-x86-any
71         %endif
72 %else
73         %ifarch alpha
74                 TARG=linux-alpha
75         %else
76                 %ifarch sparc sparcv9
77                         TARG=linux-sparc
78                 %else
79                         %ifarch %{x8664}
80                                 TARG=linux-x86-64
81                         %else
82                                 TARG=generic
83                         %endif  
84                 %endif
85         %endif
86 %endif
87
88 %{__make} $TARG \
89         CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
90         CC="%{__cc}"
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
96 install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
97 install run/john $RPM_BUILD_ROOT%{_bindir}
98 %if %{do_mmxfb}
99 install -d $RPM_BUILD_ROOT%{_libdir}/john
100 install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
101 %endif
102
103 rm -f doc/INSTALL
104
105 cd $RPM_BUILD_ROOT%{_bindir}
106 ln -sf john unafs
107 ln -sf john unique
108 ln -sf john unshadow
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc doc/* run/mailer
116 %attr(755,root,root) %{_bindir}/*
117 %if %{do_mmxfb}
118 %dir %{_libdir}/john
119 %attr(755,root,root) %{_libdir}/john/john-non-mmx
120 %endif
121 %{_datadir}/john
This page took 0.099865 seconds and 4 git commands to generate.