]> git.pld-linux.org Git - packages/john.git/blob - john.spec
51e053e14ea7d0b74cf7be08d3f1037d73b049a7
[packages/john.git] / john.spec
1 #
2 # TODO:
3 # - investigate build-time vs runtime CPU features detection
4 #
5 # Conditional build:
6 %bcond_without  opencl          # OpenCL support
7 %bcond_without  openmp          # OpenMP support
8
9 %define         snap            20190327
10 %define         githash         4840892d68d14ad4a28f3e6f8c2e2941e9c0a2ad
11 %define         rel     1
12
13 Summary:        Password cracker
14 Summary(pl.UTF-8):      Łamacz haseł
15 Name:           john
16 Version:        1.8.0
17 Release:        2.%{snap}.%{rel}
18 License:        GPL v2
19 Group:          Applications/System
20 Source0:        https://github.com/magnumripper/JohnTheRipper/archive/%{githash}/%{name}-%{snap}.tar.gz
21 # Source0-md5:  0338a3184bf5598a5b027f3ee929ba24
22 Patch0:         %{name}-mailer.patch
23 Patch1:         jumbo-optflags.patch
24 Patch4:         %{name}-x32.patch
25 URL:            http://www.openwall.com/john/
26 %{?with_opencl:BuildRequires:   OpenCL-devel}
27 BuildRequires:  autoconf >= 2.69
28 BuildRequires:  bzip2-devel
29 %{?with_openmp:BuildRequires:   gcc >= 6:4.2}
30 BuildRequires:  gmp-devel
31 %{?with_openmp:BuildRequires:   libgomp-devel}
32 BuildRequires:  rpmbuild(macros) >= 1.213
33 BuildRequires:  tar >= 1:1.22
34 # for SIPdump and vncpcap2john binaries, which are not packaged
35 #BuildRequires: libpcap-devel
36 BuildRequires:  openssl-devel >= 0.9.7
37 BuildRequires:  pkgconfig
38 BuildRequires:  yasm
39 BuildRequires:  zlib-devel
40 Requires:       words
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 John the Ripper is a fast password cracker, currently available for
45 many flavors of Unix (11 are officially supported, not counting
46 different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
47 requires a contributed patch). Its primary purpose is to detect weak
48 Unix passwords. Besides several crypt(3) password hash types most
49 commonly found on various Unix flavors, supported out of the box are
50 Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
51 contributed patches.
52
53 %description -l pl.UTF-8
54 John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
55 rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
56 architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
57 łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
58 Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
59 na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
60 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
61
62 %prep
63 %setup -q -n JohnTheRipper-%{githash}
64 %patch0 -p1
65 %patch1 -p1
66 %ifarch x32
67 %patch4 -p1
68 %endif
69
70 %build
71 cd src
72 %{__autoconf}
73
74 %ifarch x32
75 ax_intel_x32=yes \
76 %endif
77 %configure \
78         %{!?with_opencl:--disable-opencl} \
79         %{!?with_openmp:--disable-openmp}
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
86 cp -a run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
87 install -p run/john $RPM_BUILD_ROOT%{_bindir}
88
89 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unafs
90 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unique
91 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unshadow
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc doc/* run/mailer
99 %attr(755,root,root) %{_bindir}/john
100 %attr(755,root,root) %{_bindir}/unafs
101 %attr(755,root,root) %{_bindir}/unique
102 %attr(755,root,root) %{_bindir}/unshadow
103 %{_datadir}/john
This page took 0.124239 seconds and 2 git commands to generate.