]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- todo
[packages/john.git] / john.spec
1 #
2 # TODO:
3 # - investigate build-time vs runtime detection
4 #
5 # Conditional build:
6 %bcond_without  opencl          # OpenCL support (in jumbo version)
7 %bcond_without  openmp          # OpenMP support (in jumbo version)
8
9 %define         snap            20181101
10 %define         githash         d73288b91d92f3bd670c18d3853ddaf0e02159f0
11
12 Summary:        Password cracker
13 Summary(pl.UTF-8):      Łamacz haseł
14 Name:           john
15 Version:        1.8.0
16 Release:        2.%{snap}.1
17 License:        GPL v2
18 Group:          Applications/System
19 Source0:        https://github.com/magnumripper/JohnTheRipper/archive/%{githash}/john-%{snap}.tar.gz
20 # Source0-md5:  a75c1108111c5181b471a9f4a9dab898
21 Patch0:         %{name}-mailer.patch
22 Patch1:         jumbo-optflags.patch
23 Patch4:         %{name}-x32.patch
24 URL:            http://www.openwall.com/john/
25 BuildRequires:  rpmbuild(macros) >= 1.213
26 BuildRequires:  autoconf >= 2.69
27 BuildRequires:  tar >= 1:1.22
28 %{?with_opencl:BuildRequires:   OpenCL-devel}
29 BuildRequires:  bzip2-devel
30 %{?with_openmp:BuildRequires:   gcc >= 6:4.2}
31 BuildRequires:  gmp-devel
32 %{?with_openmp:BuildRequires:   libgomp-devel}
33 # for SIPdump and vncpcap2john binaries, which are not packaged
34 #BuildRequires: libpcap-devel
35 BuildRequires:  openssl-devel >= 0.9.7
36 BuildRequires:  pkgconfig
37 BuildRequires:  yasm
38 BuildRequires:  zlib-devel
39 Requires:       words
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 John the Ripper is a fast password cracker, currently available for
44 many flavors of Unix (11 are officially supported, not counting
45 different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
46 requires a contributed patch). Its primary purpose is to detect weak
47 Unix passwords. Besides several crypt(3) password hash types most
48 commonly found on various Unix flavors, supported out of the box are
49 Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
50 contributed patches.
51
52 %description -l pl.UTF-8
53 John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
54 rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
55 architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
56 łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
57 Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
58 na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
59 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
60
61 %prep
62 %setup -q -n JohnTheRipper-%{githash}
63 %patch0 -p1
64 %patch1 -p1
65 %ifarch x32
66 %patch4 -p1
67 %endif
68
69 %build
70 cd src
71 %{__autoconf}
72
73 %ifarch x32
74 ax_intel_x32=yes \
75 %endif
76 %configure \
77         %{!?with_opencl:--disable-opencl} \
78         %{!?with_openmp:--disable-openmp}
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
85 cp -a run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
86 install -p run/john $RPM_BUILD_ROOT%{_bindir}
87
88 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unafs
89 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unique
90 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unshadow
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc doc/* run/mailer
98 %attr(755,root,root) %{_bindir}/john
99 %attr(755,root,root) %{_bindir}/unafs
100 %attr(755,root,root) %{_bindir}/unique
101 %attr(755,root,root) %{_bindir}/unshadow
102 %{_datadir}/john
This page took 0.19422 seconds and 3 git commands to generate.