]> git.pld-linux.org Git - packages/jenkins.git/blob - jenkins.spec
- up to 1.335, dedicated to _zork_
[packages/jenkins.git] / jenkins.spec
1 # TODO
2 # - build it from sources
3 #   https://hudson.dev.java.net/files/documents/2402/125619/hudson-1.280-src.zip
4 # - use system jars
5 %include        /usr/lib/rpm/macros.java
6 Summary:        Hudson Continuous Build Server
7 Name:           hudson
8 Version:        1.335
9 Release:        1
10 License:        MIT License
11 Group:          Networking/Daemons/Java/Servlets
12 # Check for new releases and URLs here: https://hudson.dev.java.net/servlets/ProjectRSS?type=news
13 Source0:        http://dlc.sun.com/hudson/downloads/war/%{version}/%{name}.war
14 # Source0-md5:  27fedd4b7e39fdeb3b0e8b3c237eb511
15 Source1:        %{name}-web.xml
16 Source2:        %{name}-context.xml
17 URL:            https://hudson.dev.java.net/
18 BuildRequires:  jpackage-utils
19 BuildRequires:  rpm-javaprov
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 Requires:       group(servlet)
22 Requires:       jpackage-utils
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Hudson monitors executions of repeated jobs, such as building a
28 software project or jobs run by cron.
29
30 Among those things, current Hudson focuses on the following two jobs:
31 - Building/testing software projects continuously, just like
32   CruiseControl or DamageControl. In a nutshell, Hudson provides an
33   easy-to-use so-called continuous integration system, making it easier
34   for developers to integrate changes to the project, and making it
35   easier for users to obtain a fresh build. The automated, continoues
36   build increases the productivity.
37 - Monitoring executions of externally-run jobs, such as cron jobs and
38   procmail jobs, even those that are run on a remote machine. For
39   example, with cron, all you receive is regular e-mails that capture
40   the output, and it is up to you to look at them diligently and notice
41   when it broke. Hudson keeps those outputs and makes it easy for you to
42   notice when something is wrong.
43
44 %prep
45 %setup -qc
46
47 rm *.class
48 rm winstone.jar
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hudson,%{_datadir}/hudson,%{_sharedstatedir}/{hudson,tomcat/conf/Catalina/localhost}}
53 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/hudson/web.xml
54 install %{SOURCE2} $RPM_BUILD_ROOT%{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
55 cp -a . $RPM_BUILD_ROOT%{_datadir}/hudson
56 ln -sf %{_sysconfdir}/hudson/web.xml $RPM_BUILD_ROOT%{_datadir}/hudson/WEB-INF/web.xml
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %dir %{_sysconfdir}/hudson
64 %config(noreplace) %{_sysconfdir}/hudson/web.xml
65 # do not make this file writeable by tomcat. We do not want to allow user to
66 # undeploy this app via tomcat manager.
67 %config(noreplace) %{_sharedstatedir}/tomcat/conf/Catalina/localhost/hudson.xml
68 %{_datadir}/hudson
69 %attr(2775,root,servlet) %dir %{_sharedstatedir}/hudson
This page took 0.034888 seconds and 3 git commands to generate.