]> git.pld-linux.org Git - packages/iv.git/commitdiff
- updated to 2.6.1 auto/th/iv-2.6.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Feb 2014 15:01:15 +0000 (16:01 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Feb 2014 15:01:15 +0000 (16:01 +0100)
- added libpng, verbose patches

iv-libpng.patch [new file with mode: 0644]
iv-verbose.patch [new file with mode: 0644]
iv.spec

diff --git a/iv-libpng.patch b/iv-libpng.patch
new file mode 100644 (file)
index 0000000..41550da
--- /dev/null
@@ -0,0 +1,25 @@
+--- iv-2.6.1/iv/imgio_png.c.orig       2009-07-27 02:00:00.000000000 +0200
++++ iv-2.6.1/iv/imgio_png.c    2014-02-02 15:50:22.418709431 +0100
+@@ -2,6 +2,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
++#include <string.h>
++#include <strings.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ /* png.h and setjmp.h may not be combined */
+@@ -651,11 +653,11 @@
+       /* Get the PNG color type */
+       ctx->png_color_type = color_type = ((png_info_ptr != NULL) ?
+-              png_info_ptr->color_type : PNG_COLOR_TYPE_GRAY
++              png_get_color_type(png_ptr, png_info_ptr) : PNG_COLOR_TYPE_GRAY
+       );
+       /* Get the PNG bit depth */
+-      ctx->png_bit_depth = bit_depth = (png_info_ptr != NULL) ? png_info_ptr->bit_depth : 1;
++      ctx->png_bit_depth = bit_depth = (png_info_ptr != NULL) ? png_get_bit_depth(png_ptr, png_info_ptr) : 1;
+       /* Insert transformations here */
diff --git a/iv-verbose.patch b/iv-verbose.patch
new file mode 100644 (file)
index 0000000..5af5795
--- /dev/null
@@ -0,0 +1,43 @@
+--- iv-2.6.1/Makefile.orig     2009-07-27 02:00:00.000000000 +0200
++++ iv-2.6.1/Makefile  2014-02-02 15:52:09.872038255 +0100
+@@ -40,7 +40,7 @@
+ #
+ all config:
+       @for subdir in $(ALL_SRC_DIRS); do                      \
+-            $(MAKE) -s -C $$subdir -f Makefile $@;            \
++            $(MAKE) -C $$subdir -f Makefile $@;               \
+         done
+       @echo "To install, type \"su\" (to gain root privileges)\
+ and then type \"make install\"."
+@@ -50,7 +50,7 @@
+ #
+ install:
+       @for subdir in $(ALL_SRC_DIRS); do                      \
+-            $(MAKE) -s -C $$subdir -f Makefile $@;            \
++            $(MAKE) -C $$subdir -f Makefile $@;               \
+         done
+       @echo "Installation complete."
+@@ -59,5 +59,5 @@
+ #
+ clean:
+       @for subdir in $(ALL_SRC_DIRS); do                      \
+-            $(MAKE) -s -C $$subdir -f Makefile $@;            \
++            $(MAKE) -C $$subdir -f Makefile $@;               \
+         done
+--- iv-2.6.1/iv/Makefile.orig  2009-07-27 02:00:00.000000000 +0200
++++ iv-2.6.1/iv/Makefile       2014-02-02 15:55:18.495363672 +0100
+@@ -51,11 +51,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP       = $(SRC_CPP:.cpp=.o)
+ .c.o:
+-      @echo "Compiling module $*.o"
+-      @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++      $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+-      @echo "Compiling module $*.o"
+-      @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++      $(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
+ $(BIN): prebuild config modules postbuild
diff --git a/iv.spec b/iv.spec
index 3ea31e6d886063e999cb96360edcf85379db7bbf..bd591ac0a14294170f225f9a64b81a9e0038ce14 100644 (file)
--- a/iv.spec
+++ b/iv.spec
@@ -1,14 +1,16 @@
 Summary:       ImgView - simple GTK+ image viewer using Imlib
 Summary(pl.UTF-8):     ImgView - prosta przeglądarka obrazków oparta na GTK+ i używająca Imliba
 Name:          iv
-Version:       1.4.2
-Release:       5
-License:       GPL
+Version:       2.6.1
+Release:       1
+License:       GPL v2
 Group:         X11/Applications/Graphics
-Source0:       ftp://wolfpack.twu.net/users/wolfpack/%{name}-%{version}.tar.bz2
-# Source0-md5: c35e8b210b27acfa5689a8a547eeb947
+Source0:       http://wolfsinger.com/~wolfpack/packages/%{name}-%{version}.tar.bz2
+# Source0-md5: e18ffd722be6905e69c97d641b5c6839
 Patch0:                %{name}-vidmode.patch
-URL:           http://wolfpack.twu.net/IV/
+Patch1:                %{name}-libpng.patch
+Patch2:                %{name}-verbose.patch
+URL:           http://freecode.com/projects/iv
 BuildRequires: gtk+-devel
 BuildRequires: imlib-devel
 BuildRequires: libpng-devel >= 2:1.4.0
@@ -24,8 +26,8 @@ Prosta przeglądarka obrazków oparta na GTK+ i używająca Imliba.
 %prep
 %setup -q
 %patch0 -p1
-
-%{__sed} -i -e 's/!png_check_sig(sig_buf, 8)/png_sig_cmp(sig_buf, 0, 8)/g' iv/imgiopng.c
+%patch1 -p1
+%patch2 -p1
 
 %build
 ./configure Linux
@@ -51,7 +53,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
-%attr(755,root,root) %{_bindir}/*
-%{_pixmapsdir}/*.xpm
-%{_mandir}/man1/*.1*
+%doc AUTHORS README
+%attr(755,root,root) %{_bindir}/iv
+%{_pixmapsdir}/iv.xpm
+%{_mandir}/man1/iv.1*
This page took 0.062884 seconds and 4 git commands to generate.