]> git.pld-linux.org Git - packages/itk.git/blob - itk.spec
- separated from itcl.spec
[packages/itk.git] / itk.spec
1 Summary:        [incr Tk] - object-oriented extension of the Tcl/Tk language
2 Summary(pl.UTF-8):      [incr Tk] - obiektowo zorientowane rozszerzenie języka Tcl/Tk
3 Name:           itk
4 Version:        3.4
5 %define snap    20111128
6 Release:        0.%{snap}.1
7 License:        distributable
8 Group:          Development/Languages/Tcl
9 #Source0:       http://downloads.sourceforge.net/incrtcl/%{name}%{version}.tar.gz
10 # fossil clone http://core.tcl.tk/itk itk.fossil && mkdir itk && cd itk && fossil open ../itk.fossil itk-3-branch
11 Source0:        %{name}-3-%{snap}.tar.xz
12 # Source0-md5:  837ebeadb9f2e167431248186bf3f3e0
13 Patch0:         %{name}-soname.patch
14 Patch1:         %{name}-tclconfig.patch
15 URL:            http://incrtcl.sourceforge.net/itk/
16 BuildRequires:  autoconf >= 2.13
17 BuildRequires:  itcl-devel >= 3.4.1
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  tk-devel >= 8.4.6
20 BuildRequires:  xz
21 Requires:       itcl >= 3.4.1
22 Requires:       tk >= 8.4.6
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _ulibdir        %{_prefix}/lib
26
27 %description
28 [incr Tk] is a framework for building mega-widgets using the [incr
29 Tcl] object system. Mega-widgets are high-level widgets like a file
30 browser or a tab notebook that act like ordinary Tk widgets but are
31 constructed using Tk widgets as component parts, without having to
32 write C code. In effect, a mega-widget looks and acts exactly like a
33 Tk widget, but is considerably easier to implement.
34
35 %description -l pl.UTF-8
36 [incr Tk] to szkielet do tworzenia mega-widgetów przy użyciu systemu
37 obiektów [incr ZTcl]. Mega-widgety to widgety wyższego poziomu, takie
38 jak przeglądarka plików czy notatnik z zakładkami, zachowujące się jak
39 zwykłe widgety Tk, ale skonstruowane z części składowych będących
40 widgetami Tk bez potrzeby pisania kodu w C. W efekcie mega-widget
41 wygląda i zachowuje się dokładnie tak, jak widget Tk, ale jest
42 znacząco łatwiejszy w implementacji.
43
44 %package devel
45 Summary:        Header files for itk library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki itk
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       itcl-devel >= 3.4.1
50 Requires:       tk-devel >= 8.4.6
51
52 %description devel
53 Header files for itk library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki itk.
57
58 %prep
59 %setup -q -n %{name}
60 %patch0 -p1
61 %patch1 -p1
62
63 %build
64 %{__autoconf}
65 %configure \
66         --libdir=%{_ulibdir}
67
68 %{__make} \
69         CFLAGS_DEFAULT=
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT%{_libdir}
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 mv -f $RPM_BUILD_ROOT%{_ulibdir}/itk%{version}/libitk* $RPM_BUILD_ROOT%{_libdir}
79
80 libfile=$(basename $RPM_BUILD_ROOT%{_libdir}/libitk%{version}.so.0.*)
81 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk%{version}.so.0
82 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk%{version}.so
83 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk.so
84
85 # some substs missing in configure, install missing in Makefile
86 %{__sed} -i -e "s,ITCL_VERSION='@ITCL_VERSION@',ITK_VERSION='%{version}'," \
87         -e 's,@ITK_LIB_FILE@,libitk%{version}.so,' \
88         -e 's,@ITK_BUILD_LIB_SPEC@,-litk%{version},' \
89         -e 's,@ITK_LIB_SPEC@,-litk%{version},' \
90         -e 's,@ITK_STUB_LIB_FILE@,,' \
91         -e 's,@ITK_BUILD_STUB_LIB_SPEC@,,' \
92         -e 's,@ITK_STUB_LIB_SPEC@,,' \
93         -e 's,@ITK_SRC_DIR@,%{_ulibdir},' itkConfig.sh
94 install itkConfig.sh $RPM_BUILD_ROOT%{_ulibdir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libitk%{version}.so.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libitk%{version}.so.0
106 %dir %{_ulibdir}/itk%{version}
107 %{_ulibdir}/itk%{version}/*.itk
108 %{_ulibdir}/itk%{version}/*.tcl
109 %{_ulibdir}/itk%{version}/tclIndex
110 %{_mandir}/mann/Archetype.n*
111 %{_mandir}/mann/Toplevel.n*
112 %{_mandir}/mann/Widget.n*
113 %{_mandir}/mann/itk.n*
114 %{_mandir}/mann/itkvars.n*
115 %{_mandir}/mann/usual.n*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libitk%{version}.so
120 %attr(755,root,root) %{_libdir}/libitk.so
121 %attr(755,root,root) %{_ulibdir}/itkConfig.sh
122 %{_includedir}/itk*.h
This page took 0.24322 seconds and 3 git commands to generate.