]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- start update 0.8.10-rc5
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 #
7 %define         _rel rc5
8 %define         _idea_ver       0.1.46
9 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
10 Summary:        Irssi is a IRC client
11 Summary(fr):    Irssi est un client IRC
12 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
13 Name:           irssi
14 Version:        0.8.10
15 Release:        0.%{_del}
16 License:        GPL
17 Group:          Applications/Communications
18 Source0:        http://real.irssi.org/files/%{name}-%{version}-%{_rel}.tar.gz
19 # Source0-md5:  7c0b6c1533c85e918f41ded1238e4ca1
20 Source1:        %{name}.desktop
21 Source2:        %{name}.png
22 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
23 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
24 Patch0:         %{name}-dcc-send-limit.patch
25 Patch1:         %{name}-channel_auto_who.patch
26 Patch2:         %{name}-tinfo.patch
27 Patch3:         %{name}-home_etc.patch
28 Patch4:         %{name}.conf.patch
29 Patch5:         %{name}-idea-listlen.patch
30 URL:            http://www.irssi.org/
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  gettext-devel
34 BuildRequires:  glib-devel
35 BuildRequires:  glib2-devel >= 2.1.0
36 BuildRequires:  libtool
37 BuildRequires:  ncurses-devel >= 5.0
38 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
39 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
40 BuildRequires:  pkgconfig
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42 Obsoletes:      %{name}-speech
43 Obsoletes:      %{name}-sql
44
45 %description
46 Irssi is a textUI IRC client with IPv6 support.
47
48 %description -l fr
49 Irssi est client IRC.
50
51 %description -l pl
52 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
53
54 %package plugin-idea
55 Summary:        Irssi plugin IDEA crypt
56 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
57 Group:          Applications/Communications
58 Requires:       %{name} = %{version}
59
60 %description plugin-idea
61 This package contains IDEA Crypt plugin for Irssi.
62
63 %description plugin-idea
64 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
65
66 %prep
67 %setup -q -n %{name}-%{version}-%{_rel} -a3
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %patch3 -p1
72 %patch4 -p1
73 %patch5 -p1
74
75 %build
76 rm -f missing
77 %{__libtoolize}
78 %{__aclocal} -I .
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --without-socks \
83         --with-bot \
84         --with-textui \
85         --with-proxy \
86         --with-terminfo \
87         --with-modules \
88         %{?with_perl:--with-perl=yes} \
89         %{?with_perl:--with-perl-lib=vendor} \
90         %{!?with_perl:--with-perl=no} \
91         %{?with_ipv6:--enable-ipv6} \
92         --enable-nls \
93         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
94
95 %{__make}
96
97 cd irssi-idea-%{_idea_ver}
98 rm -f missing
99 %{__libtoolize}
100 %{__aclocal} -I .
101 %{__autoconf}
102 %{__automake}
103 %configure
104
105 %{__make}
106
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         docdir=%{_datadir}/%{name}-%{version}
115
116 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
118
119 %{__make} -C irssi-idea-%{_idea_ver} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog README TODO NEWS docs/*.txt
128 %attr(755,root,root) %{_bindir}/*
129 %dir %{_libdir}/irssi
130 %dir %{_libdir}/irssi/modules
131 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
132 %{_datadir}/%{name}
133 %{_desktopdir}/irssi.desktop
134 %{_pixmapsdir}/*
135 %{_sysconfdir}/irssi.conf
136 %{_mandir}/man1/*
137
138 %if %{with perl}
139 %{perl_vendorarch}/*.pm
140 %dir %{perl_vendorarch}/Irssi
141 %{perl_vendorarch}/Irssi/*.pm
142
143 %dir %{perl_vendorarch}/auto/Irssi
144 %{perl_vendorarch}/auto/Irssi/*.bs
145 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
146
147 %dir %{perl_vendorarch}/auto/Irssi/Irc
148 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
149 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
150
151 %dir %{perl_vendorarch}/auto/Irssi/TextUI
152 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
153 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
154
155 %dir %{perl_vendorarch}/auto/Irssi/UI
156 %{perl_vendorarch}/auto/Irssi/UI/*.bs
157 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
158 %endif
159
160 %files plugin-idea
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.079939 seconds and 4 git commands to generate.