]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- %bcond_with new_bcond_style
[packages/irssi.git] / irssi.spec
1 # Conditional build:
2 %bcond_without  perl    # without perl support
3 %bcond_without  ipv6    # without IPv6 support
4 #
5 %define         _idea_ver       0.1.46
6 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
7 Summary:        Irssi is a IRC client
8 Summary(fr):    Irssi est un client IRC
9 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
10 Name:           irssi
11 Version:        0.8.9
12 Release:        1
13 License:        GPL
14 Group:          Applications/Communications
15 Source0:        http://real.irssi.org/files/%{name}-%{version}.tar.bz2
16 # Source0-md5:  6610ee0e27922f447e40828cf7dee507
17 Source1:        %{name}.desktop
18 Source2:        %{name}.png
19 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
20 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
21 #Patch0:                %{name}-dcc-send-limit.patch
22 Patch1:         %{name}-channel_auto_who.patch
23 Patch2:         %{name}-tinfo.patch
24 Patch3:         %{name}-home_etc.patch
25 URL:            http://www.irssi.org/
26 BuildRequires:  automake
27 BuildRequires:  autoconf
28 BuildRequires:  libtool
29 BuildRequires:  gettext-devel
30 BuildRequires:  glib-devel
31 BuildRequires:  glib2-devel >= 2.1.0
32 BuildRequires:  ncurses-devel >= 5.0
33 BuildRequires:  openssl-devel >= 0.9.7c
34 %{?with_perl:BuildRequires:     perl-devel >= 5.6.1}
35 BuildRequires:  pkgconfig
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37 Obsoletes:      %{name}-speech
38 Obsoletes:      %{name}-sql
39
40 %description
41 Irssi is a textUI IRC client with IPv6 support.
42
43 %description -l fr
44 Irssi est client IRC.
45
46 %description -l pl
47 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
48
49 %package plugin-idea
50 Summary:        Irssi plugin IDEA crypt
51 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
52 Group:          Applications/Communications
53 Requires:       %{name} = %{version}
54
55 %description plugin-idea
56 This package contains IDEA Crypt plugin for Irssi.
57
58 %description plugin-idea
59 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
60
61 %prep
62 %setup -q -a3
63 #%patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66 %patch3 -p1
67
68 %build
69 rm -f missing
70 %{__libtoolize}
71 %{__aclocal} -I .
72 %{__autoconf}
73 %{__automake}
74 %configure \
75         --without-socks \
76         --with-bot \
77         --with-textui \
78         --with-proxy \
79         --with-terminfo \
80         --with-modules \
81         %{?with_perl:--with-perl=yes} \
82         %{?with_perl:--with-perl-lib=vendor} \
83         %{!?with_perl:--with-perl=no} \
84         %{?with_ipv6:--enable-ipv6} \
85         --enable-nls
86
87 %{__make}
88
89 cd irssi-idea-%{_idea_ver}
90 rm -f missing
91 %{__libtoolize}
92 %{__aclocal} -I .
93 %{__autoconf}
94 %{__automake}
95 %configure
96
97 %{__make}
98
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT \
106         docdir=%{_datadir}/%{name}-%{version}
107
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
109 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
110
111 cd irssi-idea-%{_idea_ver}
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog README TODO NEWS docs/*.txt
121 %attr(755,root,root) %{_bindir}/*
122 %dir %{_libdir}/irssi
123 %dir %{_libdir}/irssi/modules
124 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
125 %{_datadir}/%{name}
126 %{_desktopdir}/irssi.desktop
127 %{_pixmapsdir}/*
128 %{_sysconfdir}/irssi.conf
129 %{_mandir}/man1/*
130
131 %if %{with perl}
132 %{perl_vendorarch}/*.pm
133 %dir %{perl_vendorarch}/Irssi
134 %{perl_vendorarch}/Irssi/*.pm
135
136 %dir %{perl_vendorarch}/auto/Irssi
137 %{perl_vendorarch}/auto/Irssi/*.bs
138 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
139
140 %dir %{perl_vendorarch}/auto/Irssi/Irc
141 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
142 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
143
144 %dir %{perl_vendorarch}/auto/Irssi/TextUI
145 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
146 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
147
148 %dir %{perl_vendorarch}/auto/Irssi/UI
149 %{perl_vendorarch}/auto/Irssi/UI/*.bs
150 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
151 %endif
152
153 %files plugin-idea
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.061023 seconds and 4 git commands to generate.