]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
a0676b3b9520da7ce72fd504912bf3e5e1c4dca7
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 #
7 %define         _idea_ver       0.1.46
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9 Summary:        Irssi is a IRC client
10 Summary(fr):    Irssi est un client IRC
11 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
12 Name:           irssi
13 Version:        0.8.9
14 Release:        2
15 License:        GPL
16 Group:          Applications/Communications
17 Source0:        http://real.irssi.org/files/%{name}-%{version}.tar.bz2
18 # Source0-md5:  6610ee0e27922f447e40828cf7dee507
19 Source1:        %{name}.desktop
20 Source2:        %{name}.png
21 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
22 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
23 #Patch0:                %{name}-dcc-send-limit.patch
24 Patch1:         %{name}-channel_auto_who.patch
25 Patch2:         %{name}-tinfo.patch
26 Patch3:         %{name}-home_etc.patch
27 URL:            http://www.irssi.org/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  gettext-devel
31 BuildRequires:  glib-devel
32 BuildRequires:  glib2-devel >= 2.1.0
33 BuildRequires:  libtool
34 BuildRequires:  ncurses-devel >= 5.0
35 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7c}
36 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.0}
37 BuildRequires:  pkgconfig
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39 Obsoletes:      %{name}-speech
40 Obsoletes:      %{name}-sql
41
42 %description
43 Irssi is a textUI IRC client with IPv6 support.
44
45 %description -l fr
46 Irssi est client IRC.
47
48 %description -l pl
49 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
50
51 %package plugin-idea
52 Summary:        Irssi plugin IDEA crypt
53 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
54 Group:          Applications/Communications
55 Requires:       %{name} = %{version}
56
57 %description plugin-idea
58 This package contains IDEA Crypt plugin for Irssi.
59
60 %description plugin-idea
61 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
62
63 %prep
64 %setup -q -a3
65 #%patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 %build
71 rm -f missing
72 %{__libtoolize}
73 %{__aclocal} -I .
74 %{__autoconf}
75 %{__automake}
76 %configure \
77         --without-socks \
78         --with-bot \
79         --with-textui \
80         --with-proxy \
81         --with-terminfo \
82         --with-modules \
83         %{?with_perl:--with-perl=yes} \
84         %{?with_perl:--with-perl-lib=vendor} \
85         %{!?with_perl:--with-perl=no} \
86         %{?with_ipv6:--enable-ipv6} \
87         --enable-nls \
88         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
89
90 %{__make}
91
92 cd irssi-idea-%{_idea_ver}
93 rm -f missing
94 %{__libtoolize}
95 %{__aclocal} -I .
96 %{__autoconf}
97 %{__automake}
98 %configure
99
100 %{__make}
101
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT \
109         docdir=%{_datadir}/%{name}-%{version}
110
111 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
112 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
113
114 %{__make} -C irssi-idea-%{_idea_ver} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog README TODO NEWS docs/*.txt
123 %attr(755,root,root) %{_bindir}/*
124 %dir %{_libdir}/irssi
125 %dir %{_libdir}/irssi/modules
126 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
127 %{_datadir}/%{name}
128 %{_desktopdir}/irssi.desktop
129 %{_pixmapsdir}/*
130 %{_sysconfdir}/irssi.conf
131 %{_mandir}/man1/*
132
133 %if %{with perl}
134 %{perl_vendorarch}/*.pm
135 %dir %{perl_vendorarch}/Irssi
136 %{perl_vendorarch}/Irssi/*.pm
137
138 %dir %{perl_vendorarch}/auto/Irssi
139 %{perl_vendorarch}/auto/Irssi/*.bs
140 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
141
142 %dir %{perl_vendorarch}/auto/Irssi/Irc
143 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
144 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
145
146 %dir %{perl_vendorarch}/auto/Irssi/TextUI
147 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
148 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
149
150 %dir %{perl_vendorarch}/auto/Irssi/UI
151 %{perl_vendorarch}/auto/Irssi/UI/*.bs
152 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
153 %endif
154
155 %files plugin-idea
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.031114 seconds and 3 git commands to generate.