]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
70c9c7fdeddc1d24eaed0b5e25cff84c43b0417e
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7 #
8 #define         _snap           20050301
9 #define         _rc             rc5
10 %define         _idea_ver       0.1.46
11 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
12 Summary:        Irssi is a IRC client
13 Summary(fr):    Irssi est un client IRC
14 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
15 Name:           irssi
16 Version:        0.8.10
17 Release:        2
18 License:        GPL
19 Group:          Applications/Communications
20 #Source0:       http://irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
21 Source0:        http://irssi.org/files/%{name}-%{version}.tar.gz
22 # Source0-md5:  ed29412e86e1d5fbb71d24ae02edd462
23 Source1:        %{name}.desktop
24 Source2:        %{name}.png
25 Source3:        http://real.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
26 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
27 Patch0:         %{name}-dcc-send-limit.patch
28 Patch1:         %{name}-tinfo.patch
29 Patch2:         %{name}-home_etc.patch
30 Patch3:         %{name}.conf.patch
31 Patch4:         %{name}-idea-listlen.patch
32 Patch5:         %{name}-gcc4.patch
33 Patch6:         %{name}-dynamic.patch
34 URL:            http://www.irssi.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib-devel
39 BuildRequires:  glib2-devel >= 2.1.0
40 BuildRequires:  libtool
41 BuildRequires:  ncurses-devel >= 5.0
42 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
43 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
44 BuildRequires:  pkgconfig
45 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
46 Obsoletes:      %{name}-speech
47 Obsoletes:      %{name}-sql
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Irssi is a textUI IRC client with IPv6 support.
52
53 %description -l fr
54 Irssi est client IRC.
55
56 %description -l pl
57 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
58
59 %package plugin-idea
60 Summary:        Irssi plugin IDEA crypt
61 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
62 Group:          Applications/Communications
63 Requires:       %{name} = %{version}
64
65 %description plugin-idea
66 This package contains IDEA Crypt plugin for Irssi.
67
68 %description plugin-idea
69 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
70
71 %prep
72 %setup -q -a3
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77 %patch4 -p1
78 %patch5 -p1
79 %if %{with dynamic}
80 %patch6 -p1
81 %endif
82
83 %build
84 rm -f missing
85 %{__libtoolize}
86 %{__aclocal} -I .
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         --without-socks \
91         --with-bot \
92         --with-textui \
93         --with-proxy \
94         --with-terminfo \
95         --with-modules \
96         %{?with_perl:--with-perl=yes} \
97         %{?with_perl:--with-perl-lib=vendor} \
98         %{!?with_perl:--with-perl=no} \
99         %{?with_ipv6:--enable-ipv6} \
100         --enable-nls \
101         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
102
103 %{__make}
104
105 cd irssi-idea-%{_idea_ver}
106 rm -f missing
107 %{__libtoolize}
108 %{__aclocal} -I .
109 %{__autoconf}
110 %{__automake}
111 %configure
112
113 %{__make}
114
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT \
122         docdir=%{_datadir}/%{name}-%{version}
123
124 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
125 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
126
127 %{__make} -C irssi-idea-%{_idea_ver} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
136 %attr(755,root,root) %{_bindir}/*
137 %dir %{_libdir}/irssi
138 %dir %{_libdir}/irssi/modules
139 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
140 %if %{with dynamic}
141 %attr(755,root,root) %{_libdir}/libirssi*.so.*
142 %endif
143 %{_datadir}/%{name}
144 %{_desktopdir}/irssi.desktop
145 %{_pixmapsdir}/*
146 %{_sysconfdir}/irssi.conf
147 %{_mandir}/man1/*
148
149 %if %{with perl}
150 %{perl_vendorarch}/*.pm
151 %dir %{perl_vendorarch}/Irssi
152 %{perl_vendorarch}/Irssi/*.pm
153
154 %dir %{perl_vendorarch}/auto/Irssi
155 %{perl_vendorarch}/auto/Irssi/*.bs
156 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
157
158 %dir %{perl_vendorarch}/auto/Irssi/Irc
159 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
160 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
161
162 %dir %{perl_vendorarch}/auto/Irssi/TextUI
163 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
164 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
165
166 %dir %{perl_vendorarch}/auto/Irssi/UI
167 %{perl_vendorarch}/auto/Irssi/UI/*.bs
168 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
169 %endif
170
171 %files plugin-idea
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.044216 seconds and 3 git commands to generate.