]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- fixed to build with _libdir
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7 #
8 %define         _snap           20050301
9 %define         _rc             rc5
10 %define         _idea_ver       0.1.46
11 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
12 Summary:        Irssi is a IRC client
13 Summary(fr):    Irssi est un client IRC
14 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
15 Name:           irssi
16 Version:        0.8.10
17 Release:        0.%{_snap}.1
18 License:        GPL
19 Group:          Applications/Communications
20 Source0:        http://real.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
21 # Source0-md5:  f8da44dd0584857168b494f2365c6b2f
22 Source1:        %{name}.desktop
23 Source2:        %{name}.png
24 Source3:        http://real.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
25 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
26 Patch0:         %{name}-dcc-send-limit.patch
27 Patch1:         %{name}-tinfo.patch
28 Patch2:         %{name}-home_etc.patch
29 Patch3:         %{name}.conf.patch
30 Patch4:         %{name}-idea-listlen.patch
31 Patch5:         %{name}-gcc4.patch
32 Patch6:         %{name}-dynamic.patch
33 URL:            http://www.irssi.org/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  gettext-devel
37 BuildRequires:  glib-devel
38 BuildRequires:  glib2-devel >= 2.1.0
39 BuildRequires:  libtool
40 BuildRequires:  ncurses-devel >= 5.0
41 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
42 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
43 BuildRequires:  pkgconfig
44 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
45 Obsoletes:      %{name}-speech
46 Obsoletes:      %{name}-sql
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Irssi is a textUI IRC client with IPv6 support.
51
52 %description -l fr
53 Irssi est client IRC.
54
55 %description -l pl
56 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
57
58 %package plugin-idea
59 Summary:        Irssi plugin IDEA crypt
60 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
61 Group:          Applications/Communications
62 Requires:       %{name} = %{version}
63
64 %description plugin-idea
65 This package contains IDEA Crypt plugin for Irssi.
66
67 %description plugin-idea
68 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
69
70 %prep
71 %setup -q -n %{name}-%{version}-%{_rc} -a3
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77 %patch5 -p1
78 %if %{with dynamic}
79 %patch6 -p1
80 %endif
81
82 %build
83 rm -f missing
84 %{__libtoolize}
85 %{__aclocal} -I .
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --without-socks \
90         --with-bot \
91         --with-textui \
92         --with-proxy \
93         --with-terminfo \
94         --with-modules \
95         %{?with_perl:--with-perl=yes} \
96         %{?with_perl:--with-perl-lib=vendor} \
97         %{!?with_perl:--with-perl=no} \
98         %{?with_ipv6:--enable-ipv6} \
99         --enable-nls \
100         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
101
102 %{__make}
103
104 cd irssi-idea-%{_idea_ver}
105 rm -f missing
106 %{__libtoolize}
107 %{__aclocal} -I .
108 %{__autoconf}
109 %{__automake}
110 %configure
111
112 %{__make}
113
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT \
121         docdir=%{_datadir}/%{name}-%{version}
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
124 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
125
126 %{__make} -C irssi-idea-%{_idea_ver} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
135 %attr(755,root,root) %{_bindir}/*
136 %dir %{_libdir}/irssi
137 %dir %{_libdir}/irssi/modules
138 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
139 %if %{with dynamic}
140 %attr(755,root,root) %{_libdir}/libirssi*.so.*
141 %endif
142 %{_datadir}/%{name}
143 %{_desktopdir}/irssi.desktop
144 %{_pixmapsdir}/*
145 %{_sysconfdir}/irssi.conf
146 %{_mandir}/man1/*
147
148 %if %{with perl}
149 %{perl_vendorarch}/*.pm
150 %dir %{perl_vendorarch}/Irssi
151 %{perl_vendorarch}/Irssi/*.pm
152
153 %dir %{perl_vendorarch}/auto/Irssi
154 %{perl_vendorarch}/auto/Irssi/*.bs
155 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
156
157 %dir %{perl_vendorarch}/auto/Irssi/Irc
158 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
159 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
160
161 %dir %{perl_vendorarch}/auto/Irssi/TextUI
162 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
163 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
164
165 %dir %{perl_vendorarch}/auto/Irssi/UI
166 %{perl_vendorarch}/auto/Irssi/UI/*.bs
167 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
168 %endif
169
170 %files plugin-idea
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.039795 seconds and 3 git commands to generate.