]> git.pld-linux.org Git - packages/ipset.git/commitdiff
- fix build with linux 3.3
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 6 Apr 2012 20:37:01 +0000 (20:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ipset-kernel-3.3.patch -> 1.1
    ipset.spec -> 1.155

ipset-kernel-3.3.patch [new file with mode: 0644]
ipset.spec

diff --git a/ipset-kernel-3.3.patch b/ipset-kernel-3.3.patch
new file mode 100644 (file)
index 0000000..f8c8fe1
--- /dev/null
@@ -0,0 +1,33 @@
+--- ipset-6.11/kernel/net/netfilter/ipset/ip_set_getport.c~    2012-01-13 21:26:27.000000000 +0100
++++ ipset-6.11/kernel/net/netfilter/ipset/ip_set_getport.c     2012-04-06 22:33:28.410967308 +0200
+@@ -119,9 +119,16 @@
+ {
+       int protoff;
+       u8 nexthdr;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,3,0)
++      __be16 frag_off;
++#endif
+       nexthdr = ipv6_hdr(skb)->nexthdr;
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,3,0)
++      protoff = ipv6_skip_exthdr(skb, sizeof(struct ipv6hdr), &nexthdr, &frag_off);
++#else
+       protoff = ipv6_skip_exthdr(skb, sizeof(struct ipv6hdr), &nexthdr);
++#endif
+       if (protoff < 0)
+               return false;
+--- ipset-6.11/kernel/net/netfilter/ipset/ip_set_hash_ip.c~    2011-10-04 17:18:10.000000000 +0200
++++ ipset-6.11/kernel/net/netfilter/ipset/ip_set_hash_ip.c     2012-04-06 22:35:56.923721440 +0200
+@@ -241,7 +241,11 @@
+ static inline void
+ hash_ip6_data_copy(struct hash_ip6_elem *dst, const struct hash_ip6_elem *src)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,3,0)
++      dst->ip.in6 = src->ip.in6;
++#else
+       ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
++#endif
+ }
+ static inline void
index 60e33a78bd7546723e0959a10d94fbd6b3219de4..e7f30246ae2d1b7c2808cb895505175962bf3242 100644 (file)
@@ -35,6 +35,7 @@ Source0:      http://ipset.netfilter.org/%{pname}-%{version}.tar.bz2
 Source1:       %{pname}.init
 Patch0:                %{pname}-no_kernel.patch
 Patch1:                %{pname}-hash-net-if-fix.patch
+Patch2:                %{pname}-kernel-3.3.patch
 URL:           http://ipset.netfilter.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -135,6 +136,7 @@ Ten pakiet zawiera moduły jądra oferujące wsparcie dla zbiorów IP.
 %setup -q -n %{pname}-%{version}
 %{!?with_kernel:%patch0 -p1}
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -198,7 +200,7 @@ fi
 %doc ChangeLog ChangeLog.ippool README UPGRADE
 %attr(755,root,root) %{_sbindir}/ipset
 %attr(755,root,root) %{_libdir}/libipset.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libipset.so.1
+%attr(755,root,root) %ghost %{_libdir}/libipset.so.2
 %{_mandir}/man8/ipset.8*
 
 %files devel
This page took 0.107682 seconds and 4 git commands to generate.