]> git.pld-linux.org Git - packages/ipset.git/blob - ipset.spec
- new spec
[packages/ipset.git] / ipset.spec
1 #
2 # TODO:
3 #       - -devel subpackage
4 #       - Requires and BuildRequires with proper versions
5 #
6 Summary:        IP sets utility
7 Name:           ipset
8 %define version_base 2.2.6
9 %define version_tstamp 20051028
10 Version:        %{version_base}_%{version_tstamp}
11 Release:        0.1
12 License:        GPL
13 Group:          Networking/Admin
14 Source0:        http://ipset.netfilter.org/%{name}-%{version_base}-%{version_tstamp}.tar.bz2
15 # Source0-md5:  f44ed0ddb714060716677838cd19045c
16 URL:            http://ipset.netfilter.org/
17 BuildRequires:  linux-libc-headers >= 2.6.11.1
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # not all set types are supported by our kernel and linux-libc-headers
21 %define _settypes ipmap portmap macipmap iphash nethash iptree
22
23 %description
24 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
25 can be administered by the ipset utility. Depending on the type,
26 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
27 IP addresses with MAC addresses in a way, which ensures lightning
28 speed when matching an entry against a set.
29
30 %prep
31 %setup -qn %{name}-%{version_base}
32
33 %build
34 %{__make} \
35         PREFIX="%{_prefix}" \
36         LIBDIR="%{_libdir}" \
37         MANDIR="%{_mandir}" \
38         BINDIR="%{_sbindir}" \
39         SETTYPES:="%{_settypes}" \
40         COPT_FLAGS:="%{rpmcflags}"
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR="$RPM_BUILD_ROOT" \
47         PREFIX="%{_prefix}" \
48         LIBDIR="%{_libdir}" \
49         MANDIR="%{_mandir}" \
50         BINDIR="%{_sbindir}" \
51         SETTYPES:="%{_settypes}"
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc ChangeLog ChangeLog.ippool TODO
59 %attr(755,root,root) %{_sbindir}/*
60 %dir %{_libdir}/ipset
61 %attr(755,root,root) %{_libdir}/ipset/*.so
62 %{_mandir}/man8/*
This page took 0.07025 seconds and 4 git commands to generate.