]> git.pld-linux.org Git - packages/inn.git/commitdiff
- 2.3.3, updated ipv6 and db3 patches, added ac253 patch for new autoconf
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 9 May 2002 22:23:27 +0000 (22:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- HOME for user news is /home/services/news now (to work as news user)
- wait up to 0.5s for innwatch start to avoid false "FAIL" message

Changed files:
    inn-ac253.patch -> 1.1.2.1
    inn-db3.patch -> 1.1.2.1
    inn-ipv6.patch -> 1.1.2.1
    inn.init -> 1.15.2.1
    inn.spec -> 1.115.2.1

inn-ac253.patch [new file with mode: 0644]
inn-db3.patch
inn-ipv6.patch
inn.init
inn.spec

diff --git a/inn-ac253.patch b/inn-ac253.patch
new file mode 100644 (file)
index 0000000..709ce81
--- /dev/null
@@ -0,0 +1,11 @@
+--- inn-2.3.3/configure.in.orig        Thu May  9 22:30:20 2002
++++ inn-2.3.3/configure.in     Thu May  9 22:31:32 2002
+@@ -1297,7 +1297,7 @@
+    INN_TYPE_FPOS_T_LARGE
+ fi
+-MISSING_OBJ="$LIBOBJS"
++MISSING_OBJ="$LIB@&t@OBJS"
+ MISSING_SRC=`echo "$MISSING_OBJ" | sed 's/\.o/.c/g'`
+ if test "$ac_cv_func_strcasecmp" = no ; then
index b8e99d684d330818e721b24229a9be3bc96cd698..60c6dfef35efa65b3ca5972be41fb6c6be70f454 100644 (file)
@@ -1,18 +1,42 @@
---- inn-2.3.1/configure.in.orig        Sun Jan 21 04:29:26 2001
-+++ inn-2.3.1/configure.in     Sun Jan 21 04:40:55 2001
-@@ -750,8 +750,9 @@
+diff -Nur inn-2.3.3.orig/authprogs/ckpasswd.c inn-2.3.3/authprogs/ckpasswd.c
+--- inn-2.3.3.orig/authprogs/ckpasswd.c        Mon May  6 08:02:07 2002
++++ inn-2.3.3/authprogs/ckpasswd.c     Thu May  9 22:29:51 2002
+@@ -14,15 +14,8 @@
+ # include <fcntl.h>
+ #endif
+-#if HAVE_DBM
+-# ifdef HAVE_NDBM_H
+-#  include <ndbm.h>
+-# else
+-#  ifdef HAVE_DB1_NDBM_H
+-#   include <db1/ndbm.h>
+-#  endif
+-# endif
+-#endif
++#define DB_DBM_HSEARCH 1
++#include <db.h>
+ #ifdef HAVE_GETSPNAM
+ # include <shadow.h>
+diff -Nur inn-2.3.3.orig/configure.in inn-2.3.3/configure.in
+--- inn-2.3.3.orig/configure.in        Thu May  9 22:28:03 2002
++++ inn-2.3.3/configure.in     Thu May  9 22:29:23 2002
+@@ -762,12 +762,7 @@
+ AC_CHECK_LIB(regex, regexec)
  dnl Some of the authentication programs want to be able to open dbm files.
- dnl
- dnl FIXME: These conflict.  What order should they really be in?
--AC_CHECK_LIB(dbm, dbm_open, DBM_LIB="-ldbm")
--AC_CHECK_LIB(ndbm, dbm_open, DBM_LIB="-lndbm")
-+dnl AC_CHECK_LIB(dbm, dbm_open, DBM_LIB="-ldbm")
-+dnl AC_CHECK_LIB(ndbm, dbm_open, DBM_LIB="-lndbm")
+-inn_save_LIBS=$LIBS
+-LIBS=
+-AC_SEARCH_LIBS(dbm_open, ndbm dbm,
+-               [DBM_LIB=$LIBS
+-              AC_DEFINE(HAVE_DBM, 1, [Define if you have a dbm library.])])
+-LIBS=$inn_save_LIBS
 +DBM_LIB="-ldb"
  AC_SUBST(DBM_LIB)
  
  dnl Libraries and flags for embedded Perl.  Some distributions of Linux have
-@@ -955,14 +956,9 @@
+@@ -991,15 +986,10 @@
  
  dnl Generic checks for header files.
  dnl NOTUSED: sys/file.h sys/ioctl.h
 +AC_CHECK_HEADERS(crypt.h fcntl.h limits.h stddef.h stdint.h \
                   sys/bitypes.h sys/file.h sys/filio.h sys/ioctl.h \
                   sys/select.h sys/sysinfo.h sys/time.h unistd.h)
--
 -dnl Some Linux systems have db1/ndbm.h instead of ndbm.h.
 -if test x"$ac_cv_header_ndbm_h" = xno ; then
 -    AC_CHECK_HEADERS(db1/ndbm.h)
 -fi
+-
  dnl Checks for typedefs, structures, and compiler characteristics.
  AC_STRUCT_ST_BLKSIZE
---- inn-2.3.1/authprogs/ckpasswd.c~    Thu Jan 11 09:55:23 2001
-+++ inn-2.3.1/authprogs/ckpasswd.c     Sun Jan 21 04:37:54 2001
-@@ -14,13 +14,8 @@
- # include <fcntl.h>
- #endif
--#ifdef HAVE_NDBM_H
--# include <ndbm.h>
--#else
--# ifdef HAVE_DB1_NDBM_H
--#  include <db1/ndbm.h>
--# endif
--#endif
-+#define DB_DBM_HSEARCH 1
-+#include <db.h>
- #ifdef HAVE_GETSPNAM
- # include <shadow.h>
+ AC_STRUCT_TM
index d124c364829262639a5c3a4b37e6c318385db41c..1eece94d8be8a3c610d53032cbd1ba5096d6e72d 100644 (file)
@@ -1674,15 +1674,15 @@ diff -Nur inn-2.3.2.orig/innfeed/host.h inn-2.3.2/innfeed/host.h
  
  /*
   * Functions used by the Connection to indicate Connection state.
-diff -Nur inn-2.3.2.orig/lib/Makefile inn-2.3.2/lib/Makefile
---- inn-2.3.2.orig/lib/Makefile        Thu May  3 22:27:32 2001
-+++ inn-2.3.2/lib/Makefile     Tue Jun 19 16:06:41 2001
+diff -Nur inn-2.3.3.orig/lib/Makefile inn-2.3.3/lib/Makefile
+--- inn-2.3.3.orig/lib/Makefile        Thu May  3 22:27:32 2001
++++ inn-2.3.3/lib/Makefile     Tue Jun 19 16:06:41 2001
 @@ -16,7 +16,7 @@
        md5.c nonblocking.c parsedate.c perl.c qio.c radix32.c readin.c \
        remopen.c reservedfd.c resource.c rwlock.c sendarticle.c \
        sendpass.c tempname.c waitnb.c wildmat.c version.c xfopena.c \
--      xmalloc.c xsignal.c xwrite.c xwritev.c
-+      xmalloc.c xsignal.c xwrite.c xwritev.c inet_ntoa.c
+-      xmalloc.c xsignal.c xwrite.c
++      xmalloc.c xsignal.c xwrite.c inet_ntoa.c
  
  OBJECTS = $(MISSING_OBJ) \
        argparse.o checkart.o cleanfrom.o clientactive.o clientlib.o \
@@ -1690,8 +1690,8 @@ diff -Nur inn-2.3.2.orig/lib/Makefile inn-2.3.2/lib/Makefile
        md5.o nonblocking.o parsedate.o qio.o radix32.o readin.o \
        remopen.o reservedfd.o resource.o rwlock.o sendarticle.o \
        sendpass.o tempname.o waitnb.o wildmat.o version.o xfopena.o \
--      xmalloc.o xsignal.o xwrite.o xwritev.o
-+      xmalloc.o xsignal.o xwrite.o xwritev.o inet_ntoa.o
+-      xmalloc.o xsignal.o xwrite.o
++      xmalloc.o xsignal.o xwrite.o inet_ntoa.o
  
  LOBJECTS= $(OBJECTS:.o=.lo)
  
index 1be69618092310f2e47f799c4eb97509dc7805f2..e208f76bb4a27a49c87576a0a1e287fc7d418bf9 100644 (file)
--- a/inn.init
+++ b/inn.init
@@ -36,6 +36,7 @@ case "$1" in
                        su news -c "umask 002 ; /usr/bin/setsid /usr/bin/innwatch &" </dev/null >&0 2>&0
                        RETVAL=$?
                        [ $RETVAL -eq 0 ] && touch /var/lock/subsys/inn
+                       ps -C innwatch >/dev/null 2>&1 || usleep 500000
                        if ps -C innwatch >/dev/null 2>&1; then
                                deltext;ok
                        else
index 405a2f7d8f274c0d8533db78c2abc90ed25d8953..0466911d90f4ac9b80c6228c28d5a88e85054e74 100644 (file)
--- a/inn.spec
+++ b/inn.spec
@@ -7,8 +7,8 @@ Summary(pl):    INN, serwer nowinek
 Summary(pt_BR):        INN, InterNet News System (servidor news)
 Summary(tr):   INN, InterNet Haber Sistemi (haber sunucu)
 Name:          inn
-Version:       2.3.2
-Release:       10
+Version:       2.3.3
+Release:       1
 License:       distributable
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/inn/%{name}-%{version}.tar.gz
@@ -33,6 +33,7 @@ Patch4:               %{name}-setreuid.patch
 Patch5:                %{name}-sec.patch
 Patch6:                %{name}-frsize.patch
 Patch7:                %{name}-ac25x.patch
+Patch8:                %{name}-ac253.patch
 URL:           http://www.isc.org/inn.html
 BuildRequires: autoconf
 BuildRequires: libtool
@@ -49,12 +50,12 @@ Requires:   util-linux
 Requires:      procps
 Requires:      textutils
 Requires:      awk
-Prereq:                /sbin/chkconfig
-Prereq:                /sbin/ldconfig
-Prereq:                rc-scripts
-Prereq:                sed
-Prereq:                fileutils
-Prereq:                %{name}-libs = %{version}
+PreReq:                %{name}-libs = %{version}
+PreReq:                rc-scripts
+Requires(post,preun):  /sbin/chkconfig
+Requires(post):        sed
+Requires(post):        fileutils
+Requires(post):        /usr/sbin/usermod
 Provides:      nntpserver
 Obsoletes:     leafnode
 Obsoletes:     leafnode+
@@ -242,6 +243,7 @@ sunucuya makaleyi yollar.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 %build
 touch innfeed/*.[ly]
@@ -284,7 +286,8 @@ install -d $RPM_BUILD_ROOT/etc/{news,rc.d/init.d,cron.d,logrotate.d} \
        $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/news/{control,filter,auth}} \
        $RPM_BUILD_ROOT%{_mandir}/{man{1,3,5,8},pl/man{1,8}} \
        $RPM_BUILD_ROOT/var/{run/news,lib/news/backoff,log/{news,archiv/news}} \
-       $RPM_BUILD_ROOT/var/spool/news/{articles,overview,incoming/{tmp,bad},outgoing,archive,uniover,innfeed,cycbuffs}
+       $RPM_BUILD_ROOT/var/spool/news/{articles,overview,incoming/{tmp,bad},outgoing,archive,uniover,innfeed,cycbuffs} \
+       $RPM_BUILD_ROOT/home/services/news
 
 %{__make} install \
        DESTDIR="$RPM_BUILD_ROOT" \
@@ -339,6 +342,9 @@ gzip -9nf CONTRIBUTORS INSTALL HISTORY README* ChangeLog LICENSE NEWS
 rm -rf $RPM_BUILD_ROOT
 
 %post
+if [ "`su - news -s /bin/sh -c pwd 2>/dev/null`" = "/var/spool/news" ]; then
+       /usr/sbin/usermod -d /home/services/news news
+fi
 if [ -f /var/lib/news/history ]; then
        cd /var/lib/news
        %{_bindir}/makedbz -s `wc -l <history` -f history
@@ -427,8 +433,8 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del inn
 fi
 
-%post libs -p /sbin/ldconfig
-%postun libs -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
This page took 0.207623 seconds and 4 git commands to generate.