]> git.pld-linux.org Git - packages/inn.git/commitdiff
- merge from DEVEL
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 31 Oct 2002 09:53:46 +0000 (09:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    inn-db3.patch -> 1.2
    inn-ipv6.patch -> 1.2

inn-db3.patch
inn-ipv6.patch

index b8e99d684d330818e721b24229a9be3bc96cd698..60c6dfef35efa65b3ca5972be41fb6c6be70f454 100644 (file)
@@ -1,18 +1,42 @@
---- inn-2.3.1/configure.in.orig        Sun Jan 21 04:29:26 2001
-+++ inn-2.3.1/configure.in     Sun Jan 21 04:40:55 2001
-@@ -750,8 +750,9 @@
+diff -Nur inn-2.3.3.orig/authprogs/ckpasswd.c inn-2.3.3/authprogs/ckpasswd.c
+--- inn-2.3.3.orig/authprogs/ckpasswd.c        Mon May  6 08:02:07 2002
++++ inn-2.3.3/authprogs/ckpasswd.c     Thu May  9 22:29:51 2002
+@@ -14,15 +14,8 @@
+ # include <fcntl.h>
+ #endif
+-#if HAVE_DBM
+-# ifdef HAVE_NDBM_H
+-#  include <ndbm.h>
+-# else
+-#  ifdef HAVE_DB1_NDBM_H
+-#   include <db1/ndbm.h>
+-#  endif
+-# endif
+-#endif
++#define DB_DBM_HSEARCH 1
++#include <db.h>
+ #ifdef HAVE_GETSPNAM
+ # include <shadow.h>
+diff -Nur inn-2.3.3.orig/configure.in inn-2.3.3/configure.in
+--- inn-2.3.3.orig/configure.in        Thu May  9 22:28:03 2002
++++ inn-2.3.3/configure.in     Thu May  9 22:29:23 2002
+@@ -762,12 +762,7 @@
+ AC_CHECK_LIB(regex, regexec)
  dnl Some of the authentication programs want to be able to open dbm files.
- dnl
- dnl FIXME: These conflict.  What order should they really be in?
--AC_CHECK_LIB(dbm, dbm_open, DBM_LIB="-ldbm")
--AC_CHECK_LIB(ndbm, dbm_open, DBM_LIB="-lndbm")
-+dnl AC_CHECK_LIB(dbm, dbm_open, DBM_LIB="-ldbm")
-+dnl AC_CHECK_LIB(ndbm, dbm_open, DBM_LIB="-lndbm")
+-inn_save_LIBS=$LIBS
+-LIBS=
+-AC_SEARCH_LIBS(dbm_open, ndbm dbm,
+-               [DBM_LIB=$LIBS
+-              AC_DEFINE(HAVE_DBM, 1, [Define if you have a dbm library.])])
+-LIBS=$inn_save_LIBS
 +DBM_LIB="-ldb"
  AC_SUBST(DBM_LIB)
  
  dnl Libraries and flags for embedded Perl.  Some distributions of Linux have
-@@ -955,14 +956,9 @@
+@@ -991,15 +986,10 @@
  
  dnl Generic checks for header files.
  dnl NOTUSED: sys/file.h sys/ioctl.h
 +AC_CHECK_HEADERS(crypt.h fcntl.h limits.h stddef.h stdint.h \
                   sys/bitypes.h sys/file.h sys/filio.h sys/ioctl.h \
                   sys/select.h sys/sysinfo.h sys/time.h unistd.h)
--
 -dnl Some Linux systems have db1/ndbm.h instead of ndbm.h.
 -if test x"$ac_cv_header_ndbm_h" = xno ; then
 -    AC_CHECK_HEADERS(db1/ndbm.h)
 -fi
+-
  dnl Checks for typedefs, structures, and compiler characteristics.
  AC_STRUCT_ST_BLKSIZE
---- inn-2.3.1/authprogs/ckpasswd.c~    Thu Jan 11 09:55:23 2001
-+++ inn-2.3.1/authprogs/ckpasswd.c     Sun Jan 21 04:37:54 2001
-@@ -14,13 +14,8 @@
- # include <fcntl.h>
- #endif
--#ifdef HAVE_NDBM_H
--# include <ndbm.h>
--#else
--# ifdef HAVE_DB1_NDBM_H
--#  include <db1/ndbm.h>
--# endif
--#endif
-+#define DB_DBM_HSEARCH 1
-+#include <db.h>
- #ifdef HAVE_GETSPNAM
- # include <shadow.h>
+ AC_STRUCT_TM
index d124c364829262639a5c3a4b37e6c318385db41c..1eece94d8be8a3c610d53032cbd1ba5096d6e72d 100644 (file)
@@ -1674,15 +1674,15 @@ diff -Nur inn-2.3.2.orig/innfeed/host.h inn-2.3.2/innfeed/host.h
  
  /*
   * Functions used by the Connection to indicate Connection state.
-diff -Nur inn-2.3.2.orig/lib/Makefile inn-2.3.2/lib/Makefile
---- inn-2.3.2.orig/lib/Makefile        Thu May  3 22:27:32 2001
-+++ inn-2.3.2/lib/Makefile     Tue Jun 19 16:06:41 2001
+diff -Nur inn-2.3.3.orig/lib/Makefile inn-2.3.3/lib/Makefile
+--- inn-2.3.3.orig/lib/Makefile        Thu May  3 22:27:32 2001
++++ inn-2.3.3/lib/Makefile     Tue Jun 19 16:06:41 2001
 @@ -16,7 +16,7 @@
        md5.c nonblocking.c parsedate.c perl.c qio.c radix32.c readin.c \
        remopen.c reservedfd.c resource.c rwlock.c sendarticle.c \
        sendpass.c tempname.c waitnb.c wildmat.c version.c xfopena.c \
--      xmalloc.c xsignal.c xwrite.c xwritev.c
-+      xmalloc.c xsignal.c xwrite.c xwritev.c inet_ntoa.c
+-      xmalloc.c xsignal.c xwrite.c
++      xmalloc.c xsignal.c xwrite.c inet_ntoa.c
  
  OBJECTS = $(MISSING_OBJ) \
        argparse.o checkart.o cleanfrom.o clientactive.o clientlib.o \
@@ -1690,8 +1690,8 @@ diff -Nur inn-2.3.2.orig/lib/Makefile inn-2.3.2/lib/Makefile
        md5.o nonblocking.o parsedate.o qio.o radix32.o readin.o \
        remopen.o reservedfd.o resource.o rwlock.o sendarticle.o \
        sendpass.o tempname.o waitnb.o wildmat.o version.o xfopena.o \
--      xmalloc.o xsignal.o xwrite.o xwritev.o
-+      xmalloc.o xsignal.o xwrite.o xwritev.o inet_ntoa.o
+-      xmalloc.o xsignal.o xwrite.o
++      xmalloc.o xsignal.o xwrite.o inet_ntoa.o
  
  LOBJECTS= $(OBJECTS:.o=.lo)
  
This page took 0.055096 seconds and 4 git commands to generate.