]> git.pld-linux.org Git - packages/icu.git/blob - icu.spec
- updated to 57.1 (new soname as usual...)
[packages/icu.git] / icu.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         ver     %(echo %{version} | tr . _)
6 Summary:        International Components for Unicode
7 Summary(pl.UTF-8):      Międzynarodowe komponenty dla unikodu
8 Name:           icu
9 Version:        57.1
10 Release:        1
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{ver}-src.tgz
14 # Source0-md5:  976734806026a4ef8bdd17937c8898b9
15 URL:            http://www.icu-project.org/
16 BuildRequires:  autoconf >= 2.69
17 BuildRequires:  libstdc++-devel
18 Requires:       libicu = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 ICU is a set of C and C++ libraries that provides robust and
23 full-featured Unicode and locale support. The library provides
24 calendar support, conversions for many character sets, language
25 sensitive collation, date and time formatting, support for many
26 locales, message catalogs and resources, message formatting,
27 normalization, number and currency formatting, time zones support,
28 transliteration, word, line and sentence breaking, etc.
29
30 This package contains the Unicode character database and derived
31 properties, along with converters and time zones data.
32
33 %description -l pl.UTF-8
34 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
35 obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
36 kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
37 języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
38 katalogów komunikatów i zasobów, formatowanie komunikatów,
39 normalizację, formatowanie liczb i walut, obsługę stref czasowych,
40 transliterację, łamanie słów, linii i zdań itp.
41
42 Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
43 konwerterami i danymi stref czasowych.
44
45 %package -n libicu
46 Summary:        International Components for Unicode (libraries)
47 Summary(pl.UTF-8):      Międzynarodowe Komponenty dla Unikodu (biblioteki)
48 Group:          Libraries
49 Obsoletes:      libicu30
50
51 %description -n libicu
52 ICU is a set of C and C++ libraries that provides robust and
53 full-featured Unicode support. This package contains the runtime
54 libraries for ICU. It does not contain any of the data files needed at
55 runtime and present in the `icu' package.
56
57 %description -n libicu -l pl.UTF-8
58 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
59 obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
60 uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
61 czasie działania i obecnymi w pakietach "icu".
62
63 %package -n libicu-devel
64 Summary:        International Components for Unicode (development files)
65 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
66 Group:          Development/Libraries
67 Requires:       libicu = %{version}-%{release}
68
69 %description -n libicu-devel
70 ICU is a set of C and C++ libraries that provides robust and
71 full-featured Unicode support. This package contains the development
72 files for ICU.
73
74 %description -n libicu-devel -l pl.UTF-8
75 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
76 obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
77 programistyczne ICU.
78
79 %package -n libicu-static
80 Summary:        International Components for Unicode (static libraries)
81 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (biblioteki statyczne)
82 Group:          Development/Libraries
83 Requires:       libicu-devel = %{version}-%{release}
84
85 %description -n libicu-static
86 ICU is a set of C and C++ libraries that provides robust and
87 full-featured Unicode support. This package contains the static 
88 libraries for ICU.
89
90 %description -n libicu-static -l pl.UTF-8
91 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
92 obsługę Unikodu i lokalizacji. Ten pakiet zawiera statyczne
93 biblioteki programistyczne ICU.
94
95 %prep
96 %setup -q -n %{name}
97
98 %build
99 cd source
100 %{__autoconf}
101 %configure \
102         --sbindir=%{_bindir} \
103         --with-data-packaging=library \
104         %{?with_static_libs:--enable-static} \
105         --disable-samples
106
107 %{__make} \
108         VERBOSE=1
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} -C source install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 for f in icu-i18n icu-io icu-le icu-lx icu-uc ; do
117 sed -i \
118         -e 's/\$(THREADSCXXFLAGS)//' \
119         -e 's/\$(THREADSCFLAGS)//' \
120         -e 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_pkgconfigdir}/${f}.pc
121 done
122
123 # help rpm to generate deps
124 chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
125
126 # rpm is too stupid sometimes and fails on symlinks to symlinked resources
127 # (reporting unresolved dependency at install time)
128 for f in Makefile.inc pkgdata.inc ; do
129         ln -sf %{version}/${f} $RPM_BUILD_ROOT%{_libdir}/%{name}/${f}
130 done
131
132 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/LICENSE
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -n libicu -p /sbin/ldconfig
138 %postun -n libicu -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc license.html readme.html
143 %attr(755,root,root) %{_bindir}/derb
144 %attr(755,root,root) %{_bindir}/gen*
145 %attr(755,root,root) %{_bindir}/icuinfo
146 %attr(755,root,root) %{_bindir}/icupkg
147 %attr(755,root,root) %{_bindir}/makeconv
148 %attr(755,root,root) %{_bindir}/pkgdata
149 %attr(755,root,root) %{_bindir}/uconv
150 %{_mandir}/man1/derb.1*
151 %{_mandir}/man1/gen*.1*
152 %{_mandir}/man1/makeconv.1*
153 %{_mandir}/man1/pkgdata.1*
154 %{_mandir}/man1/uconv.1*
155 %{_mandir}/man8/gen*.8*
156 %{_mandir}/man8/icupkg.8*
157
158 %files -n libicu
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libicu*.so.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libicu*.so.57
162
163 %files -n libicu-devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/icu-config
166 %attr(755,root,root) %{_libdir}/libicu*.so
167 %{_pkgconfigdir}/icu-i18n.pc
168 %{_pkgconfigdir}/icu-io.pc
169 %{_pkgconfigdir}/icu-le.pc
170 %{_pkgconfigdir}/icu-lx.pc
171 %{_pkgconfigdir}/icu-uc.pc
172 %{_includedir}/unicode
173 %{_includedir}/layout
174 %dir %{_libdir}/%{name}
175 %{_libdir}/%{name}/*.inc
176 %dir %{_libdir}/%{name}/current
177 %dir %{_libdir}/%{name}/%{version}
178 %{_libdir}/%{name}/%{version}/*.inc
179 %dir %{_datadir}/%{name}
180 %dir %{_datadir}/%{name}/%{version}
181 %{_datadir}/%{name}/%{version}/config
182 %attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
183 %attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
184 %{_mandir}/man1/icu-config.1*
185
186 %if %{with static_libs}
187 %files -n libicu-static
188 %defattr(644,root,root,755)
189 %{_libdir}/libicu*.a
190 %endif
This page took 0.111134 seconds and 3 git commands to generate.