]> git.pld-linux.org Git - packages/icu.git/blob - icu.spec
7c0bba1f68f3d02f310626d0da83d038903aaed6
[packages/icu.git] / icu.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         ver     %(echo %{version} | tr . _)
6 %define         basever %(echo %{version} | cut -d. -f1)
7 Summary:        International Components for Unicode
8 Summary(pl.UTF-8):      Międzynarodowe komponenty dla unikodu
9 Name:           icu
10 Version:        65.1
11 Release:        1
12 License:        MIT-like
13 Group:          Libraries
14 Source0:        https://github.com/unicode-org/icu/releases/download/release-65-1/icu4c-%{ver}-src.tgz
15 # Source0-md5:  d1ff436e26cabcb28e6cb383d32d1339
16 Patch0:         %{name}-cxx-pre11.patch
17 URL:            http://www.icu-project.org/
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  libstdc++-devel
20 Requires:       libicu = %{version}-%{release}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ICU is a set of C and C++ libraries that provides robust and
25 full-featured Unicode and locale support. The library provides
26 calendar support, conversions for many character sets, language
27 sensitive collation, date and time formatting, support for many
28 locales, message catalogs and resources, message formatting,
29 normalization, number and currency formatting, time zones support,
30 transliteration, word, line and sentence breaking, etc.
31
32 This package contains the Unicode character database and derived
33 properties, along with converters and time zones data.
34
35 %description -l pl.UTF-8
36 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
37 obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
38 kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
39 języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
40 katalogów komunikatów i zasobów, formatowanie komunikatów,
41 normalizację, formatowanie liczb i walut, obsługę stref czasowych,
42 transliterację, łamanie słów, linii i zdań itp.
43
44 Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
45 konwerterami i danymi stref czasowych.
46
47 %package -n libicu
48 Summary:        International Components for Unicode (libraries)
49 Summary(pl.UTF-8):      Międzynarodowe Komponenty dla Unikodu (biblioteki)
50 Group:          Libraries
51 Obsoletes:      libicu30
52
53 %description -n libicu
54 ICU is a set of C and C++ libraries that provides robust and
55 full-featured Unicode support. This package contains the runtime
56 libraries for ICU. It does not contain any of the data files needed at
57 runtime and present in the `icu' package.
58
59 %description -n libicu -l pl.UTF-8
60 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
61 obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
62 uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
63 czasie działania i obecnymi w pakietach "icu".
64
65 %package -n libicu-devel
66 Summary:        International Components for Unicode (development files)
67 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
68 Group:          Development/Libraries
69 Requires:       libicu = %{version}-%{release}
70
71 %description -n libicu-devel
72 ICU is a set of C and C++ libraries that provides robust and
73 full-featured Unicode support. This package contains the development
74 files for ICU.
75
76 %description -n libicu-devel -l pl.UTF-8
77 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
78 obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
79 programistyczne ICU.
80
81 %package -n libicu-static
82 Summary:        International Components for Unicode (static libraries)
83 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (biblioteki statyczne)
84 Group:          Development/Libraries
85 Requires:       libicu-devel = %{version}-%{release}
86
87 %description -n libicu-static
88 ICU is a set of C and C++ libraries that provides robust and
89 full-featured Unicode support. This package contains the static 
90 libraries for ICU.
91
92 %description -n libicu-static -l pl.UTF-8
93 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
94 obsługę Unikodu i lokalizacji. Ten pakiet zawiera statyczne
95 biblioteki programistyczne ICU.
96
97 %prep
98 %setup -q -n %{name}
99 %patch0 -p1
100
101 %build
102 cd source
103 %{__autoconf}
104 %configure \
105         --sbindir=%{_bindir} \
106         --with-data-packaging=library \
107         %{?with_static_libs:--enable-static} \
108         --disable-samples
109
110 %{__make} \
111         VERBOSE=1
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} -C source install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 for f in icu-i18n icu-io icu-uc ; do
120 sed -i \
121         -e 's/\$(THREADSCXXFLAGS)//' \
122         -e 's/\$(THREADSCFLAGS)//' \
123         -e 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_pkgconfigdir}/${f}.pc
124 done
125
126 # help rpm to generate deps
127 chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
128
129 # rpm is too stupid sometimes and fails on symlinks to symlinked resources
130 # (reporting unresolved dependency at install time)
131 for f in Makefile.inc pkgdata.inc ; do
132         ln -sf %{version}/${f} $RPM_BUILD_ROOT%{_libdir}/%{name}/${f}
133 done
134
135 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/LICENSE
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -n libicu -p /sbin/ldconfig
141 %postun -n libicu -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc license.html readme.html
146 %attr(755,root,root) %{_bindir}/derb
147 %attr(755,root,root) %{_bindir}/escapesrc
148 %attr(755,root,root) %{_bindir}/gen*
149 %attr(755,root,root) %{_bindir}/icuinfo
150 %attr(755,root,root) %{_bindir}/icupkg
151 %attr(755,root,root) %{_bindir}/makeconv
152 %attr(755,root,root) %{_bindir}/pkgdata
153 %attr(755,root,root) %{_bindir}/uconv
154 %{_mandir}/man1/derb.1*
155 %{_mandir}/man1/gen*.1*
156 %{_mandir}/man1/makeconv.1*
157 %{_mandir}/man1/pkgdata.1*
158 %{_mandir}/man1/uconv.1*
159 %{_mandir}/man8/gen*.8*
160 %{_mandir}/man8/icupkg.8*
161
162 %files -n libicu
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libicu*.so.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libicu*.so.%{basever}
166
167 %files -n libicu-devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/icu-config
170 %attr(755,root,root) %{_libdir}/libicu*.so
171 %{_pkgconfigdir}/icu-i18n.pc
172 %{_pkgconfigdir}/icu-io.pc
173 %{_pkgconfigdir}/icu-uc.pc
174 %{_includedir}/unicode
175 %dir %{_libdir}/%{name}
176 %{_libdir}/%{name}/*.inc
177 %dir %{_libdir}/%{name}/current
178 %dir %{_libdir}/%{name}/%{version}
179 %{_libdir}/%{name}/%{version}/*.inc
180 %dir %{_datadir}/%{name}
181 %dir %{_datadir}/%{name}/%{version}
182 %{_datadir}/%{name}/%{version}/config
183 %attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
184 %attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
185 %{_mandir}/man1/icu-config.1*
186
187 %if %{with static_libs}
188 %files -n libicu-static
189 %defattr(644,root,root,755)
190 %{_libdir}/libicu*.a
191 %endif
This page took 0.085454 seconds and 2 git commands to generate.