]> git.pld-linux.org Git - packages/hostapd.git/blob - hostapd.spec
- fix WPA2 vurnelabilities (a.k.a. KRACK)
[packages/hostapd.git] / hostapd.spec
1 Summary:        HostAP - acts as an access point
2 Summary(es.UTF-8):      HostAP - actúa como un punto de acceso
3 Summary(pl.UTF-8):      HostAP - praca jako access point
4 Name:           hostapd
5 Version:        2.6
6 Release:        2
7 License:        BSD
8 Group:          Daemons
9 Source0:        http://w1.fi/releases/%{name}-%{version}.tar.gz
10 # Source0-md5:  eaa56dce9bd8f1d195eb62596eab34c7
11 Source1:        %{name}.init
12 Patch0:         %{name}-config.patch
13 Patch1:         %{name}-build-time-config.patch
14 Patch2:         0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch
15 Patch3:         0002-Prevent-reinstallation-of-an-already-in-use-group-ke.patch
16 Patch4:         0003-Extend-protection-of-GTK-IGTK-reinstallation-of-WNM-.patch
17 Patch5:         0004-Prevent-installation-of-an-all-zero-TK.patch
18 Patch6:         0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch
19 Patch7:         0006-TDLS-Reject-TPK-TK-reconfiguration.patch
20 Patch8:         0008-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch
21 URL:            http://w1.fi/
22 BuildRequires:  libnl-devel >= 1:3.2
23 BuildRequires:  libnl1-devel
24 BuildRequires:  openssl-devel >= 1.0.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  sqlite3-devel >= 3
29 Requires(post,preun):   /sbin/chkconfig
30 Requires:       openssl >= 1.0.2
31 Requires:       rc-scripts
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This package contains utilities and userspace daemon for the Linux
36 driver for wireless LAN cards based on Intersil's Prism2/2.5/3,
37 Intersil/Conexant Prism GT/Duette/Indigo (Prism54), Atheros ar521x
38 (madwifi) chipsets. The driver supports a so called Host AP mode,
39 i.e., it takes care of IEEE 802.11 management functions in the host
40 computer and acts as an access point. This does not require any
41 special firmware for the wireless LAN card. In addition to this, it
42 has support for normal station operations in BSS and possible also in
43 IBSS.
44
45 %description -l es.UTF-8
46 Este paquete contiene unas herramientas y un servidor del espacio de
47 usuario para tarjetas LAN inalámbricas basadas en el chipset Intersil
48 Prism2/2.5/3, Intersil/Conexant Prism GT/Duette/Indigo (Prism54),
49 Atheros ar521x (madwifi). El driver soporta el llamado modo Host AP,
50 es decir, se encarga de las funciones administrativas el el host,
51 actuando como "access point". Ello no requiere ningún firmware
52 especial para la tarjeta LAN inalámbrica. Además, también hay soporte
53 para operaciones normales de estación en BSS y posiblemente también en
54 IBSS.
55
56 %description -l pl.UTF-8
57 Ten pakiet zawiera narzędzia oraz demona działającego w przestrzeni
58 użytkownika dla linuksowego sterownika kart sieci bezprzewodowych
59 opartych na układach Intersil Prism2/2.5/3, Intersil/Conexant Prism
60 GT/Duette/Indigo (Prism54), Atheros ar521x (madwifi). Sterownik
61 obsługuje tak zwany tryb Host AP, czyli dba o funkcje zarządzające
62 IEEE 802.11 na komputerze i działa jako access point. Nie wymaga to
63 żadnego specjalnego firmware dla karty sieci bezprzewodowej. Ponadto
64 ma obsługę normalnych operacji stacyjnych w BSS, a być może także
65 IBSS.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72 %patch3 -p1
73 %patch4 -p1
74 %patch5 -p1
75 %patch6 -p1
76 %patch7 -p1
77 %patch8 -p1
78
79 %{__sed} '/CFLAGS =/{s/-g//; s/-O2/$(OPTCFLAGS)/}' -i hostapd/Makefile
80
81 %build
82 %{__make} -C hostapd all nt_password_hash hlr_auc_gw \
83         V=1 \
84         CC="%{__cc}" \
85         OPTCFLAGS="%{rpmcflags} %{rpmcppflags}" \
86         LDFLAGS="%{rpmcflags} %{rpmldflags}"
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{hostap,pcmcia},%{_mandir}/man{1,8}}
91 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
92
93 # hostapd hostapd_cli nt_password_hash hlr_auc_gw
94 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/hostapd
95 install -p hostapd/hostapd $RPM_BUILD_ROOT/sbin
96 install -p hostapd/hostapd_cli $RPM_BUILD_ROOT/sbin
97 install -p hostapd/nt_password_hash $RPM_BUILD_ROOT/sbin
98 install -p hostapd/hlr_auc_gw $RPM_BUILD_ROOT/sbin
99 cp -p hostapd/hostapd.8 $RPM_BUILD_ROOT%{_mandir}/man8
100 cp -p hostapd/hostapd_cli.1 $RPM_BUILD_ROOT%{_mandir}/man1
101
102 # hostapd configuration
103 cp -a hostapd/hostapd.accept $RPM_BUILD_ROOT%{_sysconfdir}/hostap
104 cp -a hostapd/hostapd.conf $RPM_BUILD_ROOT%{_sysconfdir}/hostap
105 cp -a hostapd/hostapd.deny $RPM_BUILD_ROOT%{_sysconfdir}/hostap
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 /sbin/chkconfig --add hostapd
112 %service hostapd restart "HostAP Daemon"
113
114 %preun
115 if [ "$1" = "0" ]; then
116         %service hostapd stop
117         /sbin/chkconfig --del hostapd
118 fi
119
120 %files
121 %defattr(644,root,root,755)
122 %doc COPYING hostapd/{ChangeLog,README,README-WPS}
123 %dir %{_sysconfdir}/hostap
124 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.accept
125 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.conf
126 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.deny
127 %attr(755,root,root) /sbin/hlr_auc_gw
128 %attr(755,root,root) /sbin/hostapd
129 %attr(755,root,root) /sbin/hostapd_cli
130 %attr(755,root,root) /sbin/nt_password_hash
131 %attr(754,root,root) /etc/rc.d/init.d/hostapd
132 %{_mandir}/man1/hostapd_cli.1*
133 %{_mandir}/man8/hostapd.8*
This page took 0.094701 seconds and 4 git commands to generate.