]> git.pld-linux.org Git - packages/hostapd.git/blob - hostapd.spec
- really fix building with libnl 3.x
[packages/hostapd.git] / hostapd.spec
1 # TODO
2 # - check madwifi-ng-devel and madwifi-devel BR -- ???
3 Summary:        HostAP - acts as an access point
4 Summary(es.UTF-8):      HostAP - actúa como un punto de acceso
5 Summary(pl.UTF-8):      HostAP - praca jako access point
6 Name:           hostapd
7 Version:        0.7.3
8 Release:        4
9 License:        GPL v2
10 Group:          Daemons
11 Source0:        http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  91a7c8d0f090b7104152d3455a84c112
13 Source1:        %{name}.init
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-build-time-config.patch
16 Patch2:         %{name}-nl.patch
17 URL:            http://hostap.epitest.fi/
18 BuildRequires:  libnl-devel >= 1:3.0
19 BuildRequires:  madwifi-ng-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 BuildRequires:  sed >= 4.0
23 Requires(post,preun):   /sbin/chkconfig
24 Requires:       rc-scripts
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This package contains utilities and userspace daemon for the Linux
29 driver for wireless LAN cards based on Intersil's Prism2/2.5/3,
30 Intersil/Conexant Prism GT/Duette/Indigo (Prism54), Atheros ar521x
31 (madwifi) chipsets. The driver supports a so called Host AP mode,
32 i.e., it takes care of IEEE 802.11 management functions in the host
33 computer and acts as an access point. This does not require any
34 special firmware for the wireless LAN card. In addition to this, it
35 has support for normal station operations in BSS and possible also in
36 IBSS.
37
38 %description -l es.UTF-8
39 Este paquete contiene unas herramientas y un servidor del espacio de
40 usuario para tarjetas LAN inalámbricas basadas en el chipset Intersil
41 Prism2/2.5/3, Intersil/Conexant Prism GT/Duette/Indigo (Prism54),
42 Atheros ar521x (madwifi). El driver soporta el llamado modo Host AP,
43 es decir, se encarga de las funciones administrativas el el host,
44 actuando como "access point". Ello no requiere ningún firmware
45 especial para la tarjeta LAN inalámbrica. Además, también hay soporte
46 para operaciones normales de estación en BSS y posiblemente también en
47 IBSS.
48
49 %description -l pl.UTF-8
50 Ten pakiet zawiera narzędzia oraz demona działającego w przestrzeni
51 użytkownika dla linuksowego sterownika kart sieci bezprzewodowych
52 opartych na układach Intersil Prism2/2.5/3, Intersil/Conexant Prism
53 GT/Duette/Indigo (Prism54), Atheros ar521x (madwifi). Sterownik
54 obsługuje tak zwany tryb Host AP, czyli dba o funkcje zarządzające
55 IEEE 802.11 na komputerze i działa jako access point. Nie wymaga to
56 żadnego specjalnego firmware dla karty sieci bezprzewodowej. Ponadto
57 ma obsługę normalnych operacji stacyjnych w BSS, a być może także
58 IBSS.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65
66 %{__sed} '/CFLAGS =/{s/-g//; s/-O2/$(OPTCFLAGS)/}' -i hostapd/Makefile
67 %{__sed} '/NOBJS =/s@../src/crypto/rc4.o@../src/utils/wpabuf.o ../src/utils/wpa_debug.o@' -i hostapd/Makefile
68
69 %build
70 %{__make} -C hostapd \
71         CONFIG_LIBNL20=1 \
72         all nt_password_hash hlr_auc_gw \
73         V=1 \
74         CC="%{__cc}" \
75         OPTCFLAGS="%{rpmcflags} %{rpmcppflags} `pkg-config --cflags libnl-3.0`" \
76         LDFLAGS="%{rpmcflags} %{rpmldflags} `pkg-config --libs libnl-3.0 libnl-genl-3.0`"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{hostap,pcmcia}}
81 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
82
83 # hostapd hostapd_cli nt_password_hash hlr_auc_gw
84 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/hostapd
85 install -p hostapd/hostapd $RPM_BUILD_ROOT/sbin
86 install -p hostapd/hostapd_cli $RPM_BUILD_ROOT/sbin
87 install -p hostapd/nt_password_hash $RPM_BUILD_ROOT/sbin
88 install -p hostapd/hlr_auc_gw $RPM_BUILD_ROOT/sbin
89
90 # hostapd configuration
91 cp -a hostapd/hostapd.accept $RPM_BUILD_ROOT%{_sysconfdir}/hostap
92 cp -a hostapd/hostapd.conf $RPM_BUILD_ROOT%{_sysconfdir}/hostap
93 cp -a hostapd/hostapd.deny $RPM_BUILD_ROOT%{_sysconfdir}/hostap
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/chkconfig --add hostapd
100 %service hostapd restart "HostAP Daemon"
101
102 %preun
103 if [ "$1" = "0" ]; then
104         %service hostapd stop
105         /sbin/chkconfig --del hostapd
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc hostapd/ChangeLog hostapd/README
111 %dir %{_sysconfdir}/hostap
112 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/*
113 %attr(755,root,root) /sbin/*
114 %attr(754,root,root) /etc/rc.d/init.d/hostapd
This page took 0.058544 seconds and 3 git commands to generate.