]> git.pld-linux.org Git - packages/hdf5.git/commitdiff
- more cmake fixes; moved to libdir (content depends on libdir); release 3 auto/th/hdf5-1.8.20-3
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 18 May 2018 14:12:31 +0000 (16:12 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 18 May 2018 14:12:31 +0000 (16:12 +0200)
hdf5-cmake.patch
hdf5.spec

index 79d03cd2b6fdaa95cd1dbba07619f7fef18a7f5b..ef58c8af968c6a01d70e259814fa96f95648c339 100644 (file)
 +# Import target "hdf5::hdf5-shared" for configuration ""
 +set_property(TARGET hdf5::hdf5-shared APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +set_target_properties(hdf5::hdf5-shared PROPERTIES
-+  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5.so.1.8.20"
-+  IMPORTED_SONAME_NOCONFIG "libhdf5.so.10.3.1"
++  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5.so.10.3.1"
++  IMPORTED_SONAME_NOCONFIG "libhdf5.so.10"
 +  )
 +
 +list(APPEND _IMPORT_CHECK_TARGETS hdf5::hdf5-shared )
-+list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5-shared "${_IMPORT_PREFIX}/@lib@/libhdf5.so.1.8.20" )
++list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5-shared "${_IMPORT_PREFIX}/@lib@/libhdf5.so.10" )
 +
 +# Import target "hdf5::hdf5_tools-static" for configuration ""
 +set_property(TARGET hdf5::hdf5_tools-static APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +# Import target "hdf5::hdf5_tools-shared" for configuration ""
 +set_property(TARGET hdf5::hdf5_tools-shared APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +set_target_properties(hdf5::hdf5_tools-shared PROPERTIES
-+  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_tools.so.1.8.20"
-+  IMPORTED_SONAME_NOCONFIG "libhdf5_tools.so.10.3.1"
++  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_tools.so.10.3.1"
++  IMPORTED_SONAME_NOCONFIG "libhdf5_tools.so.10"
 +  )
 +
 +list(APPEND _IMPORT_CHECK_TARGETS hdf5::hdf5_tools-shared )
 +# Import target "hdf5::hdf5_hl-shared" for configuration ""
 +set_property(TARGET hdf5::hdf5_hl-shared APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +set_target_properties(hdf5::hdf5_hl-shared PROPERTIES
-+  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_hl.so.1.8.20"
-+  IMPORTED_SONAME_NOCONFIG "libhdf5_hl.so.10.3.1"
++  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_hl.so.10"
++  IMPORTED_SONAME_NOCONFIG "libhdf5_hl.so.10.2.1"
 +  )
 +
 +list(APPEND _IMPORT_CHECK_TARGETS hdf5::hdf5_hl-shared )
-+list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5_hl-shared "${_IMPORT_PREFIX}/@lib@/libhdf5_hl.so.1.8.20" )
++list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5_hl-shared "${_IMPORT_PREFIX}/@lib@/libhdf5_hl.so.10" )
 +
 +# Import target "hdf5::gif2h5" for configuration ""
 +set_property(TARGET hdf5::gif2h5 APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +# Import target "hdf5::hdf5_cpp-shared" for configuration ""
 +set_property(TARGET hdf5::hdf5_cpp-shared APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +set_target_properties(hdf5::hdf5_cpp-shared PROPERTIES
-+  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_cpp.so.1.8.20"
-+  IMPORTED_SONAME_NOCONFIG "libhdf5_cpp.so.10.3.1"
++  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_cpp.so.15.0.0"
++  IMPORTED_SONAME_NOCONFIG "libhdf5_cpp.so.15"
 +  )
 +
 +list(APPEND _IMPORT_CHECK_TARGETS hdf5::hdf5_cpp-shared )
-+list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5_cpp-shared "${_IMPORT_PREFIX}/@lib@/libhdf5_cpp.so.1.8.20" )
++list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5_cpp-shared "${_IMPORT_PREFIX}/@lib@/libhdf5_cpp.so.15" )
 +
 +# Import target "hdf5::hdf5_hl_cpp-static" for configuration ""
 +set_property(TARGET hdf5::hdf5_hl_cpp-static APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +# Import target "hdf5::hdf5_hl_cpp-shared" for configuration ""
 +set_property(TARGET hdf5::hdf5_hl_cpp-shared APPEND PROPERTY IMPORTED_CONFIGURATIONS NOCONFIG)
 +set_target_properties(hdf5::hdf5_hl_cpp-shared PROPERTIES
-+  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_hl_cpp.so.1.8.20"
-+  IMPORTED_SONAME_NOCONFIG "libhdf5_hl_cpp.so.10.3.1"
++  IMPORTED_LOCATION_NOCONFIG "${_IMPORT_PREFIX}/@lib@/libhdf5_hl_cpp.so.11.1.1"
++  IMPORTED_SONAME_NOCONFIG "libhdf5_hl_cpp.so.11"
 +  )
 +
 +list(APPEND _IMPORT_CHECK_TARGETS hdf5::hdf5_hl_cpp-shared )
-+list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5_hl_cpp-shared "${_IMPORT_PREFIX}/lib/libhdf5_hl_cpp-shared.so.1.8.20" )
++list(APPEND _IMPORT_CHECK_FILES_FOR_hdf5::hdf5_hl_cpp-shared "${_IMPORT_PREFIX}/lib/libhdf5_hl_cpp-shared.so.11" )
 +
 +# Commands beyond this point should not need to know the version.
 +set(CMAKE_IMPORT_FILE_VERSION)
index a1f3155cfcc617ff82d93ec24dfb8f57ec6d8c0f..75f85ca89b9772939da96ac320f0151f0d66b201 100644 (file)
--- a/hdf5.spec
+++ b/hdf5.spec
@@ -11,7 +11,7 @@ Summary:      Hierarchical Data Format 5 library
 Summary(pl.UTF-8):     Biblioteka HDF5 (Hierarchical Data Format 5)
 Name:          hdf5
 Version:       1.8.20
-Release:       2
+Release:       3
 License:       Nearly BSD, but changed sources must be marked
 Group:         Libraries
 Source0:       https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-%{version}/src/%{name}-%{version}.tar.bz2
@@ -216,7 +216,7 @@ install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
 %{__make} -C hl/c++/examples install-examples \
        EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c++
 
-install -d $RPM_BUILD_ROOT%{_datadir}/cmake/hdf5
+install -d $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5
 vmajor=$(sed -ne 's/^#define H5_VERS_MAJOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
 vminor=$(sed -ne 's/^#define H5_VERS_MINOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
 vrel=$(sed -ne 's/^#define H5_VERS_RELEASE\s*\([0-9]\+\).*/\1/p' src/H5public.h)
@@ -259,7 +259,7 @@ for f in hdf5-config-version.cmake hdf5-config.cmake hdf5-targets.cmake hdf5-tar
            -e 's,@PACKAGE_INCLUDE_INSTALL_DIR@,%{_includedir},' \
            -e 's,@PACKAGE_SHARE_INSTALL_DIR@,%{_datadir}/cmake/hdf5,' \
            -e 's,@PACKAGE_CURRENT_BUILD_DIR@,%{_prefix},' \
-               config/cmake/${f}.in > $RPM_BUILD_ROOT%{_datadir}/cmake/hdf5/$f
+               config/cmake/${f}.in > $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5/$f
 done
 
 %clean
@@ -335,7 +335,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/hdf5.h
 %{_includedir}/hdf5_hl.h
 
-%{_datadir}/cmake/hdf5
+%{_libdir}/cmake/hdf5
 %dir %{_examplesdir}/%{name}-%{version}
 %{_examplesdir}/%{name}-%{version}/README
 %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
This page took 0.146355 seconds and 4 git commands to generate.