]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- java- R: base
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - finish (optional) MPI support (1.8.14: fails on mpi_file_open check)
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_with     hdfs            # HDFS driver (requires libhdfs, hdfs.h)
7 %bcond_without  java            # Java wrappers
8 %bcond_without  s3              # R/O S3 driver
9 %bcond_without  szip            # SZIP compression support
10 %bcond_with     mpi             # parallel version of library using MPI
11 #
12 Summary:        Hierarchical Data Format 5 library
13 Summary(pl.UTF-8):      Biblioteka HDF5 (Hierarchical Data Format 5)
14 Name:           hdf5
15 Version:        1.10.7
16 Release:        1
17 License:        Nearly BSD, but changed sources must be marked
18 Group:          Libraries
19 Source0:        https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/hdf5-%{version}/src/%{name}-%{version}.tar.bz2
20 # Source0-md5:  dff8a882b61d0b59296dccc3ad13dc29
21 Patch0:         %{name}-sig.patch
22 Patch1:         %{name}-cmake.patch
23 Patch2:         %{name}-sh.patch
24 URL:            https://support.hdfgroup.org/HDF5/
25 BuildRequires:  autoconf >= 2.69
26 BuildRequires:  automake >= 1:1.11
27 %{?with_s3:BuildRequires:       curl-devel}
28 BuildRequires:  gcc-fortran >= 6:4.2
29 %{?with_java:BuildRequires:     jdk}
30 BuildRequires:  libjpeg-devel >= 6b
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:2.2
33 %{?with_mpi:BuildRequires:      mpi-devel}
34 %{?with_s3:BuildRequires:       openssl-devel}
35 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
36 BuildRequires:  zlib-devel >= 1.1.3
37 Obsoletes:      hdf5_hl
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 HDF5 is a completely new Hierarchical Data Format product consisting
42 of a data format specification and a supporting library
43 implementation. HDF5 is designed to address some of the limitations of
44 the older HDF product and to address current and anticipated
45 requirements of modern systems and applications.
46
47 %description -l pl.UTF-8
48 HDF5 jest całkowicie nowym produktem Hierarchiczego Formatu Danych,
49 składającym się ze specyfikacji formatu danych oraz obsługującej go
50 biblioteki. HDF5 został zaprojektowany aby pozbyć się ograniczeń
51 poprzedniego HDF oraz żeby zaspokoić bieżące i przyszłe potrzeby
52 współczesnych systemów i aplikacji.
53
54 %package devel
55 Summary:        HDF5 library development package
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 %{?with_s3:Requires:    curl-devel}
60 %{?with_s3:Requires:    openssl-devel}
61 %{?with_szip:Requires:  szip-devel >= 2.0}
62 Requires:       zlib-devel
63 Obsoletes:      hdf5_hl-devel
64 Obsoletes:      hdf5_hl-tutor
65
66 %description devel
67 Header files for HDF5 library and HDF5 documentation.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki HDF5 oraz dokumentacja HDF5.
71
72 %package static
73 Summary:        HDF5 static library
74 Summary(pl.UTF-8):      Statyczna biblioteka HDF5
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Obsoletes:      hdf5_hl-static
78
79 %description static
80 Static version of HDF5 library.
81
82 %description static -l pl.UTF-8
83 Statyczna wersja biblioteki HDF5.
84
85 %package c++
86 Summary:        C++ APIs for HDF5
87 Summary(pl.UTF-8):      API C++ bibliotek HDF5
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description c++
92 C++ APIs for HDF5 (both base hdf5 and hdf5_hl).
93
94 %description c++ -l pl.UTF-8
95 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl).
96
97 %package c++-devel
98 Summary:        Header files for HDF5 C++ APIs
99 Summary(pl.UTF-8):      Pliki nagłówkowe API C++ bibliotek HDF5
100 Group:          Development/Libraries
101 Requires:       %{name}-c++ = %{version}-%{release}
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       libstdc++-devel
104
105 %description c++-devel
106 Header files for HDF5 C++ APIs (both base hdf5 and hdf5_hl).
107
108 %description c++-devel -l pl.UTF-8
109 Pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej hdf5, jak
110 i hdf5_hl).
111
112 %package c++-static
113 Summary:        C++ APIs for HDF5 - static libraries
114 Summary(pl.UTF-8):      API C++ bibliotek HDF5 - biblioteki statyczne
115 Group:          Development/Libraries
116 Requires:       %{name}-c++-devel = %{version}-%{release}
117
118 %description c++-static
119 C++ APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
120
121 %description c++-static -l pl.UTF-8
122 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl) -
123 biblioteki statyczne.
124
125 %package fortran
126 Summary:        Fortran APIs for HDF5
127 Summary(pl.UTF-8):      API Fortran bibliotek HDF5
128 Group:          Libraries
129 Requires:       %{name} = %{version}-%{release}
130
131 %description fortran
132 Fortran APIs for HDF5 (both base hdf5 and hdf5_hl).
133
134 %description fortran -l pl.UTF-8
135 API Fortran dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i
136 hdf5_hl).
137
138 %package fortran-devel
139 Summary:        Header files for HDF5 Fortran APIs
140 Summary(pl.UTF-8):      Pliki nagłówkowe API Fortran bibliotek HDF5
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143 Requires:       %{name}-fortran = %{version}-%{release}
144 Requires:       gcc-fortran >= 6:4.2
145
146 %description fortran-devel
147 Module and header files for HDF5 Fortran APIs (both base hdf5 and
148 hdf5_hl).
149
150 %description fortran-devel -l pl.UTF-8
151 Moduły i pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej
152 hdf5, jak i hdf5_hl).
153
154 %package fortran-static
155 Summary:        Fortran APIs for HDF5 - static libraries
156 Summary(pl.UTF-8):      API Fortran bibliotek HDF5 - biblioteki statyczne
157 Group:          Development/Libraries
158 Requires:       %{name}-fortran-devel = %{version}-%{release}
159
160 %description fortran-static
161 Fortran APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
162
163 %description fortran-static -l pl.UTF-8
164 API Fortran dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i
165 hdf5_hl) - biblioteki statyczne.
166
167 %package progs
168 Summary:        HDF5 utilities
169 Summary(pl.UTF-8):      Narzędzia do plików HDF5
170 Group:          Applications/File
171 Requires:       %{name} = %{version}-%{release}
172
173 %description progs
174 Utilities to convert from/to HDF5 format.
175
176 %description progs -l pl.UTF-8
177 Narzędzia do konwersji z i to formatu HDF5.
178
179 %package -n java-hdf5
180 Summary:        Java HDF5 Interface (JHI5)
181 Summary(pl.UTF-8):      Interfejs HDF5 do Javy (JHI5)
182 # to replace java-hdf5 [0:]2.11/3.3.1 from hdf-java.spec
183 Epoch:          1
184 Group:          Libraries/Java
185 URL:            http://portal.hdfgroup.org/display/HDFVIEW/JHI5+Design+Notes
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       java-slf4j >= 1.7.25
188
189 %description -n java-hdf5
190 The Java Native Interface to the standard HDF5 library.
191
192 %description -n java-hdf5 -l pl.UTF-8
193 Natywny interfejs Javy (JNI) do biblioteki standardowej HDF5.
194
195 %package -n java-hdf5-javadoc
196 Summary:        Javadoc documentation for Java HDF5 Interface (JHI5)
197 Summary(pl.UTF-8):      Dokumentacja javadoc do interfejsu HDF5 do Javy (JHI5)
198 Epoch:          1
199 Group:          Documentation
200 URL:            http://portal.hdfgroup.org/display/HDFVIEW/JHI5+Design+Notes
201
202 %description -n java-hdf5-javadoc
203 Javadoc documentation for Java HDF5 Interface (JHI5).
204
205 %description -n java-hdf5-javadoc -l pl.UTF-8
206 Dokumentacja javadoc do interfejsu HDF5 do Javy (JHI5).
207
208 %prep
209 %setup -q
210 %patch0 -p1
211 %patch1 -p1
212 %patch2 -p1
213
214 %build
215 %{__libtoolize}
216 %{__aclocal}
217 %{__autoconf}
218 %{__autoheader}
219 %{__automake}
220 %configure \
221         --docdir=%{_docdir} \
222         --disable-silent-rules \
223         --enable-cxx \
224         --enable-direct-vfd \
225         --enable-fortran \
226         %{?with_java:--enable-java} \
227         %{?with_mpi:--enable-parallel --enable-unsupported} \
228         %{?with_s3:--enable-ros3-vfd} \
229         --enable-shared \
230         %{?with_hdfs:--with-libhdfs=%{_includedir},%{_libdir}} \
231         --with-pthread \
232         %{?with_szip:--with-szlib}
233
234 #       --enable-threadsafe is unspported with cxx/fortran/java/hl
235
236 %{__make}
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT%{_includedir}
241
242 %{__make} install-recursive \
243         DESTDIR=$RPM_BUILD_ROOT \
244         hdf5_javadir=%{_javadir}
245
246 %if %{with java}
247 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhdf5_java.la
248 ln -sf jarhdf5-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/jarhdf5.jar
249 install -d $RPM_BUILD_ROOT%{_javadocdir}
250 cp -pr java/src/javadoc $RPM_BUILD_ROOT%{_javadocdir}/hdf5lib
251 %endif
252
253 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
254 %{__make} -C examples install-examples \
255         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
256         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
257 %{__make} -C c++/examples install-examples \
258         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c++
259 %{__make} -C hl/examples install-examples \
260         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c \
261         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
262 %{__make} -C hl/c++/examples install-examples \
263         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c++
264
265 install -d $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5
266 vmajor=$(sed -ne 's/^#define H5_VERS_MAJOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
267 vminor=$(sed -ne 's/^#define H5_VERS_MINOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
268 vrel=$(sed -ne 's/^#define H5_VERS_RELEASE\s*\([0-9]\+\).*/\1/p' src/H5public.h)
269 vsubr=$(sed -ne 's/^#define H5_VERS_SUBRELEASE\s*"\?\([^" \t]\+\)"\?.*/\1/p' src/H5public.h)
270 for f in hdf5-config-version.cmake hdf5-config.cmake hdf5-targets.cmake hdf5-targets-noconfig.cmake ; do
271         sed -e 's,@HDF5_PACKAGE@,hdf5,g' \
272             -e 's,@HDF_PACKAGE_EXT@,,' \
273             -e "s,@HDF5_VERSION_STRING@,%{version}," \
274             -e "s,@HDF5_VERSION_MAJOR@,1.8," \
275             -e "s,@HDF5_VERSION_MINOR@,$vrel," \
276             -e "s,@H5_VERS_MAJOR@,$vmajor," \
277             -e "s,@H5_VERS_MINOR@,$vminor," \
278             -e "s,@H5_VERS_RELEASE@,$vrel," \
279             -e "s,@H5_VERS_SUBRELEASE@,$vsubr," \
280             -e 's,@HDF5_ENABLE_PARALLEL@,OFF,' \
281             -e 's,@HDF5_BUILD_FORTRAN@,ON,' \
282             -e 's,@HDF5_BUILD_CPP_LIB@,ON,' \
283             -e 's,@HDF5_BUILD_TOOLS@,ON,' \
284             -e 's,@HDF5_BUILD_HL_LIB@,ON,' \
285             -e 's,@HDF5_ENABLE_Z_LIB_SUPPORT@,ON,' \
286             -e 's,@HDF5_ENABLE_SZIP_SUPPORT@,%{?with_szip:ON}%{!?with_szip:OFF},' \
287             -e 's,@HDF5_ENABLE_SZIP_ENCODING@,%{?with_szip:ON}%{!?with_szip:OFF},' \
288 %ifarch %{ix86} x32
289             -e 's,@CMAKE_SIZEOF_VOID_P@,4,' \
290 %else
291 %ifarch %{x8664}
292             -e 's,@CMAKE_SIZEOF_VOID_P@,8,' \
293 %endif
294 %endif
295             -e 's,@BUILD_SHARED_LIBS@,ON,' \
296             -e 's,@HDF5_PACKAGE_EXTLIBS@,OFF,' \
297             -e 's,@ZLIB_PACKAGE_NAME@,zlib,' \
298             -e 's,@SZIP_PACKAGE_NAME@,szip,' \
299             -e 's,@HDF5_LIBRARIES_TO_EXPORT@,hdf5,' \
300             -e 's,@CMAKE_GENERATOR_TOOLSET@,,' \
301             -e 's,@lib@,%{_lib},' \
302             %{?with_mpi:-e 's,@MPI_C_INCLUDE_PATH@,%{_includedir},'} \
303             %{?with_mpi:-e 's,@MPI_C_LIBRARIES@,%{_libdir},'} \
304             -e 's,@PACKAGE_INCLUDE_INSTALL_DIR@,%{_includedir},' \
305             -e 's,@PACKAGE_SHARE_INSTALL_DIR@,%{_libdir}/cmake,' \
306             -e 's,@PACKAGE_CURRENT_BUILD_DIR@,%{_prefix},' \
307                 config/cmake/${f}.in > $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5/$f
308 done
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %post   -p /sbin/ldconfig
314 %postun -p /sbin/ldconfig
315
316 %post   c++ -p /sbin/ldconfig
317 %postun c++ -p /sbin/ldconfig
318
319 %post   fortran -p /sbin/ldconfig
320 %postun fortran -p /sbin/ldconfig
321
322 %files
323 %defattr(644,root,root,755)
324 %doc COPYING README.txt release_docs/{HISTORY*.txt,RELEASE.txt}
325 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
326 %attr(755,root,root) %ghost %{_libdir}/libhdf5.so.103
327 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
328 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl.so.100
329 # used to show configuration at runtime
330 %{_libdir}/libhdf5.settings
331
332 %files devel
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{_bindir}/h5cc
335 %attr(755,root,root) %{_libdir}/libhdf5.so
336 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
337 %{_libdir}/libhdf5.la
338 %{_libdir}/libhdf5_hl.la
339 %{_includedir}/H5ACpublic.h
340 %{_includedir}/H5Apublic.h
341 %{_includedir}/H5Cpublic.h
342 %{_includedir}/H5DOpublic.h
343 %{_includedir}/H5DSpublic.h
344 %{_includedir}/H5Dpublic.h
345 %{_includedir}/H5Epubgen.h
346 %{_includedir}/H5Epublic.h
347 %{_includedir}/H5FDcore.h
348 %{_includedir}/H5FDdirect.h
349 %{_includedir}/H5FDfamily.h
350 %{_includedir}/H5FDhdfs.h
351 %{_includedir}/H5FDlog.h
352 %{_includedir}/H5FDmirror.h
353 %{_includedir}/H5FDmpi.h
354 %{_includedir}/H5FDmpio.h
355 %{_includedir}/H5FDmulti.h
356 %{_includedir}/H5FDpublic.h
357 %{_includedir}/H5FDros3.h
358 %{_includedir}/H5FDsec2.h
359 %{_includedir}/H5FDsplitter.h
360 %{_includedir}/H5FDstdio.h
361 %{_includedir}/H5FDwindows.h
362 %{_includedir}/H5Fpublic.h
363 %{_includedir}/H5Gpublic.h
364 %{_includedir}/H5IMpublic.h
365 %{_includedir}/H5Include.h
366 %{_includedir}/H5Ipublic.h
367 %{_includedir}/H5LDpublic.h
368 %{_includedir}/H5LTpublic.h
369 %{_includedir}/H5Lpublic.h
370 %{_includedir}/H5MMpublic.h
371 %{_includedir}/H5Opublic.h
372 %{_includedir}/H5PTpublic.h
373 %{_includedir}/H5Ppublic.h
374 %{_includedir}/H5PLextern.h
375 %{_includedir}/H5PLpublic.h
376 %{_includedir}/H5Rpublic.h
377 %{_includedir}/H5Spublic.h
378 %{_includedir}/H5TBpublic.h
379 %{_includedir}/H5Tpublic.h
380 %{_includedir}/H5Zpublic.h
381 %{_includedir}/H5api_adpt.h
382 %{_includedir}/H5overflow.h
383 %{_includedir}/H5pubconf.h
384 %{_includedir}/H5public.h
385 %{_includedir}/H5version.h
386 %{_includedir}/hdf5.h
387 %{_includedir}/hdf5_hl.h
388
389 %{_libdir}/cmake/hdf5
390 %dir %{_examplesdir}/%{name}-%{version}
391 %{_examplesdir}/%{name}-%{version}/README
392 %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
393 %{_examplesdir}/%{name}-%{version}/c
394 %dir %{_examplesdir}/%{name}-%{version}/hl
395 %{_examplesdir}/%{name}-%{version}/hl/run-hl-ex.sh
396 %{_examplesdir}/%{name}-%{version}/hl/c
397
398 %files static
399 %defattr(644,root,root,755)
400 %{_libdir}/libhdf5.a
401 %{_libdir}/libhdf5_hl.a
402
403 %files c++
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
406 %attr(755,root,root) %ghost %{_libdir}/libhdf5_cpp.so.103
407 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_cpp.so.100
409
410 %files c++-devel
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_bindir}/h5c++
413 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
414 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so
415 %{_libdir}/libhdf5_cpp.la
416 %{_libdir}/libhdf5_hl_cpp.la
417 %{_includedir}/H5AbstractDs.h
418 %{_includedir}/H5ArrayType.h
419 %{_includedir}/H5AtomType.h
420 %{_includedir}/H5Attribute.h
421 %{_includedir}/H5Classes.h
422 %{_includedir}/H5CommonFG.h
423 %{_includedir}/H5CompType.h
424 %{_includedir}/H5Cpp.h
425 %{_includedir}/H5CppDoc.h
426 %{_includedir}/H5DaccProp.h
427 %{_includedir}/H5DataSet.h
428 %{_includedir}/H5DataSpace.h
429 %{_includedir}/H5DataType.h
430 %{_includedir}/H5DcreatProp.h
431 %{_includedir}/H5DxferProp.h
432 %{_includedir}/H5EnumType.h
433 %{_includedir}/H5Exception.h
434 %{_includedir}/H5FaccProp.h
435 %{_includedir}/H5FcreatProp.h
436 %{_includedir}/H5File.h
437 %{_includedir}/H5FloatType.h
438 %{_includedir}/H5Group.h
439 %{_includedir}/H5IdComponent.h
440 %{_includedir}/H5IntType.h
441 %{_includedir}/H5LaccProp.h
442 %{_includedir}/H5LcreatProp.h
443 %{_includedir}/H5Library.h
444 %{_includedir}/H5Location.h
445 %{_includedir}/H5Object.h
446 %{_includedir}/H5OcreatProp.h
447 %{_includedir}/H5PacketTable.h
448 %{_includedir}/H5PredType.h
449 %{_includedir}/H5PropList.h
450 %{_includedir}/H5StrType.h
451 %{_includedir}/H5VarLenType.h
452 %{_examplesdir}/%{name}-%{version}/c++
453 %{_examplesdir}/%{name}-%{version}/hl/c++
454
455 %files c++-static
456 %defattr(644,root,root,755)
457 %{_libdir}/libhdf5_cpp.a
458 %{_libdir}/libhdf5_hl_cpp.a
459
460 %files fortran
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_libdir}/libhdf5_fortran.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libhdf5_fortran.so.102
464 %attr(755,root,root) %{_libdir}/libhdf5hl_fortran.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libhdf5hl_fortran.so.100
466
467 %files fortran-devel
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_bindir}/h5fc
470 %attr(755,root,root) %{_libdir}/libhdf5_fortran.so
471 %attr(755,root,root) %{_libdir}/libhdf5_hl_fortran.so
472 %attr(755,root,root) %{_libdir}/libhdf5hl_fortran.so
473 %{_libdir}/libhdf5_fortran.la
474 %{_libdir}/libhdf5hl_fortran.la
475 %{_includedir}/H5f90i.h
476 %{_includedir}/H5f90i_gen.h
477 %{_includedir}/h5_gen.mod
478 %{_includedir}/h5a.mod
479 %{_includedir}/h5d.mod
480 %{_includedir}/h5ds.mod
481 %{_includedir}/h5e.mod
482 %{_includedir}/h5f.mod
483 %{_includedir}/h5fortkit.mod
484 %{_includedir}/h5fortran_types.mod
485 %{_includedir}/h5g.mod
486 %{_includedir}/h5global.mod
487 %{_includedir}/h5i.mod
488 %{_includedir}/h5im.mod
489 %{_includedir}/h5l.mod
490 %{_includedir}/h5lib.mod
491 %{_includedir}/h5lt.mod
492 %{_includedir}/h5lt_const.mod
493 %{_includedir}/h5o.mod
494 %{_includedir}/h5p.mod
495 %{_includedir}/h5r.mod
496 %{_includedir}/h5s.mod
497 %{_includedir}/h5t.mod
498 %{_includedir}/h5tb.mod
499 %{_includedir}/h5tb_const.mod
500 %{_includedir}/h5z.mod
501 %{_includedir}/hdf5.mod
502
503 %files fortran-static
504 %defattr(644,root,root,755)
505 %{_libdir}/libhdf5_fortran.a
506 %{_libdir}/libhdf5_hl_fortran.a
507 %{_libdir}/libhdf5hl_fortran.a
508
509 %files progs
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_bindir}/gif2h5
512 %attr(755,root,root) %{_bindir}/h52gif
513 %attr(755,root,root) %{_bindir}/h5clear
514 %attr(755,root,root) %{_bindir}/h5copy
515 %attr(755,root,root) %{_bindir}/h5debug
516 %attr(755,root,root) %{_bindir}/h5diff
517 %attr(755,root,root) %{_bindir}/h5dump
518 %attr(755,root,root) %{_bindir}/h5format_convert
519 %attr(755,root,root) %{_bindir}/h5import
520 %attr(755,root,root) %{_bindir}/h5jam
521 %attr(755,root,root) %{_bindir}/h5ls
522 %attr(755,root,root) %{_bindir}/h5mkgrp
523 %attr(755,root,root) %{_bindir}/h5perf_serial
524 %attr(755,root,root) %{_bindir}/h5redeploy
525 %attr(755,root,root) %{_bindir}/h5repack
526 %attr(755,root,root) %{_bindir}/h5repart
527 %attr(755,root,root) %{_bindir}/h5stat
528 %attr(755,root,root) %{_bindir}/h5unjam
529 %attr(755,root,root) %{_bindir}/h5watch
530 %attr(755,root,root) %{_bindir}/mirror_server
531 %attr(755,root,root) %{_bindir}/mirror_server_stop
532
533 %if %{with java}
534 %files -n java-hdf5
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/libhdf5_java.so
537 %{_javadir}/jarhdf5-%{version}.jar
538 %{_javadir}/jarhdf5.jar
539
540 %files -n java-hdf5-javadoc
541 %defattr(644,root,root,755)
542 %{_javadocdir}/hdf5lib
543 %endif
This page took 0.141234 seconds and 3 git commands to generate.