]> git.pld-linux.org Git - packages/hdf5.git/blob - hdf5.spec
- updated to 1.10.10; gif2h5/h52gif removed (deprecated and disabled by default,...
[packages/hdf5.git] / hdf5.spec
1 # TODO:
2 # - finish (optional) MPI support (1.8.14: fails on mpi_file_open check)
3 # - check missing file
4 #
5 # Conditional build:
6 %bcond_with     hdfs            # HDFS driver (requires libhdfs, hdfs.h)
7 %bcond_without  java            # Java wrappers
8 %bcond_without  s3              # R/O S3 driver
9 %bcond_without  szip            # SZIP compression support
10 %bcond_with     mpi             # parallel version of library using MPI
11 #
12 Summary:        Hierarchical Data Format 5 library
13 Summary(pl.UTF-8):      Biblioteka HDF5 (Hierarchical Data Format 5)
14 Name:           hdf5
15 Version:        1.10.9
16 Release:        3
17 License:        Nearly BSD, but changed sources must be marked
18 Group:          Libraries
19 Source0:        https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/hdf5-%{version}/src/%{name}-%{version}.tar.bz2
20 # Source0-md5:  8f9eac14d3ee4719c3e4b52863ea42e9
21 Patch0:         %{name}-sig.patch
22 Patch1:         %{name}-cmake.patch
23 Patch2:         %{name}-sh.patch
24 URL:            https://www.hdfgroup.org/solutions/hdf5/
25 BuildRequires:  autoconf >= 2.69
26 BuildRequires:  automake >= 1:1.11
27 %{?with_s3:BuildRequires:       curl-devel}
28 BuildRequires:  gcc-fortran >= 6:4.2
29 %{?with_java:BuildRequires:     jdk}
30 BuildRequires:  libjpeg-devel >= 6b
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:2.2
33 %{?with_mpi:BuildRequires:      mpi-devel}
34 %{?with_s3:BuildRequires:       openssl-devel}
35 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
36 BuildRequires:  zlib-devel >= 1.1.3
37 Obsoletes:      hdf5_hl < 5180
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 HDF5 is a completely new Hierarchical Data Format product consisting
42 of a data format specification and a supporting library
43 implementation. HDF5 is designed to address some of the limitations of
44 the older HDF product and to address current and anticipated
45 requirements of modern systems and applications.
46
47 %description -l pl.UTF-8
48 HDF5 jest całkowicie nowym produktem Hierarchiczego Formatu Danych,
49 składającym się ze specyfikacji formatu danych oraz obsługującej go
50 biblioteki. HDF5 został zaprojektowany aby pozbyć się ograniczeń
51 poprzedniego HDF oraz żeby zaspokoić bieżące i przyszłe potrzeby
52 współczesnych systemów i aplikacji.
53
54 %package devel
55 Summary:        HDF5 library development package
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 %{?with_s3:Requires:    curl-devel}
60 %{?with_s3:Requires:    openssl-devel}
61 %{?with_szip:Requires:  szip-devel >= 2.0}
62 Requires:       zlib-devel
63 Obsoletes:      hdf5_hl-devel < 5180
64 Obsoletes:      hdf5_hl-tutor < 5180
65
66 %description devel
67 Header files for HDF5 library and HDF5 documentation.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki HDF5 oraz dokumentacja HDF5.
71
72 %package static
73 Summary:        HDF5 static library
74 Summary(pl.UTF-8):      Statyczna biblioteka HDF5
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Obsoletes:      hdf5_hl-static < 5180
78
79 %description static
80 Static version of HDF5 library.
81
82 %description static -l pl.UTF-8
83 Statyczna wersja biblioteki HDF5.
84
85 %package c++
86 Summary:        C++ APIs for HDF5
87 Summary(pl.UTF-8):      API C++ bibliotek HDF5
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description c++
92 C++ APIs for HDF5 (both base hdf5 and hdf5_hl).
93
94 %description c++ -l pl.UTF-8
95 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl).
96
97 %package c++-devel
98 Summary:        Header files for HDF5 C++ APIs
99 Summary(pl.UTF-8):      Pliki nagłówkowe API C++ bibliotek HDF5
100 Group:          Development/Libraries
101 Requires:       %{name}-c++ = %{version}-%{release}
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       libstdc++-devel
104
105 %description c++-devel
106 Header files for HDF5 C++ APIs (both base hdf5 and hdf5_hl).
107
108 %description c++-devel -l pl.UTF-8
109 Pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej hdf5, jak
110 i hdf5_hl).
111
112 %package c++-static
113 Summary:        C++ APIs for HDF5 - static libraries
114 Summary(pl.UTF-8):      API C++ bibliotek HDF5 - biblioteki statyczne
115 Group:          Development/Libraries
116 Requires:       %{name}-c++-devel = %{version}-%{release}
117
118 %description c++-static
119 C++ APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
120
121 %description c++-static -l pl.UTF-8
122 API C++ dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i hdf5_hl) -
123 biblioteki statyczne.
124
125 %package fortran
126 Summary:        Fortran APIs for HDF5
127 Summary(pl.UTF-8):      API Fortran bibliotek HDF5
128 Group:          Libraries
129 Requires:       %{name} = %{version}-%{release}
130
131 %description fortran
132 Fortran APIs for HDF5 (both base hdf5 and hdf5_hl).
133
134 %description fortran -l pl.UTF-8
135 API Fortran dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i
136 hdf5_hl).
137
138 %package fortran-devel
139 Summary:        Header files for HDF5 Fortran APIs
140 Summary(pl.UTF-8):      Pliki nagłówkowe API Fortran bibliotek HDF5
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143 Requires:       %{name}-fortran = %{version}-%{release}
144 Requires:       gcc-fortran >= 6:4.2
145
146 %description fortran-devel
147 Module and header files for HDF5 Fortran APIs (both base hdf5 and
148 hdf5_hl).
149
150 %description fortran-devel -l pl.UTF-8
151 Moduły i pliki nagłówkowe API C++ bibliotek HDF5 (zarówno podstawowej
152 hdf5, jak i hdf5_hl).
153
154 %package fortran-static
155 Summary:        Fortran APIs for HDF5 - static libraries
156 Summary(pl.UTF-8):      API Fortran bibliotek HDF5 - biblioteki statyczne
157 Group:          Development/Libraries
158 Requires:       %{name}-fortran-devel = %{version}-%{release}
159
160 %description fortran-static
161 Fortran APIs for HDF5 (both base hdf5 and hdf5_hl) - static libraries.
162
163 %description fortran-static -l pl.UTF-8
164 API Fortran dla bibliotek HDF5 (zarówno podstawowej hdf5, jak i
165 hdf5_hl) - biblioteki statyczne.
166
167 %package progs
168 Summary:        HDF5 utilities
169 Summary(pl.UTF-8):      Narzędzia do plików HDF5
170 Group:          Applications/File
171 Requires:       %{name} = %{version}-%{release}
172
173 %description progs
174 Utilities to convert from/to HDF5 format.
175
176 %description progs -l pl.UTF-8
177 Narzędzia do konwersji z i to formatu HDF5.
178
179 %package -n java-hdf5
180 Summary:        Java HDF5 Interface (JHI5)
181 Summary(pl.UTF-8):      Interfejs HDF5 do Javy (JHI5)
182 # to replace java-hdf5 [0:]2.11/3.3.1 from hdf-java.spec
183 Epoch:          1
184 Group:          Libraries/Java
185 URL:            http://portal.hdfgroup.org/display/HDFVIEW/JHI5+Design+Notes
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       java-slf4j >= 1.7.25
188
189 %description -n java-hdf5
190 The Java Native Interface to the standard HDF5 library.
191
192 %description -n java-hdf5 -l pl.UTF-8
193 Natywny interfejs Javy (JNI) do biblioteki standardowej HDF5.
194
195 %package -n java-hdf5-javadoc
196 Summary:        Javadoc documentation for Java HDF5 Interface (JHI5)
197 Summary(pl.UTF-8):      Dokumentacja javadoc do interfejsu HDF5 do Javy (JHI5)
198 Epoch:          1
199 Group:          Documentation
200 URL:            http://portal.hdfgroup.org/display/HDFVIEW/JHI5+Design+Notes
201
202 %description -n java-hdf5-javadoc
203 Javadoc documentation for Java HDF5 Interface (JHI5).
204
205 %description -n java-hdf5-javadoc -l pl.UTF-8
206 Dokumentacja javadoc do interfejsu HDF5 do Javy (JHI5).
207
208 %prep
209 %setup -q
210 %patch0 -p1
211 %patch1 -p1
212 %patch2 -p1
213
214 %build
215 %{__libtoolize}
216 %{__aclocal}
217 %{__autoconf}
218 %{__autoheader}
219 %{__automake}
220 %configure \
221         --docdir=%{_docdir} \
222         --disable-silent-rules \
223         --enable-cxx \
224         --enable-direct-vfd \
225         --enable-fortran \
226         %{?with_java:--enable-java} \
227         %{?with_mpi:--enable-parallel --enable-unsupported} \
228         %{?with_s3:--enable-ros3-vfd} \
229         --enable-shared \
230         %{?with_hdfs:--with-libhdfs=%{_includedir},%{_libdir}} \
231         --with-pthread \
232         %{?with_szip:--with-szlib}
233
234 #       --enable-threadsafe is unspported with cxx/fortran/java/hl
235
236 %{__make}
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT%{_includedir}
241
242 %{__make} install-recursive \
243         DESTDIR=$RPM_BUILD_ROOT \
244         hdf5_javadir=%{_javadir}
245
246 %if %{with java}
247 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhdf5_java.la
248 ln -sf jarhdf5-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/jarhdf5.jar
249 install -d $RPM_BUILD_ROOT%{_javadocdir}
250 cp -pr java/src/javadoc $RPM_BUILD_ROOT%{_javadocdir}/hdf5lib
251 %endif
252
253 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
254 %{__make} -C examples install-examples \
255         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
256         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
257 %{__make} -C c++/examples install-examples \
258         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c++
259 %{__make} -C hl/examples install-examples \
260         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c \
261         EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl
262 %{__make} -C hl/c++/examples install-examples \
263         EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/hl/c++
264
265 install -d $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5
266 vmajor=$(sed -ne 's/^#define H5_VERS_MAJOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
267 vminor=$(sed -ne 's/^#define H5_VERS_MINOR\s*\([0-9]\+\).*/\1/p' src/H5public.h)
268 vrel=$(sed -ne 's/^#define H5_VERS_RELEASE\s*\([0-9]\+\).*/\1/p' src/H5public.h)
269 vsubr=$(sed -ne 's/^#define H5_VERS_SUBRELEASE\s*"\?\([^" \t]\+\)"\?.*/\1/p' src/H5public.h)
270 for f in hdf5-config-version.cmake hdf5-config.cmake hdf5-targets.cmake hdf5-targets-noconfig.cmake ; do
271         sed -e 's,@HDF5_PACKAGE@,hdf5,g' \
272             -e 's,@HDF_PACKAGE_EXT@,,' \
273             -e "s,@HDF5_VERSION_STRING@,%{version}," \
274             -e "s,@HDF5_VERSION_MAJOR@,1.10," \
275             -e "s,@HDF5_VERSION_MINOR@,$vrel," \
276             -e "s,@H5_VERS_MAJOR@,$vmajor," \
277             -e "s,@H5_VERS_MINOR@,$vminor," \
278             -e "s,@H5_VERS_RELEASE@,$vrel," \
279             -e "s,@H5_VERS_SUBRELEASE@,$vsubr," \
280             -e 's,@HDF5_ENABLE_PARALLEL@,OFF,' \
281             -e 's,@HDF5_BUILD_FORTRAN@,ON,' \
282             -e 's,@HDF5_BUILD_CPP_LIB@,ON,' \
283             -e 's,@HDF5_BUILD_TOOLS@,ON,' \
284             -e 's,@HDF5_BUILD_HL_LIB@,ON,' \
285             -e 's,@HDF5_ENABLE_Z_LIB_SUPPORT@,ON,' \
286             -e 's,@HDF5_ENABLE_SZIP_SUPPORT@,%{?with_szip:ON}%{!?with_szip:OFF},' \
287             -e 's,@HDF5_ENABLE_SZIP_ENCODING@,%{?with_szip:ON}%{!?with_szip:OFF},' \
288 %ifarch %{ix86} x32
289             -e 's,@CMAKE_SIZEOF_VOID_P@,4,' \
290 %else
291 %ifarch %{x8664}
292             -e 's,@CMAKE_SIZEOF_VOID_P@,8,' \
293 %endif
294 %endif
295             -e 's,@BUILD_SHARED_LIBS@,ON,' \
296             -e 's,@HDF5_PACKAGE_EXTLIBS@,OFF,' \
297             -e 's,@ZLIB_PACKAGE_NAME@,zlib,' \
298             -e 's,@SZIP_PACKAGE_NAME@,szip,' \
299             -e 's,@HDF5_LIBRARIES_TO_EXPORT@,hdf5,' \
300             -e 's,@CMAKE_GENERATOR_TOOLSET@,,' \
301             -e 's,@lib@,%{_lib},' \
302             %{?with_mpi:-e 's,@MPI_C_INCLUDE_PATH@,%{_includedir},'} \
303             %{?with_mpi:-e 's,@MPI_C_LIBRARIES@,%{_libdir},'} \
304             -e 's,@PACKAGE_INCLUDE_INSTALL_DIR@,%{_includedir},' \
305             -e 's,@PACKAGE_SHARE_INSTALL_DIR@,%{_libdir}/cmake/hdf5,' \
306             -e 's,@PACKAGE_CURRENT_BUILD_DIR@,%{_prefix},' \
307                 config/cmake/${f}.in > $RPM_BUILD_ROOT%{_libdir}/cmake/hdf5/$f
308 done
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %post   -p /sbin/ldconfig
314 %postun -p /sbin/ldconfig
315
316 %post   c++ -p /sbin/ldconfig
317 %postun c++ -p /sbin/ldconfig
318
319 %post   fortran -p /sbin/ldconfig
320 %postun fortran -p /sbin/ldconfig
321
322 %post   -n java-hdf5 -p /sbin/ldconfig
323 %postun -n java-hdf5 -p /sbin/ldconfig
324
325 %files
326 %defattr(644,root,root,755)
327 %doc COPYING README.md release_docs/{HISTORY*.txt,RELEASE.txt}
328 %attr(755,root,root) %{_libdir}/libhdf5.so.*.*.*
329 %attr(755,root,root) %ghost %{_libdir}/libhdf5.so.103
330 %attr(755,root,root) %{_libdir}/libhdf5_hl.so.*.*.*
331 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl.so.100
332 # used to show configuration at runtime
333 %{_libdir}/libhdf5.settings
334
335 %files devel
336 %defattr(644,root,root,755)
337 %attr(755,root,root) %{_bindir}/h5cc
338 %attr(755,root,root) %{_libdir}/libhdf5.so
339 %attr(755,root,root) %{_libdir}/libhdf5_hl.so
340 %{_libdir}/libhdf5.la
341 %{_libdir}/libhdf5_hl.la
342 %{_includedir}/H5ACpublic.h
343 %{_includedir}/H5Apublic.h
344 %{_includedir}/H5Cpublic.h
345 %{_includedir}/H5DOpublic.h
346 %{_includedir}/H5DSpublic.h
347 %{_includedir}/H5Dpublic.h
348 %{_includedir}/H5Epubgen.h
349 %{_includedir}/H5Epublic.h
350 %{_includedir}/H5FDcore.h
351 %{_includedir}/H5FDdirect.h
352 %{_includedir}/H5FDfamily.h
353 %{_includedir}/H5FDhdfs.h
354 %{_includedir}/H5FDlog.h
355 %{_includedir}/H5FDmirror.h
356 %{_includedir}/H5FDmpi.h
357 %{_includedir}/H5FDmpio.h
358 %{_includedir}/H5FDmulti.h
359 %{_includedir}/H5FDpublic.h
360 %{_includedir}/H5FDros3.h
361 %{_includedir}/H5FDsec2.h
362 %{_includedir}/H5FDsplitter.h
363 %{_includedir}/H5FDstdio.h
364 %{_includedir}/H5FDwindows.h
365 %{_includedir}/H5Fpublic.h
366 %{_includedir}/H5Gpublic.h
367 %{_includedir}/H5IMpublic.h
368 %{_includedir}/H5Include.h
369 %{_includedir}/H5Ipublic.h
370 %{_includedir}/H5LDpublic.h
371 %{_includedir}/H5LTpublic.h
372 %{_includedir}/H5Lpublic.h
373 %{_includedir}/H5MMpublic.h
374 %{_includedir}/H5Opublic.h
375 %{_includedir}/H5PTpublic.h
376 %{_includedir}/H5Ppublic.h
377 %{_includedir}/H5PLextern.h
378 %{_includedir}/H5PLpublic.h
379 %{_includedir}/H5Rpublic.h
380 %{_includedir}/H5Spublic.h
381 %{_includedir}/H5TBpublic.h
382 %{_includedir}/H5Tpublic.h
383 %{_includedir}/H5Zpublic.h
384 %{_includedir}/H5api_adpt.h
385 %{_includedir}/H5overflow.h
386 %{_includedir}/H5pubconf.h
387 %{_includedir}/H5public.h
388 %{_includedir}/H5version.h
389 %{_includedir}/hdf5.h
390 %{_includedir}/hdf5_hl.h
391
392 %{_libdir}/cmake/hdf5
393 %dir %{_examplesdir}/%{name}-%{version}
394 %{_examplesdir}/%{name}-%{version}/README
395 %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
396 %{_examplesdir}/%{name}-%{version}/c
397 %dir %{_examplesdir}/%{name}-%{version}/hl
398 %{_examplesdir}/%{name}-%{version}/hl/run-hl-ex.sh
399 %{_examplesdir}/%{name}-%{version}/hl/c
400
401 %files static
402 %defattr(644,root,root,755)
403 %{_libdir}/libhdf5.a
404 %{_libdir}/libhdf5_hl.a
405
406 %files c++
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so.*.*.*
409 %attr(755,root,root) %ghost %{_libdir}/libhdf5_cpp.so.103
410 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so.*.*.*
411 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_cpp.so.100
412
413 %files c++-devel
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_bindir}/h5c++
416 %attr(755,root,root) %{_libdir}/libhdf5_cpp.so
417 %attr(755,root,root) %{_libdir}/libhdf5_hl_cpp.so
418 %{_libdir}/libhdf5_cpp.la
419 %{_libdir}/libhdf5_hl_cpp.la
420 %{_includedir}/H5AbstractDs.h
421 %{_includedir}/H5ArrayType.h
422 %{_includedir}/H5AtomType.h
423 %{_includedir}/H5Attribute.h
424 %{_includedir}/H5Classes.h
425 %{_includedir}/H5CommonFG.h
426 %{_includedir}/H5CompType.h
427 %{_includedir}/H5Cpp.h
428 %{_includedir}/H5CppDoc.h
429 %{_includedir}/H5DaccProp.h
430 %{_includedir}/H5DataSet.h
431 %{_includedir}/H5DataSpace.h
432 %{_includedir}/H5DataType.h
433 %{_includedir}/H5DcreatProp.h
434 %{_includedir}/H5DxferProp.h
435 %{_includedir}/H5EnumType.h
436 %{_includedir}/H5Exception.h
437 %{_includedir}/H5FaccProp.h
438 %{_includedir}/H5FcreatProp.h
439 %{_includedir}/H5File.h
440 %{_includedir}/H5FloatType.h
441 %{_includedir}/H5Group.h
442 %{_includedir}/H5IdComponent.h
443 %{_includedir}/H5IntType.h
444 %{_includedir}/H5LaccProp.h
445 %{_includedir}/H5LcreatProp.h
446 %{_includedir}/H5Library.h
447 %{_includedir}/H5Location.h
448 %{_includedir}/H5Object.h
449 %{_includedir}/H5OcreatProp.h
450 %{_includedir}/H5PacketTable.h
451 %{_includedir}/H5PredType.h
452 %{_includedir}/H5PropList.h
453 %{_includedir}/H5StrType.h
454 %{_includedir}/H5VarLenType.h
455 %{_examplesdir}/%{name}-%{version}/c++
456 %{_examplesdir}/%{name}-%{version}/hl/c++
457
458 %files c++-static
459 %defattr(644,root,root,755)
460 %{_libdir}/libhdf5_cpp.a
461 %{_libdir}/libhdf5_hl_cpp.a
462
463 %files fortran
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_libdir}/libhdf5_fortran.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libhdf5_fortran.so.102
467 %attr(755,root,root) %{_libdir}/libhdf5hl_fortran.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libhdf5hl_fortran.so.100
469
470 %files fortran-devel
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{_bindir}/h5fc
473 %attr(755,root,root) %{_libdir}/libhdf5_fortran.so
474 %attr(755,root,root) %{_libdir}/libhdf5_hl_fortran.so
475 %attr(755,root,root) %{_libdir}/libhdf5hl_fortran.so
476 %{_libdir}/libhdf5_fortran.la
477 %{_libdir}/libhdf5hl_fortran.la
478 %{_includedir}/H5f90i.h
479 %{_includedir}/H5f90i_gen.h
480 %{_includedir}/h5_gen.mod
481 %{_includedir}/h5a.mod
482 %{_includedir}/h5d.mod
483 %{_includedir}/h5ds.mod
484 %{_includedir}/h5e.mod
485 %{_includedir}/h5f.mod
486 %{_includedir}/h5fortkit.mod
487 %{_includedir}/h5fortran_types.mod
488 %{_includedir}/h5g.mod
489 %{_includedir}/h5global.mod
490 %{_includedir}/h5i.mod
491 %{_includedir}/h5im.mod
492 %{_includedir}/h5l.mod
493 %{_includedir}/h5lib.mod
494 %{_includedir}/h5lt.mod
495 %{_includedir}/h5lt_const.mod
496 %{_includedir}/h5o.mod
497 %{_includedir}/h5p.mod
498 %{_includedir}/h5r.mod
499 %{_includedir}/h5s.mod
500 %{_includedir}/h5t.mod
501 %{_includedir}/h5tb.mod
502 %{_includedir}/h5tb_const.mod
503 %{_includedir}/h5z.mod
504 %{_includedir}/hdf5.mod
505
506 %files fortran-static
507 %defattr(644,root,root,755)
508 %{_libdir}/libhdf5_fortran.a
509 %{_libdir}/libhdf5_hl_fortran.a
510 %{_libdir}/libhdf5hl_fortran.a
511
512 %files progs
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/gif2h5
515 %attr(755,root,root) %{_bindir}/h52gif
516 %attr(755,root,root) %{_bindir}/h5clear
517 %attr(755,root,root) %{_bindir}/h5copy
518 %attr(755,root,root) %{_bindir}/h5debug
519 %attr(755,root,root) %{_bindir}/h5diff
520 %attr(755,root,root) %{_bindir}/h5dump
521 %attr(755,root,root) %{_bindir}/h5format_convert
522 %attr(755,root,root) %{_bindir}/h5import
523 %attr(755,root,root) %{_bindir}/h5jam
524 %attr(755,root,root) %{_bindir}/h5ls
525 %attr(755,root,root) %{_bindir}/h5mkgrp
526 %attr(755,root,root) %{_bindir}/h5perf_serial
527 %attr(755,root,root) %{_bindir}/h5redeploy
528 %attr(755,root,root) %{_bindir}/h5repack
529 %attr(755,root,root) %{_bindir}/h5repart
530 %attr(755,root,root) %{_bindir}/h5stat
531 %attr(755,root,root) %{_bindir}/h5unjam
532 %attr(755,root,root) %{_bindir}/h5watch
533
534 %if %{with java}
535 %files -n java-hdf5
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/libhdf5_java.so.100.7.0
538 %attr(755,root,root) %ghost %{_libdir}/libhdf5_java.so.100
539 %attr(755,root,root) %{_libdir}/libhdf5_java.so
540 %{_javadir}/jarhdf5-%{version}.jar
541 %{_javadir}/jarhdf5.jar
542
543 %files -n java-hdf5-javadoc
544 %defattr(644,root,root,755)
545 %{_javadocdir}/hdf5lib
546 %endif
This page took 0.146158 seconds and 3 git commands to generate.