]> git.pld-linux.org Git - packages/hatari.git/commitdiff
- up to 1.4.0
authorlisu <lisu@pld-linux.org>
Mon, 14 Jun 2010 13:25:20 +0000 (13:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- switch to cmake build system (TODO)
- patches updated

Changed files:
    hatari-desktop.patch -> 1.2
    hatari-useless_files.patch -> 1.5
    hatari.spec -> 1.20

hatari-desktop.patch
hatari-useless_files.patch
hatari.spec

index 1d6ce5e207e5f0bd37e0616ba7d81b7525c54d15..ffa536f5ee04dcebb11610de254370e26d0184f6 100644 (file)
@@ -8,5 +8,5 @@
  Name=Hatari UI
  Exec=hatariui
  Icon=hatari-icon
-+Categories=Application;Game;
++Categories=Utility;Emulator;
 +# vi: encoding=utf-8
index e55b8eb7fcd39c797e5dcdde1d2a641d306e9065..6f846c97ccce1639f80070b167d3e64dba5eb756 100644 (file)
@@ -1,29 +1,21 @@
---- hatari-1.3.1/Makefile~     2009-09-05 00:52:41.000000000 +0200
-+++ hatari-1.3.1/Makefile      2009-09-08 12:33:20.000000000 +0200
-@@ -61,8 +61,6 @@
-       $(INSTALL) -d $(DESTDIR)$(BINDIR)
-       $(INSTALL) -d $(DESTDIR)$(DATADIR)
-       $(INSTALL) -d $(DESTDIR)$(MANDIR)
--      $(INSTALL) -d $(DESTDIR)$(DOCDIR)
--      $(INSTALL) -d $(DESTDIR)$(DOCDIR)/images
-       $(INSTALL_PROGRAM) src/hatari $(DESTDIR)$(BINDIR)/hatari
-       $(INSTALL_PROGRAM) tools/hmsa/hmsa $(DESTDIR)$(BINDIR)/hmsa
-       $(INSTALL_SCRIPT) tools/zip2st.sh $(DESTDIR)$(BINDIR)/zip2st
-@@ -71,6 +69,4 @@
-         $(INSTALL_DATA) src/tos.img $(DESTDIR)$(DATADIR)/tos.img ; \
-       fi
-       $(INSTALL_DATA) hatari.1.gz $(DESTDIR)$(MANDIR)/
--      $(INSTALL_DATA) doc/*.txt doc/*.html $(DESTDIR)$(DOCDIR)/
--      $(INSTALL_DATA) doc/images/*.png $(DESTDIR)$(DOCDIR)/images/
-       $(MAKE) -C python-ui/ install
---- hatari-1.3.1/python-ui/Makefile~   2009-09-08 12:32:43.000000000 +0200
-+++ hatari-1.3.1/python-ui/Makefile    2009-09-08 12:34:19.000000000 +0200
-@@ -25,7 +25,7 @@
-       $(INSTALL) -d $(DESTDIR)$(DATAPATH)
-       $(INSTALL_SCRIPT) hatariui.py debugui.py $(DESTDIR)$(DATAPATH)/
-       $(INSTALL_DATA) config.py dialogs.py hatari.py uihelpers.py $(DESTDIR)$(DATAPATH)/
--      $(INSTALL_DATA) README TODO Changelog *.png $(DESTDIR)$(DATAPATH)/
-+      $(INSTALL_DATA) *.png $(DESTDIR)$(DATAPATH)/
-       $(INSTALL) -d $(DESTDIR)$(ICONPATH)
-       $(INSTALL_DATA) hatari-icon.png $(DESTDIR)$(ICONPATH)/
-       $(INSTALL) -d $(DESTDIR)$(DESKPATH)
+--- hatari-1.4.0/CMakeLists.txt~       2010-06-12 13:04:40.000000000 +0200
++++ hatari-1.4.0/CMakeLists.txt        2010-06-14 15:05:28.646457915 +0200
+@@ -180,10 +180,6 @@
+       set(MANDIR share/man/man1)
+ endif()
+-if(NOT DOCDIR)
+-      set(DOCDIR share/doc/hatari)
+-endif()
+-
+ # #########################################
+ # Create config.h and recurse into subdirs:
+ # #########################################
+@@ -192,7 +188,6 @@
+               ${CMAKE_BINARY_DIR}/config.h)
+ add_subdirectory(src)
+-add_subdirectory(doc)
+ add_subdirectory(tools)
+ include(FindPythonInterp)
index 74b6a36130ea7c29c8885d588161bf5e6d895c9d..26e6be53815e3655267a7fc24b272567812c34a6 100644 (file)
@@ -1,19 +1,21 @@
+#
+# TODO: try to pass our CFLAGS and LDFLAGS
+#
 Summary:       hatari - an Atari ST and STE emulator for Linux
 Summary(pl.UTF-8):     hatari - emulator Atari ST i STE dla Linuksa
 Name:          hatari
-Version:       1.3.1
+Version:       1.4.0
 Release:       1
 License:       GPL v2+
 Group:         Applications/Emulators
 Source0:       http://download.berlios.de/hatari/%{name}-%{version}.tar.bz2
-# Source0-md5: 112b544ec4affb7c04e931088e62a115
+# Source0-md5: 2f30e5c9e146ee92e3f2f5ae1cef3673
 Patch0:                %{name}-useless_files.patch
 Patch1:                %{name}-python_init.patch
 Patch2:                %{name}-desktop.patch
 URL:           http://hatari.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.0
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: cmake
 BuildRequires: libpng-devel
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
@@ -31,31 +33,34 @@ of most of the ST and STE hardware.
 
 %description -l pl.UTF-8
 Hatari jest emulatorem Atari ST i STE dla Linuksa i innych systemów
-obsługiwanych przez bibliotekę SDL. Hatari emuluje większość
-sprzętu Atari ST i STE.
+obsługiwanych przez bibliotekę SDL. Hatari emuluje większość sprzętu
+Atari ST i STE.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%{__sed} -i 's#path=$(DATAPATH)#path=%{_datadir}/hatari/hatariui#' python-ui/Makefile
 
 %build
-%{__aclocal}
-%{__autoconf}
-%configure \
-       --datadir=%{_datadir}/%{name}
+install -d build
+cd build
+%cmake .. \
+       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
+       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+%if "%{_lib}" == "lib64"
+       -DLIB_SUFFIX=64
+%endif
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/{,fr}/man1}
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install doc/hatari.1   $RPM_BUILD_ROOT%{_mandir}/man1/hatari.1
 install doc/fr/hatari.1        $RPM_BUILD_ROOT%{_mandir}/fr/man1
 
 %clean
@@ -63,10 +68,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc readme.txt doc/*.txt python-ui/{Changelog,README,TODO}
+%doc readme.txt doc/*.txt python-ui/{README,TODO}
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/%{name}
-%{_mandir}/man1/hatari.1*
+%{_mandir}/man1/hatari*.1*
 %lang(fr) %{_mandir}/fr/man1/hatari.1*
 %{_desktopdir}/hatariui.desktop
 %{_iconsdir}/hicolor/32x32/apps/hatari-icon.png
This page took 0.085421 seconds and 4 git commands to generate.