]> git.pld-linux.org Git - packages/hatari.git/commitdiff
- Reverted removal of python-init patch, just corrected it.
authorŁukasz Maśko <lmasko@pld-linux.org>
Sat, 7 Nov 2015 21:24:27 +0000 (22:24 +0100)
committerŁukasz Maśko <lmasko@pld-linux.org>
Sat, 7 Nov 2015 21:24:27 +0000 (22:24 +0100)
hatari-python_init.patch [new file with mode: 0644]
hatari.spec

diff --git a/hatari-python_init.patch b/hatari-python_init.patch
new file mode 100644 (file)
index 0000000..634af01
--- /dev/null
@@ -0,0 +1,33 @@
+--- hatari-1.5.0/python-ui/hatariui.orig       2011-07-19 00:32:26.000000000 +0200
++++ hatari-1.5.0/python-ui/hatariui    2011-07-23 10:05:56.946083979 +0200
+@@ -6,7 +6,7 @@
+ path=${0%/*}
+ name=${0##*/}
+-if [ ! -e $path/$name.py ]; then
++if [ ! -e $path/$name.pyc ]; then
+       # Assume package has been relocated, try relative data directory:
+       path=${0%/*}/../share/hatari/hatariui
+ fi
+@@ -20,18 +20,18 @@
+ export HATARI_SYSTEM_CONFDIR=$conf
+ # example setup for Hatari UI
+-$path/$name.py --right "about,|,run,pause,forward,|,reset,|,quit" --embed $*
++python $path/$name.pyc --right "about,|,run,pause,forward,|,reset,|,quit" --embed $*
+ exit 0
+ # test setup without embedding, duplicate toggles
+-$path/$name.py --top "about,run,pause,quit" \
++python $path/$name.pyc --top "about,run,pause,quit" \
+ --panel "Testpanel,pause,>,close" \
+ --bottom "sound,|,forward,pause,|,Testpanel" \
+ $*
+ exit 0
+ # test setup with embedding and all available controls
+-$path/$name.py --embed \
++python $path/$name.pyc --embed \
+ --top "about,|,run,pause,|,reset,debug,|,quit" \
+ --left "run,pause,reset,machine,about" \
+ --panel "Keys,F1=59,F2=60,F3=61,F4=62,F5=63,F6=64,F7=65,F8=66,F9=67,F10=68,>,Macro=Test,Undo=97,Help=98,Enter=114,>,close" \
index 308f993620fb39370cead8b0126fbb76984a6e3b..2f06cec6807b94a36273e0707901411a7ec9c445 100644 (file)
@@ -8,6 +8,7 @@ Group:          Applications/Emulators
 Source0:       http://download.tuxfamily.org/hatari/%{version}/%{name}-%{version}.tar.bz2
 # Source0-md5: 24e54b19958943dbe5ac1b1f6f32b284
 Patch0:                %{name}-useless_files.patch
+Patch1:                %{name}-python_init.patch
 URL:           http://hatari.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: cmake >= 2.6
@@ -38,6 +39,7 @@ Atari ST i STE.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 sed -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' python-ui/*.py tools/hconsole/*.py
 
This page took 0.069157 seconds and 4 git commands to generate.