]> git.pld-linux.org Git - packages/handbrake.git/blob - handbrake.spec
add binutils 2.41 patch for embedded ffmpeg
[packages/handbrake.git] / handbrake.spec
1 Summary:        A program to transcode DVDs and other sources to MPEG-4 and MKV
2 Name:           handbrake
3 Version:        1.4.1
4 Release:        2
5 License:        GPL v2+
6 Group:          Applications/Multimedia
7 Source0:        https://github.com/HandBrake/HandBrake/releases/download/%{version}/HandBrake-%{version}-source.tar.bz2
8 # Source0-md5:  73fe8df8340ac7b7c23a8c09974d6906
9 # Source1 is a tarball of the downloads/ folder that contains third party
10 # libraries required and automatically downloaded by HandBrake the first
11 # time 'make' is run. If you update Source0 to a newer release you must
12 # recreate an updated Source1 tarball for it too!
13 Source1:        HandBrake-%{version}-contrib-tarballs.tar
14 # Source1-md5:  11691c785ee60b58651c5405eeeb5f22
15 Patch0:         binutils2.41.patch
16 URL:            https://handbrake.fr/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 BuildRequires:  cmake
21 BuildRequires:  curl-devel
22 BuildRequires:  dbus-glib-devel
23 BuildRequires:  fontconfig-devel
24 BuildRequires:  freetype-devel
25 BuildRequires:  fribidi-devel
26 BuildRequires:  glib2-devel
27 BuildRequires:  gstreamer-devel
28 BuildRequires:  gstreamer-plugins-base-devel
29 BuildRequires:  gtk+3-devel
30 BuildRequires:  gtk-webkit3-devel
31 BuildRequires:  harfbuzz-devel
32 BuildRequires:  intltool
33 BuildRequires:  jansson-devel
34 BuildRequires:  lame-libs-devel
35 BuildRequires:  libass-devel
36 BuildRequires:  libnotify-devel
37 BuildRequires:  libogg-devel
38 BuildRequires:  libsamplerate-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtheora-devel
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel
43 BuildRequires:  libx264-devel
44 BuildRequires:  libxml2-devel
45 BuildRequires:  m4
46 BuildRequires:  opus-devel
47 BuildRequires:  pkgconfig
48 BuildRequires:  python
49 BuildRequires:  subversion
50 BuildRequires:  udev-glib-devel
51 BuildRequires:  yasm
52 BuildRequires:  zlib-devel
53 BuildConflicts: libudfread-devel
54 ExclusiveArch:  %{x8664}
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _debugsource_packages   0
58
59 %description
60 HandBrake is an open-source, GPL-licensed, multi-platform,
61 multi-threaded transcoder, available for MacOS X, Linux and Windows.
62
63 %package gui
64 Summary:        A program to transcode DVDs and other sources to MPEG-4 and MKV
65 Group:          Applications/Multimedia
66 Requires:       gstreamer-plugins-bad
67 Requires:       gstreamer-plugins-ugly
68 Requires:       gtk+3
69 Requires:       libdvdcss
70 Obsoletes:      HandBrake
71 Obsoletes:      handbrake
72
73 %package cli
74 Summary:        A program to transcode DVDs and other sources to MPEG-4 and MKV
75 Group:          Applications/Multimedia
76 Requires:       gtk-update-icon-cache
77 Requires:       libdvdcss
78 Obsoletes:      HandBrake
79 Obsoletes:      handbrake
80
81 %description gui
82 HandBrake is an open-source, GPL-licensed, multi-platform,
83 multi-threaded transcoder, available for MacOS X, Linux and Windows.
84
85 This is the GTK GUI version of HandBrake.
86
87 %description cli
88 HandBrake is an open-source, GPL-licensed, multi-platform,
89 multi-threaded transcoder, available for MacOS X, Linux and Windows.
90
91 This is the CLI tool version of HandBrake.
92
93 %prep
94 %setup -q -n HandBrake-%{version} -a1
95
96 cp -p %{PATCH0} contrib/ffmpeg/A77-%{basename:%{PATCH0}}
97
98 %build
99 export CFLAGS="%{rpmcflags}"
100 export CXXFLAGS="%{rpmcxxflags}"
101 export LDFLAGS="%{rpmldflags}"
102 ./configure \
103         --force \
104         --prefix=%{_prefix} \
105         --disable-df-fetch
106
107 cat > build/GNUmakefile.custom.defs <<EOF
108 STRIP.exe = /bin/true
109 BUILD.jobs = %{__jobs}
110 GCC.args.g.none = %{rpmcflags}
111 GCC.args.O.speed = %{rpmcflags}
112 EOF
113
114 %{__make} -C build
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 cat > build/GNUmakefile.custom.defs <<EOF
119 STRIP.exe = /bin/true
120 CONF.args = --prefix=$RPM_BUILD_ROOT%{_prefix}
121 PREFIX    = $RPM_BUILD_ROOT%{_prefix}
122 PREFIX/   = $RPM_BUILD_ROOT%{_prefix}/
123 EOF
124 %{__make} -C build install
125
126 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
127
128 %{__mv} $RPM_BUILD_ROOT%{_localedir}/sl{_SI,}
129 %{__mv} $RPM_BUILD_ROOT%{_localedir}/uk{_UA,}
130 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{no,nb}
131
132 %find_lang ghb
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post gui
138 %update_icon_cache hicolor
139
140 %postun gui
141 %update_icon_cache hicolor
142
143 %files gui -f ghb.lang
144 %defattr(644,root,root,755)
145 %doc COPYING AUTHORS.markdown NEWS.markdown README.markdown THANKS.markdown
146 %attr(755,root,root) %{_bindir}/ghb
147 %{_desktopdir}/fr.handbrake.ghb.desktop
148 %{_iconsdir}/hicolor/scalable/apps/hb-icon.svg
149 %{_iconsdir}/hicolor/scalable/apps/fr.handbrake.ghb.svg
150 %{_datadir}/metainfo/fr.handbrake.ghb.metainfo.xml
151
152 %files cli
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/HandBrakeCLI
This page took 0.074706 seconds and 3 git commands to generate.