]> git.pld-linux.org Git - packages/gxml.git/blob - gxml.spec
fac9dd3e72da99cc9361e3323643b5915c96ab78
[packages/gxml.git] / gxml.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # API documentation [doesn't build up to 0.8.0 release]
4 %bcond_without  static_libs     # static library
5
6 Summary:        GXml - GObject API that wraps around libxml2
7 Summary(pl.UTF-8):      GXml - API GObject obudowujące libxml2
8 Name:           gxml
9 Version:        0.8.2
10 Release:        2
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gxml/0.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  77af0fb4e1e178b60fc898b8beeaabfe
15 URL:            https://github.com/GNOME/gxml
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-tools >= 0.18.1
19 BuildRequires:  glib2-devel >= 1:2.32.0
20 BuildRequires:  gobject-introspection-devel >= 1.32.0
21 BuildRequires:  intltool >= 0.35.0
22 BuildRequires:  libgee-devel >= 0.10.5
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  libxml2-devel >= 1:2.7
25 BuildRequires:  pkgconfig >= 1:0.21
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  vala >= 2:0.26
29 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
30 BuildRequires:  xz
31 BuildRequires:  yelp-tools
32 Requires:       glib2 >= 1:2.32.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GXml is a GObject API that wraps around libxml2.
37
38 %description -l pl.UTF-8
39 GXml to API GObject obudowujące libxml2.
40
41 %package devel
42 Summary:        Header files for GXml library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GXml
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.32.0
47 Requires:       libgee-devel >= 0.10.5
48 Requires:       libxml2-devel >= 1:2.7
49
50 %description devel
51 Header files for GXml library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki GXml.
55
56 %package static
57 Summary:        Static GXml library
58 Summary(pl.UTF-8):      Statyczna biblioteka GXml
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static GXml library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka GXml.
67
68 %package -n vala-gxml
69 Summary:        Vala API for GXml library
70 Summary(pl.UTF-8):      API języka Vala dla biblioteki GXml
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73 Requires:       vala >= 2:0.26
74 Requires:       vala-libgee >= 0.10.5
75 %if "%{_rpmversion}" >= "5"
76 BuildArch:      noarch
77 %endif
78
79 %description -n vala-gxml
80 Vala API for GXml library.
81
82 %description -n vala-gxml -l pl.UTF-8
83 API języka Vala dla biblioteki GXml.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__intltoolize}
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --enable-gi-system-install \
97         --disable-silent-rules \
98         %{?with_static_libs:--enable-static} \
99         %{?with_apidocs:--enable-docs --enable-gtk-docs --enable-valadoc}
100 # --enable-gir-docs --enable-devhelp-docs ???
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # obsoleted by pkg-config
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.6.la
111 # packaged as %doc
112 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
113
114 %find_lang GXml
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files -f GXml.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README
125 %attr(755,root,root) %{_libdir}/libgxml-0.6.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libgxml-0.6.so.8
127 %{_libdir}/girepository-1.0/GXml-0.6.typelib
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libgxml-0.6.so
132 %{_includedir}/gxml-0.6
133 %{_datadir}/gir-1.0/GXml-0.6.gir
134 %{_pkgconfigdir}/gxml-0.6.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libgxml-0.6.a
140 %endif
141
142 %files -n vala-gxml
143 %defattr(644,root,root,755)
144 %{_datadir}/vala/vapi/gxml-0.6.deps
145 %{_datadir}/vala/vapi/gxml-0.6.vapi
This page took 0.051816 seconds and 2 git commands to generate.