]> git.pld-linux.org Git - packages/gxml.git/blob - gxml.spec
- added normalize patch (normalize cheader path in .vapi file to fix debuginfo extrac...
[packages/gxml.git] / gxml.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5
6 Summary:        GXml - GObject API that wraps around libxml2
7 Summary(pl.UTF-8):      GXml - API GObject obudowujące libxml2
8 Name:           gxml
9 Version:        0.10.0
10 Release:        2
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gxml/0.10/%{name}-%{version}.tar.xz
14 # Source0-md5:  a268a60a6bc9fbad3f0fd580a0a93538
15 Patch0:         %{name}-bug770449.patch
16 Patch1:         %{name}-missing.patch
17 Patch2:         %{name}-docs.patch
18 Patch3:         %{name}-normalize.patch
19 URL:            https://github.com/GNOME/gxml
20 BuildRequires:  autoconf >= 2.65
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  gettext-tools >= 0.18.1
23 BuildRequires:  glib2-devel >= 1:2.32.0
24 BuildRequires:  gobject-introspection-devel >= 1.32.0
25 BuildRequires:  intltool >= 0.35.0
26 BuildRequires:  libgee-devel >= 0.10.5
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  libxml2-devel >= 1:2.7
29 BuildRequires:  pkgconfig >= 1:0.21
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  vala >= 2:0.26
33 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
34 BuildRequires:  xz
35 BuildRequires:  yelp-tools
36 Requires:       glib2 >= 1:2.32.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 GXml is a GObject API that wraps around libxml2.
41
42 %description -l pl.UTF-8
43 GXml to API GObject obudowujące libxml2.
44
45 %package devel
46 Summary:        Header files for GXml library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GXml
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       glib2-devel >= 1:2.32.0
51 Requires:       libgee-devel >= 0.10.5
52 Requires:       libxml2-devel >= 1:2.7
53
54 %description devel
55 Header files for GXml library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki GXml.
59
60 %package static
61 Summary:        Static GXml library
62 Summary(pl.UTF-8):      Statyczna biblioteka GXml
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static GXml library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka GXml.
71
72 %package -n vala-gxml
73 Summary:        Vala API for GXml library
74 Summary(pl.UTF-8):      API języka Vala dla biblioteki GXml
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Requires:       vala >= 2:0.26
78 Requires:       vala-libgee >= 0.10.5
79 %if "%{_rpmversion}" >= "5"
80 BuildArch:      noarch
81 %endif
82
83 %description -n vala-gxml
84 Vala API for GXml library.
85
86 %description -n vala-gxml -l pl.UTF-8
87 API języka Vala dla biblioteki GXml.
88
89 %package apidocs
90 Summary:        API documentation for GXml library
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki GXml
92 Group:          Documentation
93
94 %description apidocs
95 API documentation for GXml library.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API biblioteki GXml.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106
107 %build
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --disable-silent-rules \
116         %{?with_static_libs:--enable-static} \
117         %{?with_apidocs:--enable-docs --enable-gtk-docs --enable-valadoc}
118 # --enable-devhelp-docs is almost the same as gtk-docs html, but built with valadoc(?) and installed to devhelp dirs
119 # --enable-gir-docs ???
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         gxmlgtkdocdir=%{_gtkdocdir}/gxml
128
129 # obsoleted by pkg-config
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.10.la
131 # packaged as %doc
132 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
133
134 # what a mess... gtk-doc XML intermediate files are installed to html dir...
135 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/gxml/*.{bottom,top,stamp,txt,types,xml}
136 cp -p docs/valadoc/gtk-doc/gtk-doc/gxml/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/gxml
137
138 # "GXml" gettext domain, "gxml" gnome help
139 %find_lang GXml --with-gnome --all-name
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files -f GXml.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog NEWS README
150 %attr(755,root,root) %{_libdir}/libgxml-0.10.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libgxml-0.10.so.10
152 %{_libdir}/girepository-1.0/GXml-0.10.typelib
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libgxml-0.10.so
157 %{_includedir}/gxml-0.10
158 %{_datadir}/gir-1.0/GXml-0.10.gir
159 %{_pkgconfigdir}/gxml-0.10.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libgxml-0.10.a
165 %endif
166
167 %files -n vala-gxml
168 %defattr(644,root,root,755)
169 %{_datadir}/vala/vapi/gxml-0.10.deps
170 %{_datadir}/vala/vapi/gxml-0.10.vapi
171
172 %if %{with apidocs}
173 %files apidocs
174 %defattr(644,root,root,755)
175 %{_gtkdocdir}/gxml
176 %endif
This page took 0.057442 seconds and 3 git commands to generate.