]> git.pld-linux.org Git - packages/gxml.git/blob - gxml.spec
- updated to 0.10.0 (note: new soname and API version)
[packages/gxml.git] / gxml.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5
6 Summary:        GXml - GObject API that wraps around libxml2
7 Summary(pl.UTF-8):      GXml - API GObject obudowujące libxml2
8 Name:           gxml
9 Version:        0.10.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gxml/0.10/%{name}-%{version}.tar.xz
14 # Source0-md5:  a268a60a6bc9fbad3f0fd580a0a93538
15 Patch0:         %{name}-bug770449.patch
16 Patch1:         %{name}-missing.patch
17 Patch2:         %{name}-docs.patch
18 URL:            https://github.com/GNOME/gxml
19 BuildRequires:  autoconf >= 2.65
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  gettext-tools >= 0.18.1
22 BuildRequires:  glib2-devel >= 1:2.32.0
23 BuildRequires:  gobject-introspection-devel >= 1.32.0
24 BuildRequires:  intltool >= 0.35.0
25 BuildRequires:  libgee-devel >= 0.10.5
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  libxml2-devel >= 1:2.7
28 BuildRequires:  pkgconfig >= 1:0.21
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  vala >= 2:0.26
32 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
33 BuildRequires:  xz
34 BuildRequires:  yelp-tools
35 Requires:       glib2 >= 1:2.32.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GXml is a GObject API that wraps around libxml2.
40
41 %description -l pl.UTF-8
42 GXml to API GObject obudowujące libxml2.
43
44 %package devel
45 Summary:        Header files for GXml library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GXml
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glib2-devel >= 1:2.32.0
50 Requires:       libgee-devel >= 0.10.5
51 Requires:       libxml2-devel >= 1:2.7
52
53 %description devel
54 Header files for GXml library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki GXml.
58
59 %package static
60 Summary:        Static GXml library
61 Summary(pl.UTF-8):      Statyczna biblioteka GXml
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static GXml library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka GXml.
70
71 %package -n vala-gxml
72 Summary:        Vala API for GXml library
73 Summary(pl.UTF-8):      API języka Vala dla biblioteki GXml
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76 Requires:       vala >= 2:0.26
77 Requires:       vala-libgee >= 0.10.5
78 %if "%{_rpmversion}" >= "5"
79 BuildArch:      noarch
80 %endif
81
82 %description -n vala-gxml
83 Vala API for GXml library.
84
85 %description -n vala-gxml -l pl.UTF-8
86 API języka Vala dla biblioteki GXml.
87
88 %package apidocs
89 Summary:        API documentation for GXml library
90 Summary(pl.UTF-8):      Dokumentacja API biblioteki GXml
91 Group:          Documentation
92
93 %description apidocs
94 API documentation for GXml library.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API biblioteki GXml.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104
105 %build
106 %{__intltoolize}
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --disable-silent-rules \
114         %{?with_static_libs:--enable-static} \
115         %{?with_apidocs:--enable-docs --enable-gtk-docs --enable-valadoc}
116 # --enable-devhelp-docs is almost the same as gtk-docs html, but built with valadoc(?) and installed to devhelp dirs
117 # --enable-gir-docs ???
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         gxmlgtkdocdir=%{_gtkdocdir}/gxml
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.10.la
129 # packaged as %doc
130 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
131
132 # what a mess... gtk-doc XML intermediate files are installed to html dir...
133 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/gxml/*.{bottom,top,stamp,txt,types,xml}
134 cp -p docs/valadoc/gtk-doc/gtk-doc/gxml/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/gxml
135
136 # "GXml" gettext domain, "gxml" gnome help
137 %find_lang GXml --with-gnome --all-name
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files -f GXml.lang
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog NEWS README
148 %attr(755,root,root) %{_libdir}/libgxml-0.10.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libgxml-0.10.so.10
150 %{_libdir}/girepository-1.0/GXml-0.10.typelib
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libgxml-0.10.so
155 %{_includedir}/gxml-0.10
156 %{_datadir}/gir-1.0/GXml-0.10.gir
157 %{_pkgconfigdir}/gxml-0.10.pc
158
159 %if %{with static_libs}
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/libgxml-0.10.a
163 %endif
164
165 %files -n vala-gxml
166 %defattr(644,root,root,755)
167 %{_datadir}/vala/vapi/gxml-0.10.deps
168 %{_datadir}/vala/vapi/gxml-0.10.vapi
169
170 %if %{with apidocs}
171 %files apidocs
172 %defattr(644,root,root,755)
173 %{_gtkdocdir}/gxml
174 %endif
This page took 0.087578 seconds and 3 git commands to generate.