]> git.pld-linux.org Git - packages/gxml.git/blob - gxml.spec
- updated to 0.14.3
[packages/gxml.git] / gxml.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5
6 Summary:        GXml - GObject API that wraps around libxml2
7 Summary(pl.UTF-8):      GXml - API GObject obudowujące libxml2
8 Name:           gxml
9 Version:        0.14.3
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gxml/0.14/%{name}-%{version}.tar.xz
14 # Source0-md5:  1c30d72ca8b7294072268ca125c9a50b
15 Patch0:         %{name}-normalize.patch
16 URL:            https://github.com/GNOME/gxml
17 BuildRequires:  autoconf >= 2.65
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  gettext-tools >= 0.18.1
20 BuildRequires:  glib2-devel >= 1:2.32.0
21 BuildRequires:  gobject-introspection-devel >= 1.32.0
22 BuildRequires:  intltool >= 0.35.0
23 BuildRequires:  libgee-devel >= 0.18.0
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  libxml2-devel >= 1:2.7
26 BuildRequires:  pkgconfig >= 1:0.21
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  vala >= 2:0.34.6
30 %{?with_apidocs:BuildRequires:  valadoc >= 0.30}
31 BuildRequires:  xz
32 BuildRequires:  yelp-tools
33 Requires:       glib2 >= 1:2.32.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GXml is a GObject API that wraps around libxml2.
38
39 %description -l pl.UTF-8
40 GXml to API GObject obudowujące libxml2.
41
42 %package devel
43 Summary:        Header files for GXml library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GXml
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 1:2.32.0
48 Requires:       libgee-devel >= 0.18.0
49 Requires:       libxml2-devel >= 1:2.7
50
51 %description devel
52 Header files for GXml library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki GXml.
56
57 %package static
58 Summary:        Static GXml library
59 Summary(pl.UTF-8):      Statyczna biblioteka GXml
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GXml library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka GXml.
68
69 %package -n vala-gxml
70 Summary:        Vala API for GXml library
71 Summary(pl.UTF-8):      API języka Vala dla biblioteki GXml
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74 Requires:       vala >= 2:0.34.6
75 Requires:       vala-libgee >= 0.18.0
76 %if "%{_rpmversion}" >= "5"
77 BuildArch:      noarch
78 %endif
79
80 %description -n vala-gxml
81 Vala API for GXml library.
82
83 %description -n vala-gxml -l pl.UTF-8
84 API języka Vala dla biblioteki GXml.
85
86 %package apidocs
87 Summary:        API documentation for GXml library
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki GXml
89 Group:          Documentation
90
91 %description apidocs
92 API documentation for GXml library.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki GXml.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 %{__intltoolize}
103 %{__libtoolize}
104 %{__aclocal} -I m4
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         %{!?with_apidocs:--disable-docs} \
110         --disable-silent-rules \
111         %{?with_static_libs:--enable-static}
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         gxmlgtkdocdir=%{_gtkdocdir}/gxml
121
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.14.la
124 # packaged as %doc
125 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
126
127 # what a mess... gtk-doc XML intermediate files are installed to html dir...
128 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/gxml/*.{bottom,top,stamp,txt,types,xml}
129 cp -p docs/valadoc/gtk-doc/gtk-doc/gxml/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/gxml
130
131 # similar to gtk-doc?
132 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/devhelp
133
134 # "GXml" gettext domain, "gxml" gnome help
135 %find_lang GXml --with-gnome --all-name
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f GXml.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README
146 %attr(755,root,root) %{_libdir}/libgxml-0.14.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libgxml-0.14.so.14
148 %{_libdir}/girepository-1.0/GXml-0.14.typelib
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libgxml-0.14.so
153 %{_includedir}/gxml-0.14
154 %{_datadir}/gir-1.0/GXml-0.14.gir
155 %{_pkgconfigdir}/gxml-0.14.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libgxml-0.14.a
161 %endif
162
163 %files -n vala-gxml
164 %defattr(644,root,root,755)
165 %{_datadir}/vala/vapi/gxml-0.14.deps
166 %{_datadir}/vala/vapi/gxml-0.14.vapi
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/gxml
172 %endif
This page took 0.12015 seconds and 3 git commands to generate.